E90Post
 


Extreme Powerhouse
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > 2E7C and BSD issues



Reply
 
Thread Tools Search this Thread
      Yesterday, 10:18 PM   #1
lowrydr310
Robot
181
Rep
621
Posts

Drives: 06 325i
Join Date: Apr 2013
Location: Los Angeles

iTrader: (0)

2E7C and BSD issues

I went to check my oil level and it read INACTIVE on the central display, however iDrive still reported my oil level with no errors. I scanned DME errors with INPA and found a 2E7C BSD data bus error code, along with several other codes all related to the BSD bus (alternator, water pump, DME, IBS). I cleared everything but the 2E7C remains.

I haven't had any issues with this before. My 9 year old battery wasn't holding a charge any more so I replaced it and registered it recently (and yes it's the same 90AH capacity as the old battery I replaced, so I didn't need to change that). The BSD issues just started after this recent battery change.

I'm going to inspect and clean the connector on the alternator, IBS connector, and the oil level sensor connector. Is there anything else I should be looking at?

I did replace my alternator over a year ago with a generic Taiwan manufactured one and didn't have any issues. I kept my Valeo alternator and I'm going to finish rebuilding it this weekend with new slip rings, brushes, and bearings.
Appreciate 0
      Today, 12:11 AM   #2
gbalthrop
Major
585
Rep
1,462
Posts

Drives: 2007 328xi E91
Join Date: May 2017
Location: Fairfax County, Virginia

iTrader: (0)

Quote:
Originally Posted by lowrydr310 View Post
I went to check my oil level and it read INACTIVE...2E7C BSD data bus error code, along with several other codes all related to the BSD bus (alternator, water pump, DME, IBS). I cleared everything but the 2E7C remains... The BSD issues just started after this recent battery change...
With codes for ALL FOUR components connected to the DME by the BSD, and the BSD/IBS Connection being disconnected just before the faults appeared, the BSD Connector X13895, just above the Negative Battery Post is certainly the first suspect. While there, also make sure the B+ connector from the IBS to the Rear Power Distribution Panel is plugged in. If any doubts about wiring positions/ installations, attach photo(s).

Here is the BSD Interface and X13895 Installation Location:
https://www.newtis.info/tisv2/a/en/e...rnator/oYPEvM2
https://www.newtis.info/tisv2/a/en/e90-325i-lim/SQE9rMY

George
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 06:19 AM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST