E90Post
 


TNT Racewerks
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > AUDIO/VIDEO + BLUETOOTH + Electronics/Alarm/Software > Noise Suppressor Filter



Reply
 
Thread Tools Search this Thread
      11-03-2013, 08:41 PM   #1
rightaway
Second Lieutenant
United_States
4
Rep
287
Posts

Drives: 2009 BMW 328i
Join Date: Apr 2013
Location: PA

iTrader: (0)

Question Noise Suppressor Filter

I have installed an Alpine PDX amp and the speakers hum. I read and it is normal. how any body tried a noise suppressor filter? will this help at all?
I was looking into this... http://cgi.ebay.com/ws/eBayISAPI.dll...X:eRTM:US:1123
Appreciate 0
      11-03-2013, 08:45 PM   #2
kaigoss69
Brigadier General
kaigoss69's Avatar
United_States
192
Rep
3,858
Posts

Drives: '08 335i
Join Date: Jul 2008
Location: JAX

iTrader: (6)

Doubt it, you're gonna need a new amp!
__________________
Mobridge DA2 > JBL MS-8 > ARC XDi 600/4 > JBL Gti 408 Mids & Vifa OT19 Tweeters; PG Ti2 1600.5 > Morel HCW-10 & IDMax 15
Appreciate 0
      11-03-2013, 11:11 PM   #3
bmw325i
Major General
160
Rep
5,122
Posts

Drives: 2006 BMW 325i
Join Date: Oct 2010
Location: United States

iTrader: (8)

I have an xd600/6 but channels 5 and 6 stopped working other than that it works perfect and noise free. I was planning on replacing it with and F6 pretty soon but I'd be willing to work out a trade if your interested.
Appreciate 0
      11-04-2013, 12:10 PM   #4
makkan00
Major General
makkan00's Avatar
United Kingdom
691
Rep
9,063
Posts

Drives: F10 Sold
Join Date: Dec 2011
Location: Essex

iTrader: (55)

Quote:
Originally Posted by bmw325i
I have an xd600/6 but channels 5 and 6 stopped working other than that it works perfect and noise free. I was planning on replacing it with and F6 pretty soon but I'd be willing to work out a trade if your interested.
Have to tried to run channel 5 and 6 in bridge mode?
__________________
Appreciate 0
      11-04-2013, 12:31 PM   #5
bmw325i
Major General
160
Rep
5,122
Posts

Drives: 2006 BMW 325i
Join Date: Oct 2010
Location: United States

iTrader: (8)

Quote:
Originally Posted by makkan00 View Post
Have to tried to run channel 5 and 6 in bridge mode?
That's how I had it hooked up when those channels stopped working. It was bridged powering the Morels which are 4 Ohm. It'll be replaced soon.
Appreciate 0
      11-04-2013, 06:47 PM   #6
rightaway
Second Lieutenant
United_States
4
Rep
287
Posts

Drives: 2009 BMW 328i
Join Date: Apr 2013
Location: PA

iTrader: (0)

so you guys don't think its a bad ground? I have it ground to a bolt to the body
Appreciate 0
      11-04-2013, 08:32 PM   #7
ctuna
Major General
729
Rep
8,198
Posts

Drives: 325xi 06 wagon MT
Join Date: Jan 2010
Location: Santa Cruz, Ca

iTrader: (0)

Which system did you start with or are you driving it with ?

Which system did you start with or are you driving the amp with ?
Did you have noise before you installed?
The standard steps are
remove the input to the amp is the noise gone
Inject a music signal directly into the amp from a cd player or
device of your choice does if it plays cleanly then the noise is from the head
unit or whatever else up stream.
The guys that commented on the pdx know the pdx.
Appreciate 0
      11-06-2013, 07:44 PM   #8
darren0311
New Member
0
Rep
17
Posts

Drives: 2006 BMW 325i
Join Date: Apr 2013
Location: Philadelphia Pa

iTrader: (0)

You shouldn't have any noise at all and noise filters are junk, check your ground and make sure you have a solid ground! If your using low level inputs make sure your using a good set of wires that are shielded. If that doesn't work, chances are it's the amp
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 02:22 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST