E90Post
 


Extreme Powerhouse
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > Interior Light Problem/Bug



Reply
 
Thread Tools Search this Thread
      11-05-2019, 09:18 PM   #1
Cira
New Member
0
Rep
6
Posts

Drives: 2007 E90 320d
Join Date: Nov 2019
Location: Europe

iTrader: (0)

Interior Light Problem/Bug

Hey guys,

I have an interior light problem that is really annoying and I can't figure it out for a while now.

-The headlight switch buttons/markings (Markings: 0, Auto, DRL, I) are only shining when the switch is on 0 (Headlights are off) and are not shining when I turn on the actual light.
-The radio (BMW Professional) button lights are not shining at all

I have noticed this after I had some work done on the front left and rear left door (They had to take the door off off the car).

Things I have checked:

-Battery checked - it's good
-Alternator checked - it's good
-All jacks that were unplugged were checked - all good
-Fuses checked - all good
-Footwell Module (Light Control Module) checked - it's good

The only thing I found on the internet while digging this up is on this forum and all the same, was happening to this guy, he resolved the problem by replacing the LED dome light with a normal bulb, I found out that I have a LED dome light also, which I didn't even notice, so I replaced it with a normal one but it didn't solve the issue.

Any ideas? Thanks
Appreciate 0
      11-09-2019, 03:32 PM   #2
icon2015
Private
12
Rep
67
Posts

Drives: E92 320d ~200 bhp
Join Date: Apr 2018
Location: Bucharest

iTrader: (0)

Try to remove the front and back left door connectors between the doors and the car, and check if the issue still occurs.
Appreciate 0
      11-11-2019, 03:43 AM   #3
Cira
New Member
0
Rep
6
Posts

Drives: 2007 E90 320d
Join Date: Nov 2019
Location: Europe

iTrader: (0)

Quote:
Originally Posted by icon2015 View Post
Try to remove the front and back left door connectors between the doors and the car, and check if the issue still occurs.
I haven't tried that. I will definitely give it a try, thank you.
Appreciate 0
Reply

Bookmarks

Tags
bug, button, headlight, light, light switch, problem, radio

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 07:58 AM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST