E90Post
 


TNT Racewerks
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > ConnectedDrive / I-Drive / Navigation Related Discussion > CIC repaired - volume control and presets not working



Reply
 
Thread Tools Search this Thread
      09-21-2020, 04:38 PM   #1
clart
Private First Class
clart's Avatar
25
Rep
156
Posts

Drives: F31 330d
Join Date: Dec 2014
Location: Tamworth

iTrader: (0)

CIC repaired - volume control and presets not working

Had my cic from my e91 repaired by a member on here after it was continuously rebooted. Main board was replaced and updated maps etc, but now the volume dial doesnt adjust the volume although mute works when pressed.

Also the 1-8 buttons do nothing or the next track but the eject button seems to make a noise.

Any ideas ?
Appreciate 0
      09-21-2020, 07:20 PM   #2
smass
Major
326
Rep
1,489
Posts

Drives: BMWs with 3L I6 engines
Join Date: Sep 2010
Location: Phoenix, AZ

iTrader: (1)

Garage List
2009 E70 X35d  [0.00]
2016 F15 35i  [0.00]
2003 E53 3.0  [0.00]
2006 E90 325i  [0.00]
2006 E90 330i  [0.00]
2012 E88 128i  [0.00]
Check that the ribbon cable between the faceplate and circuit board is fully seated.
Appreciate 0
      09-22-2020, 04:53 AM   #3
clart
Private First Class
clart's Avatar
25
Rep
156
Posts

Drives: F31 330d
Join Date: Dec 2014
Location: Tamworth

iTrader: (0)

Quote:
Originally Posted by smass View Post
Check that the ribbon cable between the faceplate and circuit board is fully seated.
Checked that, all looks ok but I reseated it . Seems strange that some functions work and some don't ?

Would the volume dial need coding ?
Appreciate 0
      09-22-2020, 01:56 PM   #4
smass
Major
326
Rep
1,489
Posts

Drives: BMWs with 3L I6 engines
Join Date: Sep 2010
Location: Phoenix, AZ

iTrader: (1)

Garage List
2009 E70 X35d  [0.00]
2016 F15 35i  [0.00]
2003 E53 3.0  [0.00]
2006 E90 325i  [0.00]
2006 E90 330i  [0.00]
2012 E88 128i  [0.00]
Does next track work from the strring wheel but not the face? I don't think this is a coding issue.
Appreciate 0
      09-23-2020, 02:25 AM   #5
clart
Private First Class
clart's Avatar
25
Rep
156
Posts

Drives: F31 330d
Join Date: Dec 2014
Location: Tamworth

iTrader: (0)

Quote:
Originally Posted by smass View Post
Does next track work from the strring wheel but not the face? I don't think this is a coding issue.
Thats correct. all the functions work from the steering wheel.
Appreciate 0
      09-25-2020, 04:53 AM   #6
clart
Private First Class
clart's Avatar
25
Rep
156
Posts

Drives: F31 330d
Join Date: Dec 2014
Location: Tamworth

iTrader: (0)

anyone?
Appreciate 0
      09-25-2020, 08:08 AM   #7
smass
Major
326
Rep
1,489
Posts

Drives: BMWs with 3L I6 engines
Join Date: Sep 2010
Location: Phoenix, AZ

iTrader: (1)

Garage List
2009 E70 X35d  [0.00]
2016 F15 35i  [0.00]
2003 E53 3.0  [0.00]
2006 E90 325i  [0.00]
2006 E90 330i  [0.00]
2012 E88 128i  [0.00]
What is the person who repaired the CIC saying? This seems like an internal issue in the CIC.
Appreciate 0
      10-12-2020, 01:12 PM   #8
Nickco43
Lieutenant Colonel
Nickco43's Avatar
1168
Rep
1,812
Posts

Drives: 13 BMW 335i xDrive
Join Date: Apr 2018
Location: Philadelphia, PA

iTrader: (0)

Garage List
Quote:
Originally Posted by clart View Post
Had my cic from my e91 repaired by a member on here after it was continuously rebooted. Main board was replaced and updated maps etc, but now the volume dial doesnt adjust the volume although mute works when pressed.

Also the 1-8 buttons do nothing or the next track but the eject button seems to make a noise.

Any ideas ?
Sounds like the faceplate is messed up.
Appreciate 0
      02-05-2021, 04:50 AM   #9
ccfj1
Tinkerer
ccfj1's Avatar
United Kingdom
60
Rep
478
Posts

Drives: e92 335i M-Sport
Join Date: Jan 2012
Location: Brighton

iTrader: (0)

I was the guy that replaced the mainboard on this.

Sorry for the delay I don't come here often.

All that was replaced on the CIC was the main board; the cd/dvd, hdd, ribbon cables and faceplate were all from the original unit.

I tested all the functions when i had it on the bench and it all checked out.

I'm more than happy to have the unit back and test it all out, just in case something has came loose in shipping.
__________________
2010 e92 335i M-Sport: Retrofits, OEM Dab, OEM TV, Split Armrest, Rear Blind, EPS Individual Audio, Heated M3 Interior, Brembo Performance calipers, illuminated M5 Gearknob.
Appreciate 0
      04-21-2021, 04:22 AM   #10
bmw-extreme
Enlisted Member
0
Rep
31
Posts

Drives: e90
Join Date: Mar 2011
Location: turkey

iTrader: (0)

Any update on this issue? I have the same problem now. After retrofitting (not coded it yet) us cic from a donor car to my eu bimmer, no preset, am-fm and mode buttons work including cd eject button. However volume button works for switching the hu on and off and for muting, but doesn't work for setting the vol level. And also it doesn't accept storing radio channels by the controller. I think that's a coding issue.

Last edited by bmw-extreme; 04-21-2021 at 01:51 PM..
Appreciate 0
      04-21-2021, 04:32 AM   #11
ccfj1
Tinkerer
ccfj1's Avatar
United Kingdom
60
Rep
478
Posts

Drives: e92 335i M-Sport
Join Date: Jan 2012
Location: Brighton

iTrader: (0)

Its possible, there is a coding option for the button panel.

Check all the options in the cic that start with FBM
__________________
2010 e92 335i M-Sport: Retrofits, OEM Dab, OEM TV, Split Armrest, Rear Blind, EPS Individual Audio, Heated M3 Interior, Brembo Performance calipers, illuminated M5 Gearknob.
Appreciate 0
      04-21-2021, 07:38 AM   #12
bmw-extreme
Enlisted Member
0
Rep
31
Posts

Drives: e90
Join Date: Mar 2011
Location: turkey

iTrader: (0)

Thanks. I know about that option. In the past, some owners have replaced 6 button front panels with Euro style 8 button panels, and coded their cars. I will check them, when coding cic.
But I'm confused a bit. Front panel is connected directly to cic, and both two don't use k-can to communicate. So, why front panel doesn't work with my car. Maybe frm recognized its a used cic and locked some features. Because navigation, sat radio and all stored stations worked at the first power on. But I have seen they were all gone after a short coffee break.
Appreciate 0
      04-21-2021, 09:00 AM   #13
ccfj1
Tinkerer
ccfj1's Avatar
United Kingdom
60
Rep
478
Posts

Drives: e92 335i M-Sport
Join Date: Jan 2012
Location: Brighton

iTrader: (0)

Front panel uses the lin_bus (9600k) from the HVAC control panel.

Its connected directly to the cic main board.

try a replacement if you have one and see if you have the same problem, if its the same then its either, HVAC or cic.
__________________
2010 e92 335i M-Sport: Retrofits, OEM Dab, OEM TV, Split Armrest, Rear Blind, EPS Individual Audio, Heated M3 Interior, Brembo Performance calipers, illuminated M5 Gearknob.
Appreciate 0
      04-21-2021, 09:56 AM   #14
bmw-extreme
Enlisted Member
0
Rep
31
Posts

Drives: e90
Join Date: Mar 2011
Location: turkey

iTrader: (0)

Since its connected directly to the cic main board, aren't the signals coming from the front panel processed directly by the cic? When I press the eject button, doesn't the cic do it directly? I didn't try it, but I think the eject button should work when the cic is powered on the bench, and not connected to (the car) k-can. (However cic also says that I'm not able to store stations when its not connected to k-can) I have not replacement panel. You're right. Maybe some modules still think they work with professional radio. So coding them and to see what happens is the only option before saying front panel or cic is bad.

Last edited by bmw-extreme; 04-21-2021 at 10:26 AM..
Appreciate 0
      04-23-2021, 07:37 AM   #15
bmw-extreme
Enlisted Member
0
Rep
31
Posts

Drives: e90
Join Date: Mar 2011
Location: turkey

iTrader: (0)

Update.
Definitely it's not a coding problem. It's a hardware problem. I replaced the front plate and the problem is solved. But still I don't understand why these front plates fail easily.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 03:52 AM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST