E90Post
 


 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > DIY Guides > DIY: Install SSD in CIC



Reply
 
Thread Tools Search this Thread
      07-27-2023, 12:07 PM   #287
wytzzmf
Registered
0
Rep
2
Posts

Drives: BMW E90
Join Date: Jul 2023
Location: ENGLAND

iTrader: (0)

Can you advise? HDD SDD converters

Hi everyone,
Thank you for your explanations and guidance. I have recently purchased IDE to USB cable and IDE to CF Card adapter. Can you please let me know whether the items I purchased are the correct ones? I could not find exact models. In my regions these were available and affordable.

Thank you.
Attached Images
    
Appreciate 0
      07-27-2023, 10:14 PM   #288
johnnyorange
Enlisted Member
53
Rep
46
Posts

Drives: 2009 lci e91
Join Date: Sep 2018
Location: los angeles

iTrader: (1)

Quote:
Originally Posted by wytzzmf View Post
Hi everyone,
Thank you for your explanations and guidance. I have recently purchased IDE to USB cable and IDE to CF Card adapter. Can you please let me know whether the items I purchased are the correct ones? I could not find exact models. In my regions these were available and affordable.

Thank you.
I cannot confirm but that very well may work.

Good luck and keep us posted!
Appreciate 0
      08-04-2023, 01:39 AM   #289
nexus1968
New Member
2
Rep
21
Posts

Drives: BMW 330d xDrive E91
Join Date: Nov 2022
Location: Italy

iTrader: (0)

Hello to all in this useful place, in mine e91 09 cic radio professional i have changed hd to msata 128gb with ableconn adapter, have cloned partially from toshiba hd everythings but not music partition that was enlarged from a guy and copied in mine, the maps and other is working correctly but when i try to copy mp3 from usb drive in glovebox on to the enlarged partition of approximately 74gb..between 1 or 2% it stops saying data tranfer stopped!!!!!
Any help please.
regards
Appreciate 0
      08-10-2023, 03:52 PM   #290
Joe_92
Registered
0
Rep
2
Posts

Drives: BMW E93
Join Date: Mar 2023
Location: Germany

iTrader: (0)

Hello all,

I followed the instructions exactly as described (CompactFlash card + expanded partition for music storage) aaand....everything worked on the first try! Quite amazing. Even updating the maps worked. Thank you so much for this great great guide! I'm really happy to no longer drive around with a 15 year old HDD. :-)

One remark I still need to say though, the "speed improvement" is really not that noticable for me. Navigation is still rather slow, and so are map updates or copying mp3s. That's fine with me, though, speed was never my main motivation for this upgrade.

One point not mentioned in the guide, but which I highly recommend (it's quite obvious anyway): If you change the music partition I'd really pull another image with dd at the very end - should you ever ever need to replace the CompactFlash card at one point you can then skip the entire process and just flash the improved image right away :-)

I still have one question though, in case anybody knows: If you make this update and then update the maps afterwards - would you be able to install the old HDD again (essentially "downgrading" the maps)? Or will the CIC then refuse the HDD, as it's expecting newer maps? I'm just wondering for the rare offchance that I might want to revert these changes at one point, e.g. , I want to sell my car to someone who is not trusting these modifications (no matter how useful and in every case just "better") they are!) and wants to have everything back to stock....
Appreciate 0
      08-10-2023, 04:44 PM   #291
opjose
Major
opjose's Avatar
242
Rep
1,351
Posts

Drives: 335xi
Join Date: May 2016
Location: Md

iTrader: (0)

Yes you can swap the old drive back in and it will show the old maps again.
Appreciate 0
      08-10-2023, 09:43 PM   #292
POBEP
Lieutenant
POBEP's Avatar
United_States
360
Rep
541
Posts

Drives: E70 E90 E91
Join Date: Mar 2016
Location: Christmas Valley, CA

iTrader: (0)

Garage List
Quote:
Originally Posted by Joe_92 View Post
I still have one question though, in case anybody knows: If you make this update and then update the maps afterwards - would you be able to install the old HDD again (essentially "downgrading" the maps)?
Old, stock HDD will work just fine.

I had an issue with 2023 map upgrade, which fried several partitions.
Both old HDD and it's dd-ed image worked (and saved me a week of recovery first time).
In fact, I was able to use all but last partition from my 2009 E91 CIC drive backup to recover 2013 E70 CIC drive (this took few days)
__________________
Appreciate 0
      09-23-2023, 08:06 AM   #293
cosmic3000
Registered
0
Rep
2
Posts

Drives: bmw e92
Join Date: Sep 2023
Location: germany

iTrader: (0)

Hey, come from Germany, excuse my bad English.

I have in my E92 Bj. 2011 recently the problem that the music collection is no longer available. Navi goes without problems.

Have checked the hard drive and it seems to have no bad sectors.

Does anyone have a working image that he can provide me ?

Many greetings Marcel
Appreciate 0
      09-30-2023, 06:20 AM   #294
Joe_92
Registered
0
Rep
2
Posts

Drives: BMW E93
Join Date: Mar 2023
Location: Germany

iTrader: (0)

@cosmic3000: What would happen when you try to load new music to it again? If everything is still working and the drive shows no bad sectors, you might still be able to use your image after all? I can understand though that you'd rather use a 100% verified image, instead your personal one when it already shows some strange behavior....sorry that I cannot help you here.

I would still give some input regarding the guide, maybe these points could be clarified, as they were quite confusing to me. Even though I was successful with the upgrade at the end and everything works fine, maybe someone would like to answer them to me anyway? I'd be very curious to understand and learn :-)

Step 19: I had no idea what that step even means or for what I could possibly need it. I just ignored it honestly and got away with it. Maybe some additional clarification would be nice what this is about?

Step 22: No idea why but I was not able at all to mount my nas drive from qnx (and I really tried for a long time and am generally not a complete newbie here...). At the end I used an usb drive instead which required a lot of juggling and even splitting of archives, due to linux-links and fat32 limitations. I assume you could skip most of the latter if you really only backup partition 9 and 10. Just a recommendation for anyone else who might struggle: If you don't have a nas or don't get it running: Just mount a fat32 usb drive instead to qnx directly and backup your partitions to it there. Cumbersome, yes, but it will get you the results at the end

Step 28: I feel like a complete idiot but even after successfully concluding the upgrade I really still don't understand *why* I would need to backup or memorize this information or even write it down? Or which one even exactly? Later in step 30, when it even says "this is why we needed to save the information" I still don't get why.....and in step 31 and step 32 you just insert the "free space following" accordingly and it will fit automatically? I might have been very lucky here but until the very end I did not understand what I was supposed to write down and reinsert at a later point in time and the upgrade still worked flawlessly...

Step 40:
It says "you don't need to copy the .boot partition" - i must admit this left me very confused as I tend to follow the manual exactly, as much as possible. So i really didn't know what would be the best way now? Also, I didn't even understand what the ".boot" partition was, but I assume it was the ".boot"-folder? At the end I copied everything, as I thought it couldn't hurt....and what can I say, it worked. As much as I admire this guide and manual, if I dare make any improvement suggestion at all, I would not leave the reader with such a vague statement at this point, but state clearly what should be done or at least make the options here (copy it or not) a bit more clear what the differences would be.

The rest was crystal-clear and easy to follow - and I am still extremly happy that I did it. Again, I wouldn't get the hopes up too high for a big speed increase, but reliability and more media storage were my main motivations to begin with.

Last edited by Joe_92; 09-30-2023 at 06:26 AM..
Appreciate 0
      10-02-2023, 04:55 PM   #295
cosmic3000
Registered
0
Rep
2
Posts

Drives: bmw e92
Join Date: Sep 2023
Location: germany

iTrader: (0)

Joe_92
Unfortunately, the music collection does not work. The field is grayed out, and I cannot add more music. I created an image backup of the hard drive and wanted to load it onto another hard drive to test it. However, the image is larger than the capacity of the original hard drive, which seems unusual. I'm concerned that the image might be irreparably damaged. Does anyone have a working image they could share ?
Appreciate 0
      10-09-2023, 06:43 PM   #296
Jagaer
Private First Class
Canada
405
Rep
170
Posts

Drives: 2011 E91 328xi 6MT
Join Date: Aug 2017
Location: Kingston, Ont

iTrader: (0)

Joe_92

Step 19 isn't really a step, it is just showing the mount point names as designed by BMW. This gives a good idea of what to find in each partition.

Step 22 is the mount command I used on QNX to mount the network share. Note that this only works if you are using CIFS (not NFS) and set to anonymous read/write. The destination (192.168.1.100) is a Linux server.

Step 28 is needed to recreate the partition table exactly. If you do a blind dd from the old HDD to the new SSD, then you don't need that info. But if you need to recreate the partition table, you need this info to adjust the table. (mostly to align with 4k blocks, instead of legacy 512 byte)

Step 40. If you look inside the .boot partition it just contains logfiles and coredump info. At best it does nothing. At worst, there will be some permission issue that doesn't allow overwriting and the kernel gets angry that it can't write the logfile.
Appreciate 0
      10-30-2023, 04:56 AM   #297
nikolarun
New Member
2
Rep
7
Posts

Drives: BMW 325i M Sport
Join Date: May 2017
Location: London,UK

iTrader: (0)

Hi All,
The HDD in my E90 has died, and I haven't got a backup. All the links I can find the a full EU / UK image are dead.Does anyone have a working link to a full HDD image ? I have the CiC system in a 2011 car.
Appreciate 0
      11-15-2023, 06:55 PM   #298
prle
New Member
3
Rep
5
Posts

Drives: BMW 325i E90 lci
Join Date: Nov 2023
Location: Croatia

iTrader: (0)

Great post, all explained. >Think ill go for it.
Appreciate 0
      12-10-2023, 04:52 PM   #299
smartshah
New Member
3
Rep
6
Posts

Drives: BMW D3 Alpina
Join Date: Dec 2015
Location: UK

iTrader: (0)

Hi @jagaer or anyone else who can help me.

I have one request and one question.

1. Can someone link me a copy of the neutrino vm. I have neutrino 6.42, i dont know where i got it from, but that continues to crash etc, i would be ever so grateful.

2. To back up the partitions, the 2 partitions hbmedia and hbdebug, how on earth can i dump a copy of it on a USB stick?

BTW i went down the SYBA enclosure method with a Sandisk Extreme Pro 128GB CF card. Mine has a write speed up to 120 mbs, the newer one, black one has a speed of upto 160 mbps. Anyway i brought a used card, to verify if it works, as i will do the same to my E70 and E60.

I have not noticed an instant boot, on my car maps takes around a minute to load. Music folder around 2 minute or more. Could be a faulty CF card, who knows.

Im glad i did this though, as my HDD was struggling when i done the dd command, so i had to use the ddrescue -d -r3 command like someone else on here, big thanks to that guy for putting that on here.

(Neutrino 6.4 issues, it throws an error when umount is commanded, but it does it anyway.
It also fails to mount it the second time round
It then could not mkdir anymore
It then stops randomly listing the USB stick and the USB adaptor
The mouse was invisible, until i googled the crap out of how to fix it,

The fix:-

Go to Launcher, Utilities, Display, there is an option for hardware/software choose hardware, then you can see your cursor.

UPDATE 19/12/2023

1. For me i faced several issues, when it came to QNX 6.5 installation and functionality.
I tried booting from the Disk, rather than installing it, because it prompts for a license when you try to install it.

2. I pulled my hair out, trying to recognise the Compact Flash card, whilst booting the QNX machine. Luckily i had 3 laptops to play around with. It was odd, one laptop would recognise the partitions when booting from QNX on the other laptop i would have to unplug and plug the USB cable back in. It would then show the partitions as umass1077.t4.

Anyway long story short, i believe there was an issue with the image also. As I mentioned i was having issues with the dd command so i had to use ddrescue. (Although my Nav and Music Folders still worked, but there was some odd issues QNX OS was having reading the partitions, and the VM would crash

So i brought another IDE to USB adaptor, and created a new image. And i then used my ORIGINAL HDD to create another image using dd command, and it worked with no issues, took around an hour. (My Laptops are not hardcore rigs, they are around 6 years old).

So this was my setup and method:-

1. Install Linux Mint on a seperate Partition on a laptop
2. Create an image of the Original HDD
3. Install VM player from vmware website
4. Download QNX 6.5 RTOS from their website
5. Install it on the Virtual Disk or you can run from disk
6. Create additional Virtual Disk around 20GB (Allocate Disk Space now checked)
7. Go to advanced settings on both Virtual Disks and uncheck caching
8. Increase the RAM on the VM and CPU counts, i added 3 CPUs
9. Add a USB controller
10. Add bootdelay into the VM config, just google it. I added 10 seconds

Then from here on backing up the partitions etc i follwed instructions from p0lar

This is to backup the partitons, please have a look at his post, there was one thing that did not work for me

# mkdir /root/{saved/{debug,media},debug,media}

As it was not creating the "saved" folder so i created that first

# mkdir saved

And then that command worked.

# scratchdrive="/dev/hd1"
# mediapartition="/dev/hd10t77.4"
# debugpartition="/dev/hd10t77.5"
# alias mount="mount -t qnx6"
# mkqnx6fs ${scratchdrive}
# mkdir /root/{saved/{debug,media},debug,media}
# mount ${scratchdrive} /root/saved
# mount -o ro ${mediapartition} /root/media
# mount -o ro ${debugpartition} /root/debug
# cp -Rp /root/media/* /root/saved/media/
# cp -Rp /root/debug/* /root/saved/debug/
# umount /root/{media,debug,saved}

I originally tried to use another USB stick to back the partitions on, but was having huge difficulty trying to mount it etc. p0lar instructions were extremely helpful and helped me resolve most of the issues i was having.

P.S.

Originally dd failed every single time at around 12GB, so i thought i was doomed, but then used ddrescue. However the issue was with IDE to USB adaptor i got from ebay. I brought another one from Amazon, and that had no issues whatsoever.

As i have mentioned i used the Sandisk Extreme Pro Compact Flash card 128GB, its operating temp is from -20c to 80c. Initially now it takes a little while to start up and load Nav and Music, when you fit it in first time, but after that it is pretty instant.

Also prior to copying the media files over, I changed the folder name from Ripped19 to Music Folder, and then copied them, and this reflects in the CIC.

Once again thank you Jaeger and p0lar

Last edited by smartshah; 12-19-2023 at 11:17 AM.. Reason: Update
Appreciate 1
POBEP359.50
      12-11-2023, 02:16 PM   #300
opjose
Major
opjose's Avatar
242
Rep
1,351
Posts

Drives: 335xi
Join Date: May 2016
Location: Md

iTrader: (0)

https://tecadmin.net/drive-and-parti...th-dd-command/

Also the CIC boots from flash memory not from the SSD. That is why you can pull the hard drive and the unit will still start up.
Appreciate 1
Ariakas19.50
      01-12-2024, 08:33 AM   #301
Ariakas
New Member
20
Rep
23
Posts

Drives: 2009 BMW 335i xDrive
Join Date: Dec 2018
Location: Canada

iTrader: (0)

Hi all, just wanted to update this thread, I swapped my hard disk to compact flash as per instructions outlined by Jagaer and others. Heres a summary of my situation.

Background:

2009 335i CIC iDrive. Some 5 yrs ago, I noticed my Nav and radio would cutout and reconnect randomly. Black screen for a few secs and back to normal, seems to happen during cold days. I wasnt too fuss about it as I rarely drove my vehicle in winter. Fast forward to last Dec and Im starting to drive my car more during the cold. CIC reboots were more frequent whenever it was cold. Now it was truly bothering me. I read this thread from start to finish and wonder if my hard disk was failing. I read opjose reply about pulling hard disk and using iDrive to see if there are reboots, I confirmed no reboots as radio was fine so Im pretty sure my hard disk has bad sectors and the blips were really noticeable during cold weather.

Plan of action: Ordered from Amazon these items.

1. IDE to USB 3.0 adapter https://www.amazon.com/dp/B01E7EPKUO...roduct_details. Used to transfer data from BMW hard disk to my computer as an image using HDD Raw Copy https://hddguru.com/software/HDD-Raw-Copy-Tool/. Afterwards via HDD Raw Copy transfer image to CF card.

2. SanDisk 128GB Extreme PRO CompactFlash Memory Card https://www.amazon.com/dp/B00ECEVGN0...roduct_details

3. Syba Dual Compact Flash CF to 44 Pin IDE/PATA 2.5" Adapter Enclosure https://www.amazon.com/dp/B0036DDXUM...roduct_details

Creating the image using HDD Raw Copy took around 45 mins as the old IDE hard drive transfer speed was slow. Copying the image to CF memory card took about 25 mins, much quicker as expected. My laptop had USB 3.0 ports.

I did have to bend the pin on the enclosure to plug in transfer adapter, after transfer done, I cut off the pin which someone else did as well https://www.e90post.com/forums/showp...&postcount=225, as mentioned in thread that pin not needed. Last steps were installing the enclosure in vehicle, snapped trim pieces back in and started accessory power, NAV loaded up fine and I could also access stored music.

The weather last couple days was quite cold, -25C to -30C, so moment of truth. Drove the car and no issues at all for iDrive, stayed on constantly and over bumps as road had snow. Very happy to finally resolved this issue thanks to this thread. I plan to update maps to NA 2023 soon.
Appreciate 1
POBEP359.50
      01-12-2024, 05:15 PM   #302
opjose
Major
opjose's Avatar
242
Rep
1,351
Posts

Drives: 335xi
Join Date: May 2016
Location: Md

iTrader: (0)

Excellent.

Do yourself a favor and make an image of your old drive to a file in case you should ever need it again.
Appreciate 0
      01-14-2024, 05:08 PM   #303
Ariakas
New Member
20
Rep
23
Posts

Drives: 2009 BMW 335i xDrive
Join Date: Dec 2018
Location: Canada

iTrader: (0)

Quote:
Originally Posted by opjose View Post
Excellent.

Do yourself a favor and make an image of your old drive to a file in case you should ever need it again.
Thanks. Yup, indeed I kept the image on my computer.

On another note, I did encounter reboot today. However, the outside temperature was -35C with windchill of -45C. I think the extreme cold must of tripped the limits of the CF card operating temp which stated was good to -25C. The vehicle bluetooth for my phone connection was also messed up. Other than that no other dash lights. First time driving my E90 in this low of temp and was curious how it behaves.
Appreciate 0
      01-14-2024, 09:40 PM   #304
opjose
Major
opjose's Avatar
242
Rep
1,351
Posts

Drives: 335xi
Join Date: May 2016
Location: Md

iTrader: (0)

Was the car parked outside all night?

The biggest issue is condensation at the car warms.
Appreciate 0
      01-15-2024, 10:50 PM   #305
Ariakas
New Member
20
Rep
23
Posts

Drives: 2009 BMW 335i xDrive
Join Date: Dec 2018
Location: Canada

iTrader: (0)

Quote:
Originally Posted by opjose View Post
Was the car parked outside all night?
Was in garage, not heated so decently cold but of course away from the elements. Can't think of anything that would affect it besides the cold, was great up to mid minus 20s.
Appreciate 0
      01-23-2024, 01:57 PM   #306
Reefin dude
Registered
2
Rep
2
Posts

Drives: BMW E61
Join Date: Jan 2024
Location: North Carolina

iTrader: (0)

Is there a way to test that the HD has gone bad? All of a sudden my CIC upgraded e61 has stopped showing Navigation. It has been working fine for 5 years. I have tried all of the usual FSC stuff, but I am unable to even get the 1b file. I also read that sometimes a bad combox would cause Navigation to grey out, but I am able to Bluetooth fine. Everything else seems to be working fine. I have in the past done a HD swap/upgrade. I can't remember if it was for this E61 or not. it was a long time ago. If I yank the HD out and the behavior is the same, would that be a good indicator that the HD is bad?

I am just trying to figure out why all of a sudden the Navigation has suddenly greyed out.

Thank you,

G~
Appreciate 0
      01-24-2024, 01:15 PM   #307
opjose
Major
opjose's Avatar
242
Rep
1,351
Posts

Drives: 335xi
Join Date: May 2016
Location: Md

iTrader: (0)

The easiest way is to pull the drive, connect an EIDE to USB adapter and preferably from Linux read out all of the blocks to a file.

If they read the drive is ok, though you cannot rule out striction as a potential problem.

It does sound like your drive is dying though.
Appreciate 0
      01-25-2024, 04:42 PM   #308
Reefin dude
Registered
2
Rep
2
Posts

Drives: BMW E61
Join Date: Jan 2024
Location: North Carolina

iTrader: (0)

Thank you.

as a follow up. I was able to find my original HD. when I pulled the HD that is in the car it is exactly the same setup as shown here on Post #1. when I put the original HD in the car, navigation showed up again. it appears that when the HD does go bad it only affects the navigation. looking back at my records it looks like I did the SSD upgrade in 2018, so getting 6 years out of it isn't to bad. I did go to a 256GB and repartitioned, but I never used the music side, so I am going back to just a 128 and not worrying about repartitioning for larger music storage.
Appreciate 1
POBEP359.50
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 10:33 PM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST