E90Post
 


The Tire Rack
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > No clutch pedal pressure



Reply
 
Thread Tools Search this Thread
      09-21-2018, 08:20 PM   #1
Paliator
New Member
5
Rep
24
Posts

Drives: 2007 328xi
Join Date: Nov 2016
Location: Pennsylvania

iTrader: (0)

No clutch pedal pressure

I just finished replacing my clutch using a luk clutch kit. I also did a clutch delay valve delete while I was there. I went to bleed my clutch after I finished everything, and NOTHING comes out when I bleed it and there is absolutely no clutch pressure at all. Fluid did come out when I did the cdv delete. I would really appreciate some help, I'm dying to have my car back
Appreciate 0
      09-21-2018, 08:56 PM   #2
feuer
Major General
feuer's Avatar
United_States
2424
Rep
6,269
Posts

Drives: wife crazy!
Join Date: Apr 2015
Location: Chicago, IL

iTrader: (3)

Get a vacuum pump. Attached on the bleeder. Loosen up the bleeder. Start working the vaccum pump. Once brake fluid starts running you can start pumping your pedal.
Appreciate 0
      09-21-2018, 09:05 PM   #3
Paliator
New Member
5
Rep
24
Posts

Drives: 2007 328xi
Join Date: Nov 2016
Location: Pennsylvania

iTrader: (0)

Quote:
Originally Posted by feuer View Post
Get a vacuum pump. Attached on the bleeder. Loosen up the bleeder. Start working the vaccum pump. Once brake fluid starts running you can start pumping your pedal.
Do you think anything broke? My pedal was very stiff and then all of a sudden the pedal is like butter
Appreciate 0
      09-21-2018, 09:42 PM   #4
feuer
Major General
feuer's Avatar
United_States
2424
Rep
6,269
Posts

Drives: wife crazy!
Join Date: Apr 2015
Location: Chicago, IL

iTrader: (3)

Quote:
Originally Posted by Paliator View Post
Do you think anything broke? My pedal was very stiff and then all of a sudden the pedal is like butter
I don't think is broken.
Appreciate 0
      09-22-2018, 02:16 AM   #5
Paliator
New Member
5
Rep
24
Posts

Drives: 2007 328xi
Join Date: Nov 2016
Location: Pennsylvania

iTrader: (0)

Quote:
Originally Posted by feuer View Post
I don't think is broken.
I just finshed trying what you said and it started leaking from this opening in the transmission


https://ibb.co/gNKAbp
Appreciate 0
      09-22-2018, 12:42 PM   #6
feuer
Major General
feuer's Avatar
United_States
2424
Rep
6,269
Posts

Drives: wife crazy!
Join Date: Apr 2015
Location: Chicago, IL

iTrader: (3)

Quote:
Originally Posted by Paliator View Post
I just finshed trying what you said and it started leaking from this opening in the transmission


https://ibb.co/gNKAbp
I'm sorry. Probably you broke it.
Appreciate 0
      09-22-2018, 03:34 PM   #7
Paliator
New Member
5
Rep
24
Posts

Drives: 2007 328xi
Join Date: Nov 2016
Location: Pennsylvania

iTrader: (0)

Quote:
Originally Posted by feuer View Post
I'm sorry. Probably you broke it.
Broke the slave cylinder?
Appreciate 0
      09-22-2018, 03:43 PM   #8
feuer
Major General
feuer's Avatar
United_States
2424
Rep
6,269
Posts

Drives: wife crazy!
Join Date: Apr 2015
Location: Chicago, IL

iTrader: (3)

Quote:
Originally Posted by Paliator View Post
Broke the slave cylinder?
If is leaking is broken.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 05:26 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST