E90Post
 


European Auto Source (EAS)
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > HELP! Engine Clicking/Ticking when Revving



Reply
 
Thread Tools Search this Thread
      11-25-2017, 04:21 PM   #1
i_jihg
Registered
0
Rep
3
Posts

Drives: bmw 335i e92 n54
Join Date: Mar 2017
Location: Fontana CA

iTrader: (0)

HELP! Engine Clicking/Ticking when Revving

So it all started after a pull 10 months ago. My serpentine belt ripped and went inside the crank seal. We all know the deal when this happens. I got all the pieces out BESIDES the ones stuck in the oil pick up tube (I forgot.) A few months after, I would notice my car would go into limp mode at cold starts. I just literally would have to let it warm up and turn it off/on, then car would work perfect! So back to present time. I was doing a quick highway pull and got a half engine light. Pulled over and did the whole “Engine off/Engine on” thing to get rid of the light; but nothing happened. Still had the light. Then as I drove home, I got a low oil pressure light on. When I would turn on the car, I would get several Vanos codes. So I replaced both Vanos,Camshaft position sensors, valve cover gasket, oil pan gasket, and did an oil change. The car was still the same. Then I noticed when I would rev the engine, loud ticking was present. It sounded like the valves. Then I did some reading and WHOOPS! I forgot to clean the pick up tube. So I replaced the whole oil pick up tube and now the noice is gone! No lights, no nothing! I was happy until I reved the engine and heard a ticking at around 1.8-3k RPMs. It’s weird because the sound seems to be coming from the valve cover. It sounds mainly on the front of the engine (where the chain goes.) It is not present at idle, I could only hear it the most at around 1.8-3k rpms. It seems to speed up as I rev the engine higher and higher. I’m going to open up the valve cover and see if there’s anything lose in a bit. I need some advise! I checked the filter and do not see any metal pieces inside of the housing. Please all help is appreciated. I just ran out of ideas on what it could be

BTW Sorry for the grammar!!

Mods:
JB4, downpipes, straight pipe, intakes and e30



CLIPS:

https://drive.google.com/open?id=1Nt...yhJ_uXjWug1ka0

https://drive.google.com/open?id=1HH..._8Hi3vhbWQ5WiI
Appreciate 0
      11-26-2017, 09:25 PM   #2
limitdown
First Lieutenant
limitdown's Avatar
183
Rep
344
Posts

Drives: 2007 335i E93
Join Date: Jul 2015
Location: Location

iTrader: (0)

This has happened to me. Spun bearing. Needed new engine.
When you open the valve cover, probably a bunch of parts will be damaged, from the rod vibrations.
Another way to tell is if you get the car on a lift and listen to the bottom end while revving.

You can imagine how expensive this can be. ...
Appreciate 0
Reply

Bookmarks

Tags
click, lifter, n54, noise, valve

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 06:53 PM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST