E90Post
 


 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > ConnectedDrive / I-Drive / Navigation Related Discussion > idrive controller not responding



Reply
 
Thread Tools Search this Thread
      10-11-2021, 12:37 PM   #23
kissdaring
Private
kissdaring's Avatar
3
Rep
66
Posts

Drives: 2007 BMW 328i E93
Join Date: Jul 2019
Location: Toronto, Ontario CA

iTrader: (0)

Just to update. After putting in the used part all is operational. My guess would be that it fried itself.
Appreciate 0
      09-04-2022, 10:43 PM   #24
Alsanchez1226
Registered
0
Rep
2
Posts

Drives: BMW 335D
Join Date: Sep 2021
Location: Mesa Az

iTrader: (0)

This is my first post on a forum. My idrive controller isn't working. The buttons on the console and steering wheel work just not on the controller. I checked the voltage and on wire 1 and I'm getting (13.96v), Wire 2 (.002v), Wire 3 (.5v), Wire 4 (4.5v). The only thing I've done was my battery died and I recharged it and it worked fine. But the car died again because the car sat there for a while and now it doesnt work at all after I recharged the battery. I don't wanna go straight to replacing it because of the price but I just wanna know my options. A lot of people bring up issues when they get there battery replaced or alternator changed. All I did was recharge the battery when it dies. Anything helps.
Appreciate 0
      09-07-2022, 03:06 PM   #25
Cyberdemon
Brigadier General
Cyberdemon's Avatar
1462
Rep
3,264
Posts

Drives: 2020 X5 40i, 2011 E90 335i
Join Date: Jun 2012
Location: Long Island NY

iTrader: (2)

Quote:
Originally Posted by Alsanchez1226 View Post
This is my first post on a forum. My idrive controller isn't working. The buttons on the console and steering wheel work just not on the controller. I checked the voltage and on wire 1 and I'm getting (13.96v), Wire 2 (.002v), Wire 3 (.5v), Wire 4 (4.5v). The only thing I've done was my battery died and I recharged it and it worked fine. But the car died again because the car sat there for a while and now it doesnt work at all after I recharged the battery. I don't wanna go straight to replacing it because of the price but I just wanna know my options. A lot of people bring up issues when they get there battery replaced or alternator changed. All I did was recharge the battery when it dies. Anything helps.
Your controller is probably dead. For whatever reason the iDrive controller seems to have some unpleasant way of handling some type of voltage spike.

The best I could recommend is look for a used controller. If your controller is in physically good condition you can probably find one that is cosmetically ugly but you can swap your buttons and switches if you want - that's what I did. I paid less than $100 for a used controller.

If you know someone with an E90 they could potentially swap their controller with you to confirm.
__________________
Current: '20 X5, '11 E90 335i
Previous: '11 E90 M3, '16 VW GTI, '15 M235i, '13 335i, '08 TL-S, '00 Corvette
Appreciate 0
      09-16-2022, 03:05 PM   #26
Alsanchez1226
Registered
0
Rep
2
Posts

Drives: BMW 335D
Join Date: Sep 2021
Location: Mesa Az

iTrader: (0)

Quote:
Originally Posted by Cyberdemon View Post
Your controller is probably dead. For whatever reason the iDrive controller seems to have some unpleasant way of handling some type of voltage spike.

The best I could recommend is look for a used controller. If your controller is in physically good condition you can probably find one that is cosmetically ugly but you can swap your buttons and switches if you want - that's what I did. I paid less than $100 for a used controller.

If you know someone with an E90 they could potentially swap their controller with you to confirm.

He so I just bought a new one for 400 which I know wasn't my only option, but that that completely fixed it. Thanks for the tip 👍
Appreciate 0
      11-15-2022, 03:27 PM   #27
mcjoe691
Lieutenant
mcjoe691's Avatar
United_States
256
Rep
508
Posts

Drives: 2015 M3
Join Date: Sep 2011
Location: Viera , Florida

iTrader: (0)

Quote:
Originally Posted by Alsanchez1226 View Post
He so I just bought a new one for 400 which I know wasn't my only option, but that that completely fixed it. Thanks for the tip 👍
I drive contoler no power at all . I was taping into this for the strobe lights i have 😩 I should have never done this . No Radio , no CD , no Xm . The I drive is not working at all . Anyone know how I can fix this ? Thanks
Appreciate 0
      11-15-2022, 04:33 PM   #28
TheMidnightNarwhal
Major General
TheMidnightNarwhal's Avatar
Canada
1913
Rep
5,670
Posts

Drives: 11' 335is DCT
Join Date: Jun 2015
Location: Gatineau, Quebec

iTrader: (0)

Quote:
Originally Posted by mcjoe691 View Post
I drive contoler no power at all . I was taping into this for the strobe lights i have 😩 I should have never done this . No Radio , no CD , no Xm . The I drive is not working at all . Anyone know how I can fix this ? Thanks
Are you writing this after trying a replacement controller?
Appreciate 0
      11-26-2022, 01:28 PM   #29
mcjoe691
Lieutenant
mcjoe691's Avatar
United_States
256
Rep
508
Posts

Drives: 2015 M3
Join Date: Sep 2011
Location: Viera , Florida

iTrader: (0)

Quote:
Originally Posted by TheMidnightNarwhal View Post
Quote:
Originally Posted by mcjoe691 View Post
I drive contoler no power at all . I was taping into this for the strobe lights i have 😩 I should have never done this . No Radio , no CD , no Xm . The I drive is not working at all . Anyone know how I can fix this ? Thanks
Are you writing this after trying a replacement controller?
Quote:
Originally Posted by TheMidnightNarwhal View Post
Quote:
Originally Posted by mcjoe691 View Post
I drive contoler no power at all . I was taping into this for the strobe lights i have 😩 I should have never done this . No Radio , no CD , no Xm . The I drive is not working at all . Anyone know how I can fix this ? Thanks
Are you writing this after trying a replacement controller?
No .
__________________
Build by (PSI) 2019 M2C , BC suspension , BC wheels , DP , Vorsteiner trunk lip , Diffuser , Side Skirts , IND reflector kit , Rw carbůn hood , DME Tuned !
E90 M3 Supercharged
Appreciate 0
      11-26-2022, 01:42 PM   #30
TheMidnightNarwhal
Major General
TheMidnightNarwhal's Avatar
Canada
1913
Rep
5,670
Posts

Drives: 11' 335is DCT
Join Date: Jun 2015
Location: Gatineau, Quebec

iTrader: (0)

Quote:
Originally Posted by mcjoe691 View Post
No .
Then I would replace it if your joystick shows red in ISTA.
Appreciate 0
      11-26-2022, 05:37 PM   #31
mcjoe691
Lieutenant
mcjoe691's Avatar
United_States
256
Rep
508
Posts

Drives: 2015 M3
Join Date: Sep 2011
Location: Viera , Florida

iTrader: (0)

Quote:
Originally Posted by TheMidnightNarwhal View Post
Quote:
Originally Posted by mcjoe691 View Post
No .
Then I would replace it if your joystick shows red in ISTA.
I replace the joy stick also now nothing no power . The fuse is good #14
__________________
Build by (PSI) 2019 M2C , BC suspension , BC wheels , DP , Vorsteiner trunk lip , Diffuser , Side Skirts , IND reflector kit , Rw carbůn hood , DME Tuned !
E90 M3 Supercharged
Appreciate 0
      12-17-2022, 02:14 PM   #32
Evilbean
New Member
0
Rep
5
Posts

Drives: 2006 330xi
Join Date: Dec 2022
Location: US

iTrader: (0)

iDrive Controller Knob and Buttons not working

Hey guys, hoping you can help me with this one. Iíve been fighting with it for over a year. IDrive controller does not work, and neither do the buttons. However, the screen works totally fine. Iíve checked all the fuses from the fuse box Iíve run ISTA and Iíve got no communication from the controller. Iíve tried two replacement iDrive controllers that I bought from eBay and neither worked.

Any other ideas of what it might be I learned from one of the other posts that there is a single power cable going to the iDrive controller and it is under or near the footpedal something called X9331. Ista shows a fuse in here but Iím not sure if there really is one before I start. Pulling more things off the car. Is there something obvious I might be missing. Appreciate any help. Iíve got a number of tools at my disposal INPA, WinKPF, Ista-D (not P), and the Bimmergeeks protool
Attached Images
  
Appreciate 0
Reply

Bookmarks

Tags
controller, idrive, not responding

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 01:37 PM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2023, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST