Tirerack
Use the following links to go directly to useful tirerack winter items: Tirerack Winter Tires. Gary's Winter Tire FAQ.
Using the links directly supports E90Post with tirerack sales commision!

  E90Post
 


The Tire Rack

   PLEASE HELP SUPPORT E90POST BY DOING YOUR TIRERACK SHOPPING FROM THIS BANNER, THANKS!
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Wheels and Tires Forum Sponsored by The Tire Rack > TPMS Inactive - need new sensors?



Wheels and Tires forum Sponsored by The Tire Rack
Please help to directly support e90post by doing your tirerack shopping from the above link. For every sale made through the link, e90post gets sponsor support to keep the site alive. Disclaimer

Reply
 
Thread Tools Search this Thread
      02-14-2020, 12:59 PM   #1
JasW
Captain
JasW's Avatar
250
Rep
649
Posts

Drives: 2013 335is E93 6MT
Join Date: Jul 2015
Location: South Florida

iTrader: (0)

Garage List
TPMS Inactive - need new sensors?

The TPMS Inactive warning on my 2013 335is has been coming on sporadically for months now, and now it's on pretty much all the time. I'm gathering I need new TPMS sensors. Tire Rack recommends this one for my car. If I have them sent to my local tire shop (Tire Kingdom), will they be able to take care of it? That is, I've read horror stories of people trying (and failing) to code new sensors with INPA, and wanted to make sure I really don't need anything that the tire shop can't do.
__________________
2013 335is E93 6MT | LeMans Blue/Saddle Brown
BQ Tuning MHD E60 flash | Cobb catted DPs | ETS 5" FMIC | BMS DCI | Fuel-It Stage 2 LPFP | MMP inlets/outlets | Forge DVs | N20 TMAP sensor
Vibrant 1790 resonators/mid-cat delete | MPI CP | Spec Stage 3+ clutch and steel SMFW | Wavetrac LSD | M3 rear subframe and diff bushings
Appreciate 0
      02-14-2020, 01:20 PM   #2
Hulton
Registered
2
Rep
4
Posts

Drives: BMW E90 (325i 3.0 USA)
Join Date: Feb 2020
Location: Poland

iTrader: (0)

Could also be an ABS sensor failure.
Had the same issue, but also had sporadical ASR failures popping up at the same time. I've replaced the ABS sensor and everything was back to normal.

Last edited by Hulton; 02-14-2020 at 01:24 PM.. Reason: Typos
Appreciate 0
      02-14-2020, 02:00 PM   #3
JasW
Captain
JasW's Avatar
250
Rep
649
Posts

Drives: 2013 335is E93 6MT
Join Date: Jul 2015
Location: South Florida

iTrader: (0)

Garage List
Quote:
Originally Posted by Hulton View Post
Could also be an ABS sensor failure.
Had the same issue, but also had sporadical ASR failures popping up at the same time. I've replaced the ABS sensor and everything was back to normal.
I've had no ABS and DSC lights coming on, though (and front and rear brake pads plus sensors were done within the past year). Just the TPMS inactive light. Someone had mentioned the likely cause is a dead battery in the TPMS sensor(s), but apparently, even though they're basically a watch battery, they can't be replaced because they are sealed in the sensor.
__________________
2013 335is E93 6MT | LeMans Blue/Saddle Brown
BQ Tuning MHD E60 flash | Cobb catted DPs | ETS 5" FMIC | BMS DCI | Fuel-It Stage 2 LPFP | MMP inlets/outlets | Forge DVs | N20 TMAP sensor
Vibrant 1790 resonators/mid-cat delete | MPI CP | Spec Stage 3+ clutch and steel SMFW | Wavetrac LSD | M3 rear subframe and diff bushings
Appreciate 0
      02-14-2020, 03:00 PM   #4
bimmerfan1972
Private First Class
bimmerfan1972's Avatar
1
Rep
104
Posts

Drives: 2011 BMW 335xi
Join Date: Nov 2019
Location: Nashville, TN, USA

iTrader: (0)

I've had the same issue, let me know if replacing the TPMS sensors work.
__________________
2011 BMW 335i xDrive E92 N55 Alpine White\M-Sport package /BMS CAF/VRSF 5" FMIC/VRSF CP//MHD Stage 1+
Appreciate 0
      02-16-2020, 11:45 AM   #5
JasW
Captain
JasW's Avatar
250
Rep
649
Posts

Drives: 2013 335is E93 6MT
Join Date: Jul 2015
Location: South Florida

iTrader: (0)

Garage List
Quote:
Originally Posted by bimmerfan1972 View Post
I've had the same issue, let me know if replacing the TPMS sensors work.
I'm hoping someone can weigh in first before I take an almost $300 gamble on this. I'm really surprised there is no definitive answer here or in other forums. Replacing the sensors comes closest, but then there is a thread on another forum where a guy got stuck in a coding nightmare after replacing the sensors.
__________________
2013 335is E93 6MT | LeMans Blue/Saddle Brown
BQ Tuning MHD E60 flash | Cobb catted DPs | ETS 5" FMIC | BMS DCI | Fuel-It Stage 2 LPFP | MMP inlets/outlets | Forge DVs | N20 TMAP sensor
Vibrant 1790 resonators/mid-cat delete | MPI CP | Spec Stage 3+ clutch and steel SMFW | Wavetrac LSD | M3 rear subframe and diff bushings
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 07:49 AM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST