E90Post
 


 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > BMW Coding > FRM3 Resurrection Thread



Reply
 
Thread Tools Search this Thread
      03-03-2021, 07:27 PM   #397
littlecreatures
Registered
0
Rep
2
Posts

Drives: e92 335i
Join Date: Feb 2021
Location: Sydney

iTrader: (0)

Anyone in Sydney recommended for repairing one of these?
Appreciate 0
      04-03-2021, 12:25 AM   #398
cawwt
New Member
0
Rep
8
Posts

Drives: BMW x5
Join Date: Feb 2021
Location: CA

iTrader: (0)

This is a GREAT thread. Thanks for all the information.

I wished I had found this earlier though.

TL;DR Try it with the China clone XProg 5.55 if you want to shorten your life by a few years!

If anyone in the San Francisco bay area have a good programmer, please contact me. I am willing to pay you to fix my FRM3. Getting a XProg 5.60 may work, but that will mean waiting for another few weeks to ship from China.

XProg 5.55 box, as others have said, fails on read verification very often. If I kept reading, in some cases I can get a successful read/verification. After collecting a few successful reads, I converted them into eee. Diff shows that they are all the same. The dflash_to_eee also reported correct VIN number, production date and serial number. So the EEE file may be valid.

The problem is that Xprog 5.55 is so unstable that I am not sure if the write is good or not. I was trying to be smart to do a write, then read it back until I get no verification error, then I diff the read file against the one I flashed. I found no diff. But unfortunately no success. So, at this point, I am not sure if my dflash read was a success or not.
Appreciate 0
      04-06-2021, 09:57 PM   #399
cawwt
New Member
0
Rep
8
Posts

Drives: BMW x5
Join Date: Feb 2021
Location: CA

iTrader: (0)

Quote:
Originally Posted by cawwt View Post
This is a GREAT thread. Thanks for all the information.

I wished I had found this earlier though.

TL;DR Try it with the China clone XProg 5.55 if you want to shorten your life by a few years!

If anyone in the San Francisco bay area have a good programmer, please contact me. I am willing to pay you to fix my FRM3. Getting a XProg 5.60 may work, but that will mean waiting for another few weeks to ship from China.

XProg 5.55 box, as others have said, fails on read verification very often. If I kept reading, in some cases I can get a successful read/verification. After collecting a few successful reads, I converted them into eee. Diff shows that they are all the same. The dflash_to_eee also reported correct VIN number, production date and serial number. So the EEE file may be valid.

The problem is that Xprog 5.55 is so unstable that I am not sure if the write is good or not. I was trying to be smart to do a write, then read it back until I get no verification error, then I diff the read file against the one I flashed. I found no diff. But unfortunately no success. So, at this point, I am not sure if my dflash read was a success or not.



Follow up on the story in case it will help someone else. I have almost given up and convined that this Xprog 5.55 box I had could not write correctly either.

I randomly downloaded 9230433 eee and flashed it. Holyshit!! The lights, windows, turning signals are all working!! However, the "Lighting System, Stop" error message came back though. Not sure if this is a coding issue. I am waiting for a coding cable to come and will code it and see if I can get rid of that error message. I am not going to risk flashing eee again as I am not sure if I was extremely lucky or that the Xprog 5.55 has no problem writing.
Appreciate 0
      04-12-2021, 09:45 PM   #400
cawwt
New Member
0
Rep
8
Posts

Drives: BMW x5
Join Date: Feb 2021
Location: CA

iTrader: (0)

Quote:
Originally Posted by cawwt View Post
Follow up on the story in case it will help someone else. I have almost given up and convined that this Xprog 5.55 box I had could not write correctly either.

I randomly downloaded 9230433 eee and flashed it. Holyshit!! The lights, windows, turning signals are all working!! However, the "Lighting System, Stop" error message came back though. Not sure if this is a coding issue. I am waiting for a coding cable to come and will code it and see if I can get rid of that error message. I am not going to risk flashing eee again as I am not sure if I was extremely lucky or that the Xprog 5.55 has no problem writing.

Another update: I bought a cable. Using NCS Expert I was able to write the VO back into the FRM. There is no more error now and the everything is working perfectly!

Before writing the VO there was an error message of $318 not compatible with this FA. So probably that was the reason of the error message on the car screen.

Interestedly there was no option to enter VIN in WinKFP. So I couldn't my FRM still has wrong VIN number.
Appreciate 0
      Yesterday, 12:44 AM   #401
sdbmwcoding
Captain
123
Rep
660
Posts

Drives: BMW M3
Join Date: May 2019
Location: socal

iTrader: (0)

Quote:
Originally Posted by cawwt View Post
Quote:
Originally Posted by cawwt View Post
Follow up on the story in case it will help someone else. I have almost given up and convined that this Xprog 5.55 box I had could not write correctly either.

I randomly downloaded 9230433 eee and flashed it. Holyshit!! The lights, windows, turning signals are all working!! However, the "Lighting System, Stop" error message came back though. Not sure if this is a coding issue. I am waiting for a coding cable to come and will code it and see if I can get rid of that error message. I am not going to risk flashing eee again as I am not sure if I was extremely lucky or that the Xprog 5.55 has no problem writing.

Another update: I bought a cable. Using NCS Expert I was able to write the VO back into the FRM. There is no more error now and the everything is working perfectly!

Before writing the VO there was an error message of $318 not compatible with this FA. So probably that was the reason of the error message on the car screen.

Interestedly there was no option to enter VIN in WinKFP. So I couldn't my FRM still has wrong VIN number.
Winkfp > configuration > check box to write vin in comfort mode
Appreciate 0
      Yesterday, 04:38 PM   #402
cawwt
New Member
0
Rep
8
Posts

Drives: BMW x5
Join Date: Feb 2021
Location: CA

iTrader: (0)

Quote:
Originally Posted by sd********* View Post
Winkfp > configuration > check box to write vin in comfort mode
Thank you very much, Sir!!!

The check box doesn't say VIN. It says ULF (Not sure if I remember correctly). That's the trick to show the "Enter VIN" button.

I was able to update the FRM3 module with the right VIN. Apparently the update reset the VO on the FRM3. So I had to do the NCS trick again to copy it from CAS to FRM.

All good now!! Thanks a lot for all the forum/youtube friends for helping.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 12:01 AM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST