E90Post
 


The Tire Rack
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > Africa > 2010 BMW 320i E90, Engine false overheat.



Reply
 
Thread Tools Search this Thread
      08-19-2019, 04:03 AM   #1
PrimeGuy
Registered
South Africa
0
Rep
1
Posts

Drives: BMW E90 320i Motor Sport
Join Date: Aug 2019
Location: South Africa

iTrader: (0)

Exclamation 2010 BMW 320i E90, Engine false overheat.

First of all, Hello Bimmer Gurus/Fans/Owner/Godfathers. I just currently signed up to the forum. I have always been a BMW fan since childhood. I recently bought a pre-owned 2010 BMW 320i Motor Sport (e90) with mileage of 119k 4 months ago. I love the car, i use it to commute to work Mon-Fri no problems up until it acted up on 9 minutes after leaving work.


What happened is it was Hot Sunny day, I got in the car started driving home turned my AC on (Two Bars), i was driving around 60km/h while accelerating i felt loss of power over the acceleration pedal then few second it popped up a red overheating sign and lost power completely. By that time i was in the middle of Johannesburg traffic. I put my traffic hazards on and turned the engine on and swerved off road.

I opened the hood of the car, there was no steam or boiling water. I got myself towed home, next morning i took the car my nearest car Service & Repair shop and later same day i was told that the car need a new engine and they sent me a quote of 108k i don't know much about mechanical issue's but i know when i'm being ripped off, besides the car can still turn on and be on idle for at least 11 minutes until it pops up the overheating engine light. To make this shorter, i went back and collected my car and had it towed back home. I had a guy come check it, and he told me that the engine does not overheat, water and cooler flows perfectly and had the computer box checked and it works just fine.


The car drives for like 20 minutes and then it shows engine overheating light and loses throttling power. Switch it off and on it drives again for the next 1-15 minutes then the overheating light pops up again. I dont know what to do if anyone has this kind of an issue please Help.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 02:32 AM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST