E90Post
 


Extreme Powerhouse
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > UK > UK Technical Forum > 2006 320d M Sport - Turbo Not Kicking In Early



Reply
 
Thread Tools Search this Thread
      03-24-2015, 03:32 PM   #23
kukjan
Private
kukjan's Avatar
Latvia
7
Rep
66
Posts

Drives: e90 320d 210hp
Join Date: Sep 2014
Location: Goole

iTrader: (0)

cleaned with carburator cleaner-same.
Appreciate 0
      11-16-2021, 04:05 AM   #24
Pete508
Registered
0
Rep
1
Posts

Drives: E90 320D Msport Touring
Join Date: Nov 2021
Location: Merseyside

iTrader: (0)

Hi guys, old thread I know but just recently acquired a 320D Msport Touring on a 55 plate with 154k. Car runs and drives lovely until you put it under load or run it upto what seems to be around 3800-4200 ish were i get the ‘ding’ and EML then theres no, or hardly any boost! Turn it off and back on and all is fine until you do it again. Just wondering if this is a bit of a stuck wastegate issue or maybe the little valve under the inlet manifold as mentioned above?
Appreciate 0
      11-18-2021, 02:41 PM   #25
Superlander
New Member
2
Rep
25
Posts

Drives: Estoril Blue M135i Auto
Join Date: Jul 2014
Location: Derby, UK.

iTrader: (0)

Quote:
Originally Posted by Pete508 View Post
Hi guys, old thread I know but just recently acquired a 320D Msport Touring on a 55 plate with 154k. Car runs and drives lovely until you put it under load or run it upto what seems to be around 3800-4200 ish were i get the ‘ding’ and EML then theres no, or hardly any boost! Turn it off and back on and all is fine until you do it again. Just wondering if this is a bit of a stuck wastegate issue or maybe the little valve under the inlet manifold as mentioned above?
I had this issue, go on YouTube and search for 320d sticking turbo vanes. Done that fix and it's been fine ever since I bought it about 2 weeks ago!

I am however noticing a bit of an issue whereby the boost isn't coming in at low ish revs, so going to look into maf sensors etc, but the turbo is now functional!
Appreciate 0
      12-01-2021, 10:31 AM   #26
chrissyw
Second Lieutenant
chrissyw's Avatar
20
Rep
239
Posts

Drives: 2006 E90 320d M Sport
Join Date: Mar 2014
Location: Midlands

iTrader: (0)

Lowish revs can be the swirl flap actuator / flaps not working.

It'll chuck up codes for that though.

Mine felt like it was nearly stalling at low revs and there was a noticeable drop in power low down. It was the electrical connection to the swirl flap actuator, it wasn't plugged in properly.

Mine is deflapped but if you leave the actuator unplugged they run crap unless mapped out.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 06:32 AM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST