E90Post
 


Extreme Powerhouse
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Random puff of smoke out of N54? Hard to track down.



Reply
 
Thread Tools Search this Thread
      03-30-2021, 05:35 PM   #1
iqraceworks
Colonel
iqraceworks's Avatar
860
Rep
2,443
Posts

Drives: 2007 335i
Join Date: Aug 2019
Location: Missouri

iTrader: (0)

Question Random puff of smoke out of N54? Hard to track down.

Ever since I've had my 07' 335i (N54) I've noticed that at random times....I will get a puff of smoke out of the exhaust that smells like oil. It might do it twice a day, or it might do it twice a month....very random.

It only does it at cruising speed under no load, or at an idle. Acceleration, deceleration....no issues. Runs like a champ, no codes, no issues. I installed one of the RB PCV valves thinking that might help...nope. New flapper valve on the PCV system....no change.

Could it just be oil building up in the PCV system, and then randomly dumping it into the intake? Should my next step be to install a catch can?

I'm pretty sure it's not turbo seals.......it's too random.

Ideas?
__________________
2007 335i, BMS DCI, BMS Chargepipe w/Tial BOV, ARM Catless Downpipes, silicone inlets, Bilstein B12 Prokit Suspension, Whiteline subframe bushings, Front/Rear M3 control arms, G-Plus FMIC, Stage 2 LPFP, MHD Stage 2+ tune, xHP stage 3 transmission flash.
Appreciate 0
      03-31-2021, 08:50 AM   #2
TheMidnightNarwhal
Major General
TheMidnightNarwhal's Avatar
Canada
1413
Rep
5,010
Posts

Drives: 2011 335is 6 speed
Join Date: Jun 2015
Location: Gatineau, Quebec

iTrader: (0)

I must say I have a similar very random smoking issue which I was never really able to pin point either.

It also very rarely happened to me. Happened few times in bumper to bumper traffic, a lot of smoking and smelled a lot like oil, thought turbos were blown.

Another time I topped the oil before doing a track run and I idle the car around 1k RPM and it just starts to do that same smoke puffing and smell a lot like oil.

But it's been a really long while since I had it, reading your post made me remember all of this and now I'm curious to what is really is
Appreciate 0
      03-31-2021, 09:40 AM   #3
iqraceworks
Colonel
iqraceworks's Avatar
860
Rep
2,443
Posts

Drives: 2007 335i
Join Date: Aug 2019
Location: Missouri

iTrader: (0)

I did just do an oil change when I started to notice it again. I put 7qts in...and it's right at the max line on the display. Maybe it has something to do with the oil being slightly overfull?

It's very odd....and kind of annoying. It might not do it for weeks...and then the next thing I know I'm sitting at a traffic light, and my car starts smoking like crazy.....and then 10 seconds later, it's gone...and it's all back to normal.
Appreciate 0
      03-31-2021, 02:25 PM   #4
TheMidnightNarwhal
Major General
TheMidnightNarwhal's Avatar
Canada
1413
Rep
5,010
Posts

Drives: 2011 335is 6 speed
Join Date: Jun 2015
Location: Gatineau, Quebec

iTrader: (0)

Quote:
Originally Posted by iqraceworks View Post
I did just do an oil change when I started to notice it again. I put 7qts in...and it's right at the max line on the display. Maybe it has something to do with the oil being slightly overfull?

It's very odd....and kind of annoying. It might not do it for weeks...and then the next thing I know I'm sitting at a traffic light, and my car starts smoking like crazy.....and then 10 seconds later, it's gone...and it's all back to normal.
Hmm okay in my case it doesn't really happen with overfill since it never happens at my oil changes.

But yeah, mine hasn't done that in a looong while, only remember it since I saw your thread. Maybe when I did my valve cover (PCV related internals) I fixed it without knowing. I also had upgraded the PCV valve in it.
Appreciate 0
      04-01-2021, 05:56 AM   #5
iqraceworks
Colonel
iqraceworks's Avatar
860
Rep
2,443
Posts

Drives: 2007 335i
Join Date: Aug 2019
Location: Missouri

iTrader: (0)

Well....I went ahead and ordered a catch can to put on the low pressure side of the PCV system....I already have one of the RB pcc valves ....

Hopefully that might help?
Appreciate 0
      04-05-2021, 11:27 AM   #6
krazythedon
Don
31
Rep
249
Posts

Drives: '09 E90 335xi Family Sedan
Join Date: Jan 2017
Location: Your Mother's House

iTrader: (0)

Same issue, its probably turbo or possibly valve seals. Maybe adding a low side PCV catch can may help, this is my next step. Already have RB PCV, high side catch can and walnut blasted recently.
Appreciate 0
      04-05-2021, 12:28 PM   #7
dpaul
Major
United_States
422
Rep
1,441
Posts

Drives: 2009 E90 335xi, 2011 E93 M3
Join Date: Dec 2012
Location: Boston

iTrader: (3)

Quote:
Originally Posted by iqraceworks View Post
Ever since I've had my 07' 335i (N54) I've noticed that at random times....I will get a puff of smoke out of the exhaust that smells like oil. It might do it twice a day, or it might do it twice a month....very random.

It only does it at cruising speed under no load, or at an idle. Acceleration, deceleration....no issues. Runs like a champ, no codes, no issues. I installed one of the RB PCV valves thinking that might help...nope. New flapper valve on the PCV system....no change.

Could it just be oil building up in the PCV system, and then randomly dumping it into the intake? Should my next step be to install a catch can?

I'm pretty sure it's not turbo seals.......it's too random.

Ideas?
It is pretty hard to imagine how a random dumping of oil from the PCV system would occur.

Are you 1000% sure you're smelling oil when this happens?

And that the smoke is coming out of the tailpipe?

Is the smoke thin, wispy and rapidly dispersed or is it heavy and hangs around for a bit?

Have you ever captured a log when this smoking was occuring?
Appreciate 0
      04-08-2021, 06:53 AM   #8
iqraceworks
Colonel
iqraceworks's Avatar
860
Rep
2,443
Posts

Drives: 2007 335i
Join Date: Aug 2019
Location: Missouri

iTrader: (0)

Quote:
Originally Posted by dpaul View Post
It is pretty hard to imagine how a random dumping of oil from the PCV system would occur.

Are you 1000% sure you're smelling oil when this happens?

And that the smoke is coming out of the tailpipe?

Is the smoke thin, wispy and rapidly dispersed or is it heavy and hangs around for a bit?

Have you ever captured a log when this smoking was occuring?
Yes, it definitely smells like oil when it happens.

No, I'm not 100% sure it's coming from the tailpipe.....but it always comes from the bank of the car. It's so random, I haven't been in a spot yet where I can jump out and see if it's coming straight out of the mufflers or not...but I don't know where else it would be coming from.

It's pretty wispy.....as soon as I see it, a few seconds later it's gone.

Nope, no logs.......I would have to run logs all day long just to try to catch something, and even then it might not happen. The idle doesn't stumble....other than the smoke, you would never be able to tell as far as how smooth it's running when it happens.

I did notice a lot of oil inside the rear inlet when I pulled it out last weekend to install my silicon inlets.......so I'm going to install an oil catch can and see if that helps. Maybe the PCV ports in the valve cover are clogged and it's not pulling as much oil out as it should? I thought it might have been smoke from oil dripping out of the rear inlet and only the DP's.......but after I pulled the DP's and looked at them, the are clean .

The inside of the turbos look clean, no signs of oil leaking.

Still trying to figure out what's going on.
__________________
2007 335i, BMS DCI, BMS Chargepipe w/Tial BOV, ARM Catless Downpipes, silicone inlets, Bilstein B12 Prokit Suspension, Whiteline subframe bushings, Front/Rear M3 control arms, G-Plus FMIC, Stage 2 LPFP, MHD Stage 2+ tune, xHP stage 3 transmission flash.
Appreciate 0
      04-08-2021, 09:39 PM   #9
idrift4wd
Brigadier General
135
Rep
3,552
Posts

Drives: Three Hundred and Thirty Five
Join Date: Jul 2010
Location: Yonkers NY

iTrader: (0)

Garage List
2007 BMW  [3.50]
its pretty common issue. happens mostly when coming to a stop. pvc issue. pvc valve and low side catch can can help.,
__________________

12.0 @ 117
Appreciate 0
      04-12-2021, 09:04 AM   #10
iqraceworks
Colonel
iqraceworks's Avatar
860
Rep
2,443
Posts

Drives: 2007 335i
Join Date: Aug 2019
Location: Missouri

iTrader: (0)

Well, even after my OCC installed....the car is still doing it.

It's definitely coming out of the exhaust.....and it only happens if I let off the gas and coast for a while, then when I get back on the gas it will smoke again.

BUT....it's not repeatable. It might do it once or twice one day....but not at all the next day.

Is that pointing towards turbo seals? I thought when those went bad....they smoked all the time? Or could it be an issue with the valve cover?

Just looking for ideas....

Last edited by iqraceworks; 04-12-2021 at 10:16 AM..
Appreciate 0
      04-12-2021, 09:44 AM   #11
Dave92N54
Second Lieutenant
Dave92N54's Avatar
United_States
108
Rep
271
Posts

Drives: 09 E92 335i 6MT
Join Date: Nov 2020
Location: Westminster, Maryland

iTrader: (0)

Garage List
2009 BMW 335i  [0.00]
Quote:
Originally Posted by iqraceworks View Post
Well, even after my OCV installed....the car is still doing it.

It's definitely coming out of the exhaust.....and it only happens if I let off the gas and coast for a while, then when I get back on the gas it will smoke again.

BUT....it's not repeatable. It might do it once or twice one day....but not at all the next day.

Is that pointing towards turbo seals? I thought when those went bad....they smoked all the time? Or could it be an issue with the valve cover?

Just looking for ideas....
Mine seems to do the same, though it's usually when idling for awhile and when I start to move I'll get a puff out the back. Never repeatable, just seems that's when it usually happens. Happened after downpipe install, turbos showed no signs of failure before, at least no oil, was kind of "sooty" but nothing was wet with 0 shaft play, wouldn't wiggle one bit.

I have univeral secondary 02s to throw in when it stops raining every damn day here, will drop the downpipes then and look at the turbos. However I really think this is some odd condensation issue we're all having.
__________________
Current: 09 E92 335i 6MT, Alpine White
Appreciate 0
      04-12-2021, 10:20 AM   #12
iqraceworks
Colonel
iqraceworks's Avatar
860
Rep
2,443
Posts

Drives: 2007 335i
Join Date: Aug 2019
Location: Missouri

iTrader: (0)

The more I read up on smoking issues that other people have had....I'm starting to think it could be turbo seals. I've got 100k miles on the car....and I have no idea if the turbos are the originals or not...but I bet they are.

I'm hitting them with 20psi of boost and they run like a champ.....but I'm wondering if the seals are starting to get worn. I've noticed that if I cost to a stop in N I don't get the smoke.....but if I leave it in D when I come to a stop (pulling lots of vacuum) that's when I get the puff of smoke. BUT...it doesn't do it all the time, so that still confuses me.
Appreciate 0
      04-19-2021, 06:51 AM   #13
iqraceworks
Colonel
iqraceworks's Avatar
860
Rep
2,443
Posts

Drives: 2007 335i
Join Date: Aug 2019
Location: Missouri

iTrader: (0)

Well, I ordered a new valve cover off of FCP Euro last night. I figured I would try that first before I spend the money on a new set of turbos. Hopefully it gets rid of my random smoking issue....at 100K miles, I'm sure it can't hurt to replace the valve cover anyways.

If that doesn't fix it...hello new 17T turbos
__________________
2007 335i, BMS DCI, BMS Chargepipe w/Tial BOV, ARM Catless Downpipes, silicone inlets, Bilstein B12 Prokit Suspension, Whiteline subframe bushings, Front/Rear M3 control arms, G-Plus FMIC, Stage 2 LPFP, MHD Stage 2+ tune, xHP stage 3 transmission flash.
Appreciate 0
      04-19-2021, 11:05 AM   #14
Ruster82
Private
18
Rep
59
Posts

Drives: 2006 BMW 335i N54
Join Date: Aug 2020
Location: Devon

iTrader: (0)

Will be interesting to see if the new cover solves the issue.

I have had the same problem in my 2006 E92 with 92000 miles on it. I replaced the PCV valve with an upgraded one but it seems to have made no difference.

I'm fairly sure mine is a breathing issue so the valve cover is my next step so will be very interested to see how you get on .

Have you noticed any creamy sludge build up in your oil filler cap?
Appreciate 0
      04-19-2021, 11:40 AM   #15
ky0u
Captain
ky0u's Avatar
United_States
676
Rep
649
Posts

Drives: 2007 e92 335i
Join Date: Sep 2010
Location: San Diego

iTrader: (1)

Garage List
2007 BMW 335i  [0.00]
Quote:
Originally Posted by iqraceworks View Post
The more I read up on smoking issues that other people have had....I'm starting to think it could be turbo seals. I've got 100k miles on the car....and I have no idea if the turbos are the originals or not...but I bet they are.

I'm hitting them with 20psi of boost and they run like a champ.....but I'm wondering if the seals are starting to get worn. I've noticed that if I cost to a stop in N I don't get the smoke.....but if I leave it in D when I come to a stop (pulling lots of vacuum) that's when I get the puff of smoke. BUT...it doesn't do it all the time, so that still confuses me.
Following for solution! Been chasing the same issue here. FBO with 2+ so I'm at about 18psi on stock snail's. 90% of the time im good, but every so often, come up to a light and smoke+oil smell.

noticed it after I swapped to catless DPs. Issue was probably present beforehand but masked by the cats. Turbos were swapped at 95k by PO but not sure about quality of work.

Fwiw, I recently swapped vcg (but not vc itself) as well as the pcv. Beforehand, oil smoke would come out of my engine bay from the back of my hood. That particular issue is no longer present
__________________
IG: @dragon_e92

Build Thread
Appreciate 0
      04-26-2021, 11:15 AM   #16
Ruster82
Private
18
Rep
59
Posts

Drives: 2006 BMW 335i N54
Join Date: Aug 2020
Location: Devon

iTrader: (0)

iqraceworks did you fit the valve cover yet and did it fix your issue?
Appreciate 0
      04-26-2021, 11:19 AM   #17
iqraceworks
Colonel
iqraceworks's Avatar
860
Rep
2,443
Posts

Drives: 2007 335i
Join Date: Aug 2019
Location: Missouri

iTrader: (0)

Quote:
Originally Posted by Ruster82 View Post
iqraceworks did you fit the valve cover yet and did it fix your issue?
Hasn't showed up from FCP Euro yet.......there shipping is kind of slow. Should be getting it very soon I hope.
Appreciate 0
      04-28-2021, 05:45 PM   #18
iqraceworks
Colonel
iqraceworks's Avatar
860
Rep
2,443
Posts

Drives: 2007 335i
Join Date: Aug 2019
Location: Missouri

iTrader: (0)

Well....the valve cover finally showed up from FCP today....took long enough!! Not sure if I will get it swapped out tonight or not, lots of stuff going on.

On a side note......last weekend I played around with MHD and turned the exhaust burble off (I've been running it on the medium setting). Not sure if it's related to the burbles being turned off.....but it's only smoked slightly one time so far this week..... coincidence??

I will give an update after I med the new valve cover on and spend a few days driving the car around.
Appreciate 1
ky0u676.00

      04-28-2021, 08:40 PM   #19
iqraceworks
Colonel
iqraceworks's Avatar
860
Rep
2,443
Posts

Drives: 2007 335i
Join Date: Aug 2019
Location: Missouri

iTrader: (0)

*****update*****

Well, old valve cover is off. It actually looks pretty good, not much carbon buildup inside of it, and the gasket is still nice and soft. I'm guessing it's been replaced before. It looks to be in great shape.....unless I'm missing something, I doubt it's the cause of my random puffs of smoke issue.

Anyone want a nice used valve cover in great shape?

I will put the new one on tomorrow....but I'm not hoping for any miracles at this point.
Appreciate 1
ky0u676.00

      04-29-2021, 06:45 AM   #20
FCobra94
Brigadier General
FCobra94's Avatar
2649
Rep
4,803
Posts

Drives: '07 E90 335i
Join Date: Dec 2011
Location: MD

iTrader: (2)

Do you have any WG rattle settings turned on in MHD? The only time I've had similar issues is when I've maxed out WG anti-rattle (or whatever's it's called). I only did it as a test one day when trying to see if the exhaust would sound louder or not, etc. with various settings.

Anyway, when turning off all the anti-rattle settings, I never had the problem again.

I've read in other forums that this phenomenon occurs during periods of low vacuum, where the seals are least likely to prevent pushing oil through, or something to that effect. However, during periods of boost, there's enough pressure to keep any from getting through. Makes sense for the most part.

Other than that, make sure your WG are adjusted properly and see if that makes any difference.
__________________
'07 E90 335i - Automagic - Non-sport
MHD E50|Alpina Flash|Stg 2 LPFP|VRSF 7"FMIC-DP-CP|TIAL BOV|cp-e DCI
Bilstein B6|Dinan Camber Plates|E93 M3 FSB-LCA-Guide Rods|Manzo Toe Arms|HPS 5.0
Style 393 - 225/50/17 - 10/20 F/R spacers
Appreciate 0
      04-29-2021, 06:50 AM   #21
iqraceworks
Colonel
iqraceworks's Avatar
860
Rep
2,443
Posts

Drives: 2007 335i
Join Date: Aug 2019
Location: Missouri

iTrader: (0)

Yep, no wastegate rattle at all. I'm not using any of the mhd settings to get rid of the rattle, I just adjusted the rods a long time ago and so far they're still nice and tight with no rattle.

At this point, I'm thinking you're right. The problem is oil leaking through the turbo seals at low vacuum. At least that gives me an excuse to buy a set of RB turbos now 😁

Maybe I will get luck and the new VC will fix it...but I'm not holding my breath.
Appreciate 1
FCobra942648.50

      04-30-2021, 07:39 AM   #22
iqraceworks
Colonel
iqraceworks's Avatar
860
Rep
2,443
Posts

Drives: 2007 335i
Join Date: Aug 2019
Location: Missouri

iTrader: (0)

Well.....new VC is on. Didn't see any smoking on the way to work this morning, but untill I can go a full week or two without any smoke when I'm coming to a stop....I won't really know if the VC fixed the problem or not.
Appreciate 2
FCobra942648.50

Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 08:34 AM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST