E90Post
 


Extreme Powerhouse
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > DIY Guides > DIY: E9X ACC Retrofit



Reply
 
Thread Tools Search this Thread
      02-15-2021, 04:13 AM   #243
unrulyteach
Colonel
unrulyteach's Avatar
United_States
362
Rep
2,377
Posts

Drives: 2011 335i
Join Date: May 2016
Location: myrtle beach sc

iTrader: (0)

Garage List
2011 BMW 335i  [0.00]
Quote:
Originally Posted by wololo7 View Post
Has anyone fitted ACC on E92 with the M3 look bumper?
Won't find bumper trim parts since it wasn't an option on m3 u would hav to make ur own
Appreciate 1
      03-02-2021, 06:38 PM   #244
hupchye
Private
hupchye's Avatar
Malaysia
34
Rep
63
Posts

Drives: 2010 BMW 320i E92
Join Date: Jan 2020
Location: Malaysia

iTrader: (0)

Garage List
Quote:
Originally Posted by hupchye View Post
I am going to DIY rear wheel bearing change with *** bearings c/w ABS magnetic encoder ring p/n: 33416762317 and do the LAST try...
With the working rear wheel speed sensors 34526870076, my 4 cyl patrol engine 320i E92 still cannot maintain speed in ACC. It is confirmed now ACC is not compatible with 4 cyl patrol engine DME MEV1746. May be diesel engine is an exemption.
Appreciate 0
      03-06-2021, 10:19 AM   #245
PhotoGuy87
Private First Class
PhotoGuy87's Avatar
United_States
74
Rep
116
Posts

Drives: 11 M-Sport 335d, 14 F31 328d
Join Date: Dec 2016
Location: The Woodlands, TX

iTrader: (0)

Hey guys I just completed retrofitting ACC to my 2011 335d but I am having some trouble with the coding part. I have already changed to the $541 on the FRM and CAS but don't know what parameters to change on the KOMBI, DSC, and CIC. I didn't see what parameters you guys were changing in this thread so any help would be greatly appreciated. Thanks!
Appreciate 0
      03-07-2021, 08:44 PM   #246
hupchye
Private
hupchye's Avatar
Malaysia
34
Rep
63
Posts

Drives: 2010 BMW 320i E92
Join Date: Jan 2020
Location: Malaysia

iTrader: (0)

Garage List
Quote:
Originally Posted by PhotoGuy87 View Post
Hey guys I just completed retrofitting ACC to my 2011 335d but I am having some trouble with the coding part. I have already changed to the $541 on the FRM and CAS but don't know what parameters to change on the KOMBI, DSC, and CIC. I didn't see what parameters you guys were changing in this thread so any help would be greatly appreciated. Thanks!
Hi, I think Nickco43 has explained clearly in his video clip below.



All KOMBI, DSC, and CIC by default parameters values (flash with empty .MAN file).
Appreciate 1
      03-14-2021, 01:26 PM   #247
rauno.kp
Registered
0
Rep
1
Posts

Drives: e90 330xi
Join Date: Mar 2021
Location: Estonia

iTrader: (0)

Is there any cleaner way for installing LDM and connecting it to the PT CAN besides tapping into DSC connector?

Also noticed one guy mention the need for 60 ohm resistance (120 ohm parallel resistors) for PT CAN line otherwise it can cause havoc, didn't notice Vehicular DIY use one, so anyone knows more about this subject?
Appreciate 0
      03-19-2021, 06:31 PM   #248
unrulyteach
Colonel
unrulyteach's Avatar
United_States
362
Rep
2,377
Posts

Drives: 2011 335i
Join Date: May 2016
Location: myrtle beach sc

iTrader: (0)

Garage List
2011 BMW 335i  [0.00]
Quote:
Originally Posted by rauno.kp View Post
Is there any cleaner way for installing LDM and connecting it to the PT CAN besides tapping into DSC connector?

Also noticed one guy mention the need for 60 ohm resistance (120 ohm parallel resistors) for PT CAN line otherwise it can cause havoc, didn't notice Vehicular DIY use one, so anyone knows more about this subject?
If u hav adaptive headlights u can tap into that
Appreciate 0
      03-22-2021, 08:33 PM   #249
unrulyteach
Colonel
unrulyteach's Avatar
United_States
362
Rep
2,377
Posts

Drives: 2011 335i
Join Date: May 2016
Location: myrtle beach sc

iTrader: (0)

Garage List
2011 BMW 335i  [0.00]
I wonder if it's possible to switch back n forth between regular cruise and adaptive cruise
Appreciate 0
      03-23-2021, 10:17 AM   #250
jmalm32
Registered
0
Rep
2
Posts

Drives: BMW 330XD e90
Join Date: Oct 2020
Location: Spain

iTrader: (0)

Hi, I have a 2009 330d xdrive with N57 engine. The car has cruise control with brake function. I want to equip it with ACC, but I'm not sure if I need the LDM module. Is it necessary to install it in my model?

Thanks
Appreciate 0
      03-23-2021, 11:05 AM   #251
unrulyteach
Colonel
unrulyteach's Avatar
United_States
362
Rep
2,377
Posts

Drives: 2011 335i
Join Date: May 2016
Location: myrtle beach sc

iTrader: (0)

Garage List
2011 BMW 335i  [0.00]
Quote:
Originally Posted by jmalm32 View Post
Hi, I have a 2009 330d xdrive with N57 engine. The car has cruise control with brake function. I want to equip it with ACC, but I'm not sure if I need the LDM module. Is it necessary to install it in my model?

Thanks
Yes u will
Appreciate 0
      03-24-2021, 03:58 AM   #252
jmalm32
Registered
0
Rep
2
Posts

Drives: BMW 330XD e90
Join Date: Oct 2020
Location: Spain

iTrader: (0)

Quote:
Originally Posted by unrulyteach View Post
Yes u will
Hello, thank you very much for the information.
I understand that I must connect in parallel the new LDM module and the ACC module. I should say that I have adaptive headlights and I could get from FRM the PT-CAN lines. In short it would look like this:

-----> ------> <-----
ACC LDM FRM Rest of car
<----- <------ <-----

Thanks
Appreciate 0
      03-24-2021, 08:25 PM   #253
scroller
Registered
Bulgaria
0
Rep
2
Posts

Drives: bmw e90 320i
Join Date: Mar 2021
Location: Bulgaria

iTrader: (0)

Quote:
Originally Posted by hupchye View Post
With the working rear wheel speed sensors 34526870076, my 4 cyl patrol engine 320i E92 still cannot maintain speed in ACC. It is confirmed now ACC is not compatible with 4 cyl patrol engine DME MEV1746. May be diesel engine is an exemption.
Hello , i'm trying as like you to retrofit to e90 320i 2007 ACC and i'm getting errors d024, d025 , because the computer on the car is not reading the CAN signal.Did you had any ideas after your last try. Who can create circuit board for this engine , bsc its specific.
Thanks you in advance.
Appreciate 0
      03-25-2021, 08:06 AM   #254
hupchye
Private
hupchye's Avatar
Malaysia
34
Rep
63
Posts

Drives: 2010 BMW 320i E92
Join Date: Jan 2020
Location: Malaysia

iTrader: (0)

Garage List
Quote:
Originally Posted by scroller View Post
Hello , i'm trying as like you to retrofit to e90 320i 2007 ACC and i'm getting errors d024, d025 , because the computer on the car is not reading the CAN signal.Did you had any ideas after your last try. Who can create circuit board for this engine , bsc its specific.
Thanks you in advance.
Hello, I encountered many problems when retrofit my e92 320i.
Same to you, first problem encountered errors d024, d025. These error codes are not caused by computer on the car is not reading the CAN signal. They are wheel torque errors from DSC because stock DSC in e90 320i (without braking) is not suitable for ACC. You may refer back to my old thread #214 for the summary.
Appreciate 0
      03-28-2021, 01:10 PM   #255
scroller
Registered
Bulgaria
0
Rep
2
Posts

Drives: bmw e90 320i
Join Date: Mar 2021
Location: Bulgaria

iTrader: (0)

do you had final solution hupchye for the motherboard , bsc after changing the DSC and the 4 sensors the rear sensors is not giving any values.The problem is that the computer is not reading this signals.
Appreciate 0
      03-28-2021, 07:47 PM   #256
hupchye
Private
hupchye's Avatar
Malaysia
34
Rep
63
Posts

Drives: 2010 BMW 320i E92
Join Date: Jan 2020
Location: Malaysia

iTrader: (0)

Garage List
Quote:
Originally Posted by scroller View Post
do you had final solution hupchye for the motherboard , bsc after changing the DSC and the 4 sensors the rear sensors is not giving any values.The problem is that the computer is not reading this signals.
I do not have the final solution yet. What I am still trying is using my own made CanBus bridge to alter the Can Bus ID 0x194 command data from LDM, see whether it will work for my e92 320i ECU or not.

After changing DSC and 4x wheel speed sensor, you need to change the coding setting in DSC

C07_DF_DIR to wert_02

in order for rear sensors to work.
Appreciate 1
      03-31-2021, 04:42 PM   #257
aeroshurik
Registered
aeroshurik's Avatar
Germany
0
Rep
4
Posts

Drives: BMW 3er E91 318d
Join Date: Mar 2021
Location: Berlin

iTrader: (0)

Hi hupchye, I see that you are very deep in the subject and your findings are really helpfull to understand many things. Appreciate that you share this for free.

I'am also currently rertofitting the ACC to my BMW E91 318d (2009 year) Automatic and CC $540 on stock.

I am planning to do it in two main steps:
1. Retrofit $544 (CC with Brakes)
2. Retrofit $541 (ACC)

I finished step 1 today without real success:

- Replaced stock 4 cyl DSC by a 6cyl DSC module MK60E5
- Replaced all 4-off wheel sensors
- Replaced DSC Sensor under the front seat
- Flashed the DSC unit with WinKFP to the latest software
- Coded it with NCS
- Calibrated the steering-angle sensor SZL (INPA)
- Calibrated the DSC unit (INPA)
- Calibrated the DSC Sensor (INPA)
- Venting routine for DSC unit

After all this interim steps no faults has been stored in the DSC unit until test drive. Once I activated the Cruse Control during test drive the yellow CC sign with exclamation mark and gong has appeared on the KOMBI screen (Normally by CC $540 it shows adjusted speed number). But the car could hold the speed and it works like a usual CC $540 except for yellow CC sing and a gong by speed adjustment. No Brakes function was present.

After reading the Faults two faults have been stored in the DSC unit:
D360 - PT-CAN Motronic_4 Plausibilitaet
D362 - PT-CAN Motronic_5

INPA provides different discription:
D362 - No message (ACC,0xAC) receiver DSC, transmitter ACC
D362 - No message (ACC,0xB4) receiver DSC, transmitter ACC

I am wondering why DSC it expecting a message from the ACC? I have not installed the ACC yet, because I am retrofiting the $544 only.

It probably due to PT Can Bus tapping problem that you share in thread #179

Do you have any idea how to resolve it? Or it might be a similar problem that my DME/DDE unit does not understand a 6cyl DSC unit...
Attached Images
    
Appreciate 0
      03-31-2021, 11:12 PM   #258
hupchye
Private
hupchye's Avatar
Malaysia
34
Rep
63
Posts

Drives: 2010 BMW 320i E92
Join Date: Jan 2020
Location: Malaysia

iTrader: (0)

Garage List
Quote:
Originally Posted by aeroshurik View Post
Hi hupchye, I see that you are very deep in the subject and your findings are really helpfull to understand many things. Appreciate that you share this for free.

I'am also currently rertofitting the ACC to my BMW E91 318d (2009 year) Automatic and CC $540 on stock.

I am planning to do it in two main steps:
1. Retrofit $544 (CC with Brakes)
2. Retrofit $541 (ACC)

I finished step 1 today without real success:

- Replaced stock 4 cyl DSC by a 6cyl DSC module MK60E5
- Replaced all 4-off wheel sensors
- Replaced DSC Sensor under the front seat
- Flashed the DSC unit with WinKFP to the latest software
- Coded it with NCS
- Calibrated the steering-angle sensor SZL (INPA)
- Calibrated the DSC unit (INPA)
- Calibrated the DSC Sensor (INPA)
- Venting routine for DSC unit

After all this interim steps no faults has been stored in the DSC unit until test drive. Once I activated the Cruse Control during test drive the yellow CC sign with exclamation mark and gong has appeared on the KOMBI screen (Normally by CC $540 it shows adjusted speed number). But the car could hold the speed and it works like a usual CC $540 except for yellow CC sing and a gong by speed adjustment. No Brakes function was present.

After reading the Faults two faults have been stored in the DSC unit:
D360 - PT-CAN Motronic_4 Plausibilitaet
D362 - PT-CAN Motronic_5

INPA provides different discription:
D362 - No message (ACC,0xAC) receiver DSC, transmitter ACC
D362 - No message (ACC,0xB4) receiver DSC, transmitter ACC

I am wondering why DSC it expecting a message from the ACC? I have not installed the ACC yet, because I am retrofiting the $544 only.

It probably due to PT Can Bus tapping problem that you share in thread #179

Do you have any idea how to resolve it? Or it might be a similar problem that my DME/DDE unit does not understand a 6cyl DSC unit...
Hi, I would like to help if I can.

First of all, these 2 error codes (D360 & D362) are WheelTorqueDrive command from DME if I understand correctly.

Can-ID Length Register Description Source
0x0AC 8 WheelTorqueDrivetrain2 DME PT-CAN
0x0B4 8 WheelTorqueDriveTrain1 DME PT-CAN

May I know the part no. of the DSC unit you just replaced and the DME you have in your BMW E91 318d ??
Appreciate 0
      04-01-2021, 12:40 AM   #259
hupchye
Private
hupchye's Avatar
Malaysia
34
Rep
63
Posts

Drives: 2010 BMW 320i E92
Join Date: Jan 2020
Location: Malaysia

iTrader: (0)

Garage List
Quote:
Originally Posted by hupchye View Post
Hi, I would like to help if I can.

First of all, these 2 error codes (D360 & D362) are WheelTorqueDrive command from DME if I understand correctly.

Can-ID Length Register Description Source
0x0AC 8 WheelTorqueDrivetrain2 DME PT-CAN
0x0B4 8 WheelTorqueDriveTrain1 DME PT-CAN

May I know the part no. of the DSC unit you just replaced and the DME you have in your BMW E91 318d ??
2nd thing is to know more about your retrofit info & steps :

1) Retrofit $544 (CC with Brakes) from $540 for 4cyl BMW, you may need a different KOMBI cluster
2) For info, you may not need to replace the DSC Sensor under the front seat
3) When you Code with NCSExpert, did you delete VO $540 and add VO $544, FA_Write to CAS & NFRM modules ?
4) After you Coded your DCS module with default settings, did you change the coding setting for :
ECBA (Electronic Control Brake Actuation) to aktiv ?
5) When the yellow CC sign appeared during test drive, what is the BMW CC-ID code for this yellow CC sign ? (by Pressing BC button on the left stalk and hold it pressed for 5 seconds)
Appreciate 0
      04-01-2021, 02:15 AM   #260
aeroshurik
Registered
aeroshurik's Avatar
Germany
0
Rep
4
Posts

Drives: BMW 3er E91 318d
Join Date: Mar 2021
Location: Berlin

iTrader: (0)

Hi, thanks for your quick replay.

I have replaced my stock DSC unit (MK60) PN: 6789301 by a 6 cyl DSC unit (MK60E5) PN: 6789304. I have flashed/updated it from it's current pn 6789304 to 6862873.

My DME/DDE unit D70N47B0 is PN: 8506434 (8509547 Flash PN)

Answering your last thread:

1) Yes you are right I have replaced my KOMBI cluster (LOW) PN:9221011 to a HIGH KOMBI cluster PN:9242396 (you can see it also in attached pictures). I need to send it to the company that they can reset the e-prom etc. So now it is fully working no issues. The only I need to do is to code manually SZ_ANSTEUERUNG to aktiv. Otherwise the CC arrow will not work/shown the adjusted speed.

2)But I did it because It was the Sensor which fits to my new DSC as per ETK. The 4 pin connector is different that is why I have to remove the locking feature and it fits to the new Sensor now.

3) Yes I did exactly the same way: deleted VO $540 and added VO $544, FA_Write to CAS & NFRM modules.

4) This one is new for me and I was trying to code it as you proposed. But the FSW_PSW.TRC (attached) file does not contain ECBA aktive or nicht_aktive either. There are only three places where ECBA abbriviation is presented:

C0F_ECBA_DCC
wert_02
C0F_GMK_ECBA_HA
wert_01
C0F_GMK_ECBA_VA
wert_04

5) When the yellow CC sign appeared during test drive (above 30 km/h) it disappears so quick (after 1-2 sec) and then the KOMBI cluster does not show anything wrong. Pressing BC button on the left stalk and hold it pressed for 5 seconds: does not bring anything tryed many times. As mentioned before the CC funktion is working as usuall. the Car holds the speed and increases if I push the CC control nothing wrong from the funtionality of the CC point of view.

If I aktivate CC by the speed less than 30 km/h than there is no error message. It shows just CC sign with dashes see attached.

Thanks for your help and let me know if you need anything else.
Attached Images
  
Attached Files
File Type: txt FSW_PSW_TRC.txt (2.4 KB, 2 views)
Appreciate 0
      04-01-2021, 07:34 AM   #261
hupchye
Private
hupchye's Avatar
Malaysia
34
Rep
63
Posts

Drives: 2010 BMW 320i E92
Join Date: Jan 2020
Location: Malaysia

iTrader: (0)

Garage List
Hi, I think you have done all the coding correctly.

Due to I have C07 version of DSC and you have C0F version,

C0F_ECBA_DCC - ELECTRONIC CONTROL BRAKE ACTUATION
wert_02

for you is correct.

I have few questions on the picture you attached.
(1) Did the cruise speed pointer works during your test drive ?
(2) When the yellow CC sign appeared during test drive (above 30 km/h) it disappears so quick (after 1-2 sec). The error sign disappear too ?
Attached Images
 
Appreciate 0
      04-01-2021, 01:58 PM   #262
aeroshurik
Registered
aeroshurik's Avatar
Germany
0
Rep
4
Posts

Drives: BMW 3er E91 318d
Join Date: Mar 2021
Location: Berlin

iTrader: (0)

Hi,

(1) It is a strange behavior of the cruise speed pointer. So if I code KOMBI cluster with VO $544 (default for my current equipment) the pointer does not work despite SZ_ANSTEUERUNG parameter is aktiv. But if I code it manually with VO $540 with SZ_ANSTEUERUNG aktiv then the cruise pointer works as usual. SZ_ANSTEUERUNG is nicht aktive by VO $540. The yellow CC sign appears at both $540 and $544 VO Codings.

(2) The only I can see is the yellow CC sign for 2 sec. max. After this the yellow CC sign disappears together with the small error sign (highlighted by you). the KOMBI cluster turns to normal view i.e clean without any error messages. Not the same when you have a low fuel level for example. As far as I believe the yellow color is informing that the function is just partially compromised. As mentioned before the CC is functioning as usual.

Last edited by aeroshurik; 04-01-2021 at 03:19 PM..
Appreciate 0
      04-01-2021, 07:19 PM   #263
hupchye
Private
hupchye's Avatar
Malaysia
34
Rep
63
Posts

Drives: 2010 BMW 320i E92
Join Date: Jan 2020
Location: Malaysia

iTrader: (0)

Garage List
Quote:
Originally Posted by aeroshurik View Post
Hi,

(1) It is a strange behavior of the cruise speed pointer. So if I code KOMBI cluster with VO $544 (default for my current equipment) the pointer does not work despite SZ_ANSTEUERUNG parameter is aktiv. But if I code it manually with VO $540 with SZ_ANSTEUERUNG aktiv then the cruise pointer works as usual. SZ_ANSTEUERUNG is nicht aktive by VO $540. The yellow CC sign appears at both $540 and $544 VO Codings.

(2) The only I can see is the yellow CC sign for 2 sec. max. After this the yellow CC sign disappears together with the small error sign (highlighted by you). the KOMBI cluster turns to normal view i.e clean without any error messages. Not the same when you have a low fuel level for example. As far as I believe the yellow color is informing that the function is just partially compromised. As mentioned before the CC is functioning as usual.
(1) SZ_ANSTEUERUNG is the only parameter you changed during VO $540 or VO $544 Coding ?
What about
ACC_AUSSTATTUNG - CRUISE CONTROL INSTALLED ??
Appreciate 0
      04-02-2021, 04:16 AM   #264
aeroshurik
Registered
aeroshurik's Avatar
Germany
0
Rep
4
Posts

Drives: BMW 3er E91 318d
Join Date: Mar 2021
Location: Berlin

iTrader: (0)

In order to avoid confusion I've just compared two default TRC files for KOMBI coding with VO $540 versus $544. see TRC's attached.

There are only 5 parameters that are different between VO $540 vs $544 in the TRCs. see below in attached Table.

So but if I change SZ_ANSTEUERUNG (aktiv) manually in default TRC file for $ 540 than the cruise speed pointer works by CC activation, but with yellow cc sign.
Attached Images
 
Attached Files
File Type: txt TRC_VO540_default.txt (8.7 KB, 1 views)
File Type: txt TRC_VO544_default.txt (8.7 KB, 1 views)
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 12:53 AM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST