E90Post
 


Studio RSR
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > NA Engine (non-turbo) / Drivetrain / Exhaust Modifications > N52 Yellow engine light. Engine shutdown. 2A87 DME



Reply
 
Thread Tools Search this Thread
      Yesterday, 05:39 AM   #1
Bright1G
Registered
0
Rep
1
Posts

Drives: E92
Join Date: Jun 2022
Location: Lithuania

iTrader: (0)

N52 Yellow engine light. Engine shutdown. 2A87 DME

Hello, (sorry if you wont be able to understand what im trying to say but i'll try my best)

So basically i brought my car back from Mechanic which swapped my ruined engine to a new one because timing chain broke down and had to buy new engine so everything is fine at this part they changed pretty much everything in the new engine including chains and etc so car runs fine, i drove like ~500km which isnt that much and yesterday i drove to a local market so at one point i reached like 5000 RPM which isnt that much for this engine as far as i know, it shouldnt cause any issues if u do it sometimes, its even healthy for your engine, but once i stopped in a parking place and shutdown my engine and turn it on back i noticed that i got yellow engine light which confused me but at that point car started without any issues no weird sounds in engine block, so i just ingored it and though when i get back i will check it on laptop what it says so i drove like 9km and in roundabout my engine shutdown when i droped my gear to a neutral it fucking scared the shit out of me i though no way my timing chain just broke for no reason, even tho its brand new chain it cant be, so fingers crossed i tried to start my engine to make sure but guess what it started like a charm no particular weird sounds, like nothing happened so i checked my engine temparature it showed ~107 i though maybe it shutdown because it got overheated or something because that day it was reaching 86 degrees so maybe its because of that, so i drove more and i parked my car again so left it for like 3-4hours and came back i though i wont see this engine light again but it was still showing, so i drove back home and when i drove like 4km my engine shutdown again on neutral gear i was like wtf is going on but after that it didnt shutdown again when i drove back home it was just fine, car sounded fine too, didnt noticed any traction loss, no more engine shutdowns on neutral gear, so i parked my car and left it for next day and today i went to do car diagnostic to see what it says and this is what we got



So he checked vanos graphs it showed that its fine, but the only issue that we could point out is sensors in that graph as you can see they should be pretty much stable but in my situation they going down when this graph should be stable like in that picture from 0=>20, so he cleared all of the errors and told me to drive more and see if this engine light comes back again and if so come back again to see if it shows same fault. So i drove back home everything is fine car runs fine, no engine light so far. But it still scared the shit out of me because latest maintenance caused me 3k eu because i was lazy to change my timing chain so now im scared of every single issue i face with this car.

But this is what i have in mind and what i did
1. Can be just a electronic fault that caused this yellow engine light and caused the engine to shutdown two times.
2. Low oil level? Probably not i checked and it showed that its on minum level
3. Oil filter cap is intact? Yes its intact, no issue with that
4. Vanos solonoid sensor is fucked up which is causing this. Idk they didnt changed my vanos solonois to new ones it was taken from my old engine, so its a possibility
5. Broken vanos bolt? Maybe 5000 RPM broke the bolt like in this picture


But again if its broken vanos shouldnt be significant loss in traction and weird sound in engine? So now i will drive this car a little bit more and see if this fault accures again or not but so far it runs smooth without any issues, but it still would be great to know what i can expect.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 01:54 AM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST