E90Post
 


TNT Racewerks
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > Air conditioning problems!



Reply
 
Thread Tools Search this Thread
      06-18-2005, 12:25 PM   #1
Gator
New Member
3
Rep
13
Posts

Drives: 2006 330i
Join Date: Jun 2005
Location: Florida

iTrader: (0)

Angry Air conditioning problems!

Anyone having problems with their AC cooling? My cooling seems to work sporadically. I have been on 2 short trips since picking up my car 2 weeks ago and during both trips the AC stopped cooling after an hour or so on the road.

The system stopped cooling and the circulation dropped off to a very light movement of air. Selecting the MAX cooling feature did improve the situation. The next day it seemed to go back to functioning normally on short drives.

I have an appointment for service on Monday. If anyone else has experienced this issue, please advise. Thanks
Appreciate 0
      06-18-2005, 04:17 PM   #2
DaveCM5
Second Lieutenant
85
Rep
252
Posts

Drives: 2014 M5 Sapphire Black
Join Date: Jun 2005
Location: Florida

iTrader: (0)

All I can tell you is that sometimes in mine if the temperature outside is near the temp inside then the AC seems to go down to next to nothing. But it's still comfortable in the car. If I dial the temp down from there it will come on again.

Good luck.

-Dave C. '06 330i
Appreciate 0
      06-18-2005, 08:53 PM   #3
AudiA4
Major
AudiA4's Avatar
535
Rep
1,396
Posts

Drives: 2014 335i (EB) 6MT, M Sport
Join Date: May 2005
Location: Little Rock, AR, USA

iTrader: (0)

Mine quit altogether!

See my post above. I discovered that my A/C quit altogether upon returning from a week long vacation! Honestly, it never cooled well when it was "working" - fan speed/volume always erred on the very low side. I noted that the Edmunds online 330-A4 review commented about A/C problems as well.
Appreciate 0
      12-27-2005, 10:50 PM   #4
Wounded Knee
New Member
0
Rep
7
Posts

Drives: 2006 325i
Join Date: Dec 2005
Location: Fort Lauderdale

iTrader: (0)

Identical AC problem

Quote:
Originally Posted by Gator
Anyone having problems with their AC cooling? My cooling seems to work sporadically. I have been on 2 short trips since picking up my car 2 weeks ago and during both trips the AC stopped cooling after an hour or so on the road.

The system stopped cooling and the circulation dropped off to a very light movement of air. Selecting the MAX cooling feature did improve the situation. The next day it seemed to go back to functioning normally on short drives.
I took my E90 on its first roadtrip this weekend and experienced exactly the same thing. Now around town it is working perfect. I need to take the car in next month to have the bluetooth fixed anyway, any suggestions on the source of the problem so that I can point my service advisor in the right direction? Thanks.
Appreciate 0
      12-28-2005, 12:32 AM   #5
deutsch100
2019 i3, 2017 M6 convertible, 2018 G63
267
Rep
499
Posts

Drives: i3, M6, G63
Join Date: Dec 2005
Location: Calabasas, CA

iTrader: (0)

In general I think my AC works well, but I too have noticed that there are many times when the fan speed kicks itself down after cooling the cabin, then the fan speed is insanely slow (almost non existent). I have to then set the temp down to get the fan going again.

Let us (me) know what ya'll find out. Danke
Appreciate 0
      12-28-2005, 01:54 AM   #6
aem
Why pay more for nothing?
Australia
11
Rep
301
Posts

Drives: .
Join Date: Dec 2005
Location: Australia

iTrader: (0)

Send a message via MSN to aem
This makes it 3 major probs that i have read on e90post... if it happens for 330, 325, i can't see why it can't happen to the 320 too...
Appreciate 0
      12-28-2005, 02:35 AM   #7
E90Fleet
Lieutenant General
South Africa
1137
Rep
10,197
Posts

Drives: BMW
Join Date: Apr 2005
Location: South Africa

iTrader: (0)

There was a probem with a few cars loosing coolant

The dealer can check the pressure and look for a leak if the pressure is down
Appreciate 0
      12-28-2005, 03:06 AM   #8
JamieA
Colonel
JamieA's Avatar
Australia
64
Rep
2,176
Posts

Drives: G01 X3 M40i
Join Date: Sep 2005
Location: Adelaide, Australia

iTrader: (0)

I just spent yesterday driving through the outback of Australia, with outside temperatures of 40 deg C constantly through the drive (104F) The air con didn't miss a beat, the cabin stayed perfectly cool the whole time, and I was very impressed as it was the first time the a/c had a good workout.

I could feel the heat radiating through the windscreen on the back of my hands, and the cabin stayed the set temp - 22 Deg C (72F)

Pleased to say the car didn't miss a beat either, there was a strong headwind, and I averaged 8.4 l/100k (don't know what that is in MPG sorry - I get 11.5 l/100k in the city) great fuel economy given the circumstances.
__________________
'05 E90 325i | '06 E90 325i | '08 E90 325i LCI | '13 F30 328i M-Sport | '14 F10 535d M-Sport
Current: '19 G01 X3 M40i
Appreciate 0
      12-28-2005, 05:33 AM   #9
David328M-Sport
Brigadier General
Australia
79
Rep
3,561
Posts

Drives: F30 M-Sport 328i Estoril Blue
Join Date: Jun 2005
Location: Melbourne Australia

iTrader: (0)

no problems with my a/c working overtime during the summer days.

best 3 series bmw a/c ever!
__________________
328i M-Sport, Estoril Blue, Carbon XP 35 Tint, front heated seats, black Dakota, Sports Suspension, Anthracite Headliner, HUD, Pro Nav, Sunroof, hk 600w, Bi-Xenon, 19" 403M wheels, Reversing Camera, DAB+, Xenon, BT Ext Connect. JB4 on Map 2 with Catless DP produces awesome performance in Sport.
Appreciate 0
      12-28-2005, 10:45 AM   #10
Broken1
E90 Addict
Broken1's Avatar
South Africa
109
Rep
2,040
Posts

Drives: E90 325i Sparking Graphite
Join Date: May 2005
Location: Johannesburg

iTrader: (0)

Garage List
Quote:
Originally Posted by David325Australia
no problems with my a/c working overtime during the summer days.

best 3 series bmw a/c ever!
I second that...in this heat wave we've been having here - the a/c has been working overtime...AND very nicely!!!

Keeps the sweat out of my face after all that gear changing (See Dave, I'm mocking myself now...look what you've done!!!)
Appreciate 0
      02-06-2006, 10:06 PM   #11
bmwlano
Registered
0
Rep
1
Posts

Drives: 2006 330i
Join Date: Feb 2006
Location: New Orleans

iTrader: (0)

Confirming AC Problems

Update 14 Feb: Dealer and BMW Tech decided that the condenser is the cause of the problem and they are now replacing it. This means taking out the entire dash. Future problems - electrical and vibration???

Original Post: 330i purchased in May 2005. Problem commences with warm air from the passenger vents. Eventually, hot air from both sides. Have had this happen four times since June 2005. The last repair was made in Nov. The dealer said there was a retro for the service valve. Waited 3 weeks for the valve. The car has just been returned again this week for the same problem again - no refrigerated air.

Last edited by bmwlano; 02-14-2006 at 12:54 PM.. Reason: Update 14 Feb
Appreciate 0
      06-05-2006, 12:11 PM   #12
Will M
New Member
Will M's Avatar
0
Rep
8
Posts

Drives: E91 320d SE
Join Date: Mar 2006
Location: UK

iTrader: (0)

I have right hand drive e91 320d se.

I am getting loads of cool air out of the left hand vents, but intermitant ambient/cool air out of the right hand side. Also I think it's reading the outside air temp about 3-4 degrees C too low.

When i have both sides set to 16 degrees C I get a temperature at the vent of say 4 C on the left and 22 C on the right. Then say half an hour later its fine nice and cool on both sides. Someone suggested it's a dogdy temperature sensor on the right hand side. any Ideas ??
Appreciate 0
      06-06-2006, 04:04 PM   #13
thebigman
Private First Class
thebigman's Avatar
Scotland
2
Rep
126
Posts

Drives: E90 320d SE
Join Date: Apr 2005
Location: Scotland

iTrader: (0)

Quote:
Originally Posted by Will M
I have right hand drive e91 320d se.

I am getting loads of cool air out of the left hand vents, but intermitant ambient/cool air out of the right hand side. Also I think it's reading the outside air temp about 3-4 degrees C too low.

When i have both sides set to 16 degrees C I get a temperature at the vent of say 4 C on the left and 22 C on the right. Then say half an hour later its fine nice and cool on both sides. Someone suggested it's a dogdy temperature sensor on the right hand side. any Ideas ??
I think the air-con on the 3 is poor compared to other cars in the same segment.

There are reports from US owners of the gas leaking from the air-con system - indeed this has happened to my 320d. Although I was not aware of other UK owners having this problem.
Appreciate 0
      06-06-2006, 04:09 PM   #14
LarryK1000
Larry from Los Angeles
10
Rep
296
Posts

Drives: 2006 330i
Join Date: Mar 2006
Location: Los Angeles (SFV)

iTrader: (0)

Just got my 330: Question?

The A/C works fine with the compressor on. But, I noticed that when I switch off the compressor (when it's cold in the a.m.), it seems that the car is a lot warmer than the temperature (71) that I've selected. If I turn on the compressor, the car is fine.

I just turned in my Mercedes E (have had 7 Mercedes and this is my third BMW) and I've NEVER noticed this happening. As long as it's colder outside, the inside has always stayed as comfortable as if I had the compressor on.

Anyone else noticing this? You should NOT have to turn the TEMP down to compensate. Otherwise, what's the thermostat for?

Thanks.
Appreciate 0
      07-03-2006, 10:45 AM   #15
arcticpiper
New Member
3
Rep
12
Posts

Drives: 2011 335xi
Join Date: Oct 2005
Location: canada

iTrader: (0)

I just got back from a (hot) weekend away and had exactly the same problem.
The outside temp was around 28deg C and with the A/C set at 18deg on auto it would work for an hour then the system stopped cooling and the fan speed dropped right down. Hitting the max button had no effect. I eventually turned it all off and sweated for 15mins then turned it back on to auto again and it started working again. On a 6hr trip this became very annoying. Phoning the dealer again today - it's already had a camshft replaced and the central door locks - very disappointed with my first BMW.............

Got a call from the dealer - they say it's the Evaporator Valve which has a tendency to "freeze up" when the A/C is being used to the max. Part on order - car off the road for two days.

Last edited by arcticpiper; 07-04-2006 at 11:38 AM..
Appreciate 0
      07-12-2006, 12:56 PM   #16
Will M
New Member
Will M's Avatar
0
Rep
8
Posts

Drives: E91 320d SE
Join Date: Mar 2006
Location: UK

iTrader: (0)

My e91 went to the dealer last week. Said it needed a new compressor. That arrived and was fitted today. No change. if anything its worse.

They have sent all the data to Germany and are waiting for a reply.

Its starting to really bug me now it hot..
Appreciate 0
      07-12-2006, 02:30 PM   #17
ska///235i
***** noob
ska///235i's Avatar
United_States
955
Rep
10,506
Posts

Drives: 325xi>M235i>428GCx Mspor
Join Date: Sep 2005
Location: Boston

iTrader: (34)

Garage List
2006 325xi  [0.00]
my problem is a lil off-topic
when my AC is on for more then 15 minutes, I can hear a slight rattle coming from the front (near/under the engine). Noticeable at slow speeds and bumpy roads. Sounds like a drum sound as if something is loose.
__________________
2006 325xi (Sold)
2014 M235I (Current)
2015 428xi Gran Coupe (STB)
Appreciate 0
      07-12-2006, 03:20 PM   #18
wws341234
Private First Class
9
Rep
102
Posts

Drives: 325i/E90/MT/jet black
Join Date: Mar 2006
Location: Los Angeles, CA

iTrader: (1)

Mine only works on driver's side, passenger's side is practically blowing out warm air! I went to dealer twice to fix it and both times they said nothing was wrong. They reprogrammed the car, replaced something, and now i'm having the same freakin' problem. Now i'm just too lazy to go back again to get it fix (maybe it's the heat making me lazy...)
Appreciate 0
      05-16-2010, 10:10 PM   #19
BMWE9X
New Member
0
Rep
16
Posts

Drives: F30 328i sedan -- E46 M3 6MT
Join Date: Jul 2009
Location: GA

iTrader: (0)

Quote:
Originally Posted by arcticpiper View Post
I just got back from a (hot) weekend away and had exactly the same problem.
The outside temp was around 28deg C and with the A/C set at 18deg on auto it would work for an hour then the system stopped cooling and the fan speed dropped right down. Hitting the max button had no effect. I eventually turned it all off and sweated for 15mins then turned it back on to auto again and it started working again. On a 6hr trip this became very annoying. Phoning the dealer again today - it's already had a camshft replaced and the central door locks - very disappointed with my first BMW.............

Got a call from the dealer - they say it's the Evaporator Valve which has a tendency to "freeze up" when the A/C is being used to the max. Part on order - car off the road for two days.
"bmwlano" mentioned above that the problem was the compressor. Here you said it seems to be the evaporator valve... so which is it? Has anyone else with this problem gone to the dealer for a 411 on the intermittent A/C motor problem? In the E46 I replaced the "final stage unit" (blower motor resistor) to fix this exact same problem, but the E90 A/C is setup differently so I'm not sure if it is something like the "blower regulator" but from the above posts it seems to be the condenser or evaporator valve. Advice would be much appreciated if anyone else had this problem and fixed it. Thanks ahead of time!
Appreciate 0
      05-16-2010, 10:15 PM   #20
newbimm
Private First Class
newbimm's Avatar
2
Rep
128
Posts

Drives: 08 Silver 328xi 6sp
Join Date: Sep 2009
Location: NOVA

iTrader: (1)

I just took my car in for the intermittently working AC. Of course when I get to the dealer it's working perfectly so they said they couldn't fix anything. They told me if it ever happens just drive right up and let someone look at it....this would be fine if I didn't have things to do and places to be. Oh well, if I find something out I'll let you know.
__________________
'08 Silver 328xi Sedan| 6MT | ZSP | ZPP | Clear Bra | BlackOut Grille | 30% Tint | BMS CDV | Mtec V3 |

byebye '03 Audi A4 1.8t
Appreciate 0
      05-17-2010, 09:35 AM   #21
RoundelM3
Major General
RoundelM3's Avatar
United_States
1059
Rep
6,061
Posts

Drives: 15 M3 Sedan, 16 228i Cabrio
Join Date: Apr 2010
Location: Leland, NC

iTrader: (2)

Garage List
2015 BMW M3  [0.00]
2016 BMW 228i  [3.00]
Never had an a/c problem here in TX with any of the three 3-series I've owned. One thing to check would be refrigerant...if you have too much or too little, your system will
"freeze up" and not provide any cooling. Had that happen to one of the units on my home (all operate on same principle). So I'd recommend you have the dealer check it or take it to a reputable A/C shop that knows foreign cars and can set up and read the gauges properly. Might be as simple as adding some r-134 or as complex as replacing a component.
__________________

2015 F80 ///M3 Sedan 7DCT Tanzanite, 2016 228i M-Sport Cabrio 8AT Melbourne
Appreciate 0
      05-17-2010, 09:55 AM   #22
reprod
Lieutenant Colonel
United_States
99
Rep
1,689
Posts

Drives: '16 M3 ZCP
Join Date: Apr 2008
Location: Bay Area, CA

iTrader: (6)

Wow talk about "thread resurrection"....
__________________
'11 Space Grey E92 335xi M-Sport (KWv1 Coils | Saddle Brown | Bamboo) (Returned)
'14 Mineral Grey F32 335i M-Sport (Dinan DHP | LED Lights | Coral Red | Hexagonal Aluminum) (Returned)
'16 Mineral Grey F80 M3 ZCP
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 07:57 PM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST