E90Post
 


The Tire Rack
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > NA Engine (non-turbo) / Drivetrain / Exhaust Modifications > N52 - CEL, multiple codes (VANOS, cats)



Reply
 
Thread Tools Search this Thread
      08-12-2019, 04:53 AM   #1
midgard_coil
New Member
0
Rep
9
Posts

Drives: E91 325i Touring
Join Date: Aug 2018
Location: Budapest

iTrader: (0)

N52 - CEL, multiple codes (VANOS, cats)

Hi!

On my '06 325i (N52B25A, EU spec. 218hp) the CEL came on, checked for error codes, turned out there's plenty. VANOS-related codes are 2A82, 2A87 (VANOS intake/exhaust jammed mechanically), I also have 29F4 and 29F5 (cats. efficiency below threshold) and 2EE3 (something related to the coolant temp. sensor).

What I've already did/changed:
  • new spark plugs
  • new VANOS solenoids
  • cleaned VANOS filters
  • cleaned injectors
  • new oil/filters (obviously)

The symptoms - apart from the CEL and codes - are:
  • oil consumption (~ 1quart/1000 miles, 1L/1500km)
  • occasional loss of power (turning the engine off, then on again solves the issue)

Additional info/thoughts: The car is not tuned, everything is stock. She has 270.000km/170.000miles on it, so my cats may well be shot given the amount of oil consumption, but I don't want to change the cats and ruin the new ones also, first it should be wise to track the cause of oil consumption. How should I proceed with that?

I'm also aware of the infamous camshaft bearing ledge issue (when the camshaft rings can carve a groove into the head/bearing ledge) which if present, should explain the VANOS-related codes and occasional loss of power. On the other hand I'm not sure about oil-consumption - the car was probably cared after, engine wear should not be the issue (though it may be). Any tips on this one? CCV system maybe? I also have no idea about the coolant temp. sensor code.

I might pull the head cover sometimes soon (I'm having a mild oil-leak issue there anyway), so I'll have the chance of a thorough examination of the cams/head area, could also change the CCV if those were faulty. What other parts should I be worrying about? How should I proceed with diagnosing the cause of the problem?

Thank you for any suggestions, cheers!
Gabor
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 01:42 PM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST