E90Post
 


The Tire Rack
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > NA Engine (non-turbo) / Drivetrain / Exhaust Modifications > No throttle response after starter change



Reply
 
Thread Tools Search this Thread
      10-17-2021, 03:28 PM   #1
phsullivan
New Member
3
Rep
15
Posts

Drives: 2006 BMW 330i
Join Date: Sep 2016
Location: Tacoma, WA

iTrader: (1)

No throttle response after starter change

I just swapped in a new starter into my 2006 330i. While I had the intake manifold out I inspected the DISA valve and found that the large one is spinning freely on its shaft and the upper pin holding it in is broken. I decided to remove the damper flap and reinstall the unit until I can get a replacement later in the week.

When I start the car everything sounds normal. It idles nice and smooth. But when you push the gas pedal (with the car in neutral) the engine responds very slowly and will not rev past about 3k rpm with my foot on the floor. It takes to even get there. Driving the car, it can barely accelerate to 25 mph and can not hold that speed on any type of incline.

Is all of this caused by the missing DISA flap? After resecuring the flap I tried reinstalling it, which still flops around freely on the shaft, but this did not make any other difference.

If it is not the missing/non-functional flap, any suggestions on what might be happening? Or anything that I might have left disconnected that would cause this issue?
__________________
2006 330i
Appreciate 0
      10-17-2021, 08:23 PM   #2
E92_William
Captain
E92_William's Avatar
United_States
829
Rep
721
Posts

Drives: 2008 BMW 328xi
Join Date: Apr 2021
Location: South Florida

iTrader: (0)

Could you check if there's any sort of obstruction in the intake track? Maybe unplugged throttle body? Not having a disa shouldn't have this effect on it.
__________________
Airplane Mechanic
BMW Masochist
Appreciate 0
      10-18-2021, 12:59 AM   #3
3PedalJake
Neo-Luddite
3PedalJake's Avatar
United_States
2264
Rep
1,254
Posts

Drives: '06 325i, 330i 6MT RWD Sport
Join Date: Nov 2020
Location: NJ

iTrader: (0)

Garage List
2006 BMW 330i  [0.00]
IDK if this is what you did but this is how it would respond if you disconnected power to the valvetronic motor.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 02:08 AM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST