E90Post
 


Bimmer Retrofit
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Unknown misfires



Reply
 
Thread Tools Search this Thread
      06-14-2018, 10:02 PM   #1
Chrisred
Captain
Chrisred's Avatar
Canada
32
Rep
757
Posts

Drives: BMW 335xi coupe
Join Date: Jan 2010
Location: Montreal, Canada

iTrader: (0)

Unknown misfires

Hi, I keep getting several cylinder misfires on WOT only above 5000rpm.

Have RB turbos on 100% meth, FBO, upgrades LPFP.

Tried NGK 2 step coder plugs and stock plugs. No change

New coils.

Injectors are index 12. 4 year old. Doesn't seem like I have issue there as no morning misfires due to leaks. And misfires are always on different cylinders. Coded well and decouplers in place.

Carbon cleaning done as well.

Logged HPFP & LPFP with Trebila and everything is perfect. Logs are perfect until misfires.

Have stage 3+ spec clutch and flywheel.


No other codes. Just the misfires on several cylinders.

O2 sensors fairly new.

Any ideas.?? Anyone??

Do I change all injectors or get upgraded coils??
__________________
JB4 cp-e IC AMS exhaust BMS DCI AR DP's METH
19" VMR VB3 Stoptech BBK TC KLINE VORSHLAG
Appreciate 0
      06-15-2018, 10:27 AM   #2
Jmore92
Private First Class
25
Rep
190
Posts

Drives: 08 titanium silver e90 335i
Join Date: Mar 2016
Location: Ca

iTrader: (0)

Pre cat o2 sensors can casue missfires across all cylinders. I also remember reading a faulty or clogged pcv system can cause missfires.

My mutiple cylinder missfire issue turned out to be injectors.
Appreciate 0
      06-15-2018, 10:36 AM   #3
CeeWhizzle
Lieutenant
Canada
54
Rep
426
Posts

Drives: 2009 E92 335i
Join Date: Feb 2014
Location: Regina, SK

iTrader: (1)

Check your valve cover for any cracks or leaks along with the PCV system for the same thing. As well, make sure your injectors are coded properly. Other than that, try a compression test just to be sure.
Appreciate 0
      06-19-2018, 09:46 AM   #4
Chrisred
Captain
Chrisred's Avatar
Canada
32
Rep
757
Posts

Drives: BMW 335xi coupe
Join Date: Jan 2010
Location: Montreal, Canada

iTrader: (0)

All of the above checked. Any other ideas????
__________________
JB4 cp-e IC AMS exhaust BMS DCI AR DP's METH
19" VMR VB3 Stoptech BBK TC KLINE VORSHLAG
Appreciate 0
      06-19-2018, 09:55 AM   #5
CeeWhizzle
Lieutenant
Canada
54
Rep
426
Posts

Drives: 2009 E92 335i
Join Date: Feb 2014
Location: Regina, SK

iTrader: (1)

Quote:
Originally Posted by Chrisred View Post
All of the above checked. Any other ideas????
Maybe inspect your MOSFETS or test them to ensure none are damaged. They can cause issues with your injectors.

Also do some testing with WOT runs without meth.
Appreciate 0
      06-20-2018, 10:14 AM   #6
Chrisred
Captain
Chrisred's Avatar
Canada
32
Rep
757
Posts

Drives: BMW 335xi coupe
Join Date: Jan 2010
Location: Montreal, Canada

iTrader: (0)

MOSFET inspection was done. Everything perfect. Also have done run without meth and yes it still misfires.

Anyone try upgraded coils??

Also what are symptoms of failing injectors either then the morning cold start issue, cause I don't seem to have any symptoms.

So from what I see it's either coils need upgrading or all new injectors....
__________________
JB4 cp-e IC AMS exhaust BMS DCI AR DP's METH
19" VMR VB3 Stoptech BBK TC KLINE VORSHLAG
Appreciate 0
      06-21-2018, 05:05 PM   #7
CeeWhizzle
Lieutenant
Canada
54
Rep
426
Posts

Drives: 2009 E92 335i
Join Date: Feb 2014
Location: Regina, SK

iTrader: (1)

Well I had CONSTANT missfire problems at WOT when I was FBO on meth. I changed everything you can think of, even the coils. Then I did the Audi R8 coil pack conversion and since then it has been perfect. You never know. However, I may think your issue could be associated with injectors, but what you can do is use the run test or whatever it is called in INPA which tests the injectors. Other than that, I can only imagine it being some simple issue like a vacuum leak.

I did once have an issue with my coil packs in the past where it was a constant missfire in Cyl 4, but would throw a code for all 6 cyls. It ended up being the connector in Cyl 4 coil pack that had a pin which backed out of its slot somehow..
Appreciate 0
      06-25-2018, 11:40 AM   #8
Chrisred
Captain
Chrisred's Avatar
Canada
32
Rep
757
Posts

Drives: BMW 335xi coupe
Join Date: Jan 2010
Location: Montreal, Canada

iTrader: (0)

Quote:
Originally Posted by CeeWhizzle View Post
Well I had CONSTANT missfire problems at WOT when I was FBO on meth. I changed everything you can think of, even the coils. Then I did the Audi R8 coil pack conversion and since then it has been perfect. You never know. However, I may think your issue could be associated with injectors, but what you can do is use the run test or whatever it is called in INPA which tests the injectors. Other than that, I can only imagine it being some simple issue like a vacuum leak.

I did once have an issue with my coil packs in the past where it was a constant missfire in Cyl 4, but would throw a code for all 6 cyls. It ended up being the connector in Cyl 4 coil pack that had a pin which backed out of its slot somehow..
Thanks I will check on all that. Thinking of ordering precision raceworks upgraded coil pack. What u guys think??
__________________
JB4 cp-e IC AMS exhaust BMS DCI AR DP's METH
19" VMR VB3 Stoptech BBK TC KLINE VORSHLAG
Appreciate 0
      09-07-2018, 12:52 PM   #9
Chrisred
Captain
Chrisred's Avatar
Canada
32
Rep
757
Posts

Drives: BMW 335xi coupe
Join Date: Jan 2010
Location: Montreal, Canada

iTrader: (0)

I changed injectors on cylinders 1-2-3 but still get misfires on several random cylinders.
Attached Images
  
__________________
JB4 cp-e IC AMS exhaust BMS DCI AR DP's METH
19" VMR VB3 Stoptech BBK TC KLINE VORSHLAG
Appreciate 0
      10-03-2018, 10:14 PM   #10
Chrisred
Captain
Chrisred's Avatar
Canada
32
Rep
757
Posts

Drives: BMW 335xi coupe
Join Date: Jan 2010
Location: Montreal, Canada

iTrader: (0)

Anyone??
__________________
JB4 cp-e IC AMS exhaust BMS DCI AR DP's METH
19" VMR VB3 Stoptech BBK TC KLINE VORSHLAG
Appreciate 0
      10-04-2018, 09:15 PM   #11
DCook
Private
9
Rep
51
Posts

Drives: 91 Fox
Join Date: Dec 2017
Location: Central IL

iTrader: (0)

How old are the coils and what brand? With age and mileage the heat cycle can kill them quickly. Usually replace with plugs, or at least i would. Its got enough spark down low but up high it cant keep up.
Appreciate 0
      10-21-2018, 12:24 AM   #12
Chrisred
Captain
Chrisred's Avatar
Canada
32
Rep
757
Posts

Drives: BMW 335xi coupe
Join Date: Jan 2010
Location: Montreal, Canada

iTrader: (0)

Quote:
Originally Posted by DCook View Post
How old are the coils and what brand? With age and mileage the heat cycle can kill them quickly. Usually replace with plugs, or at least i would. Its got enough spark down low but up high it cant keep up.
There about 2 yrs old
__________________
JB4 cp-e IC AMS exhaust BMS DCI AR DP's METH
19" VMR VB3 Stoptech BBK TC KLINE VORSHLAG
Appreciate 0
      10-21-2018, 07:50 PM   #13
SilverStreak18
Private First Class
28
Rep
189
Posts

Drives: 08 SGM 335i Coupe
Join Date: Jun 2016
Location: SC

iTrader: (2)

So you only tried the 2-step colder plugs and stock plugs? Try the 1-step colder NGK and gap them properly. Also make sure the grounds are tight on the engine, specifically the ones for the coils on the valve cover.
Appreciate 0
      10-27-2018, 02:10 PM   #14
Chrisred
Captain
Chrisred's Avatar
Canada
32
Rep
757
Posts

Drives: BMW 335xi coupe
Join Date: Jan 2010
Location: Montreal, Canada

iTrader: (0)

Quote:
Originally Posted by SilverStreak18 View Post
So you only tried the 2-step colder plugs and stock plugs? Try the 1-step colder NGK and gap them properly. Also make sure the grounds are tight on the engine, specifically the ones for the coils on the valve cover.
I've tried the 1 step as well before the 2 step. Same results unfortunately
__________________
JB4 cp-e IC AMS exhaust BMS DCI AR DP's METH
19" VMR VB3 Stoptech BBK TC KLINE VORSHLAG
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 10:28 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST