E90Post
 


ECS BMW
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing / Warranty > N54 Cold start misfire MYSTERY



Reply
 
Thread Tools Search this Thread
      06-24-2018, 06:32 PM   #1
ichrisppyy
Registered
0
Rep
2
Posts

Drives: 08 e92 335i
Join Date: May 2018
Location: New York

iTrader: (0)

Red face N54 Cold start misfire MYSTERY

okay so i have a 08 335i coupe. about 2 months ago i noticed rough idles only on cold start. few days later i throw a code for misfires in several cylinders. i bring the car to my mechanic and he thinks its leaking fuel injectors. he changes the spark plugs and walnut blasts carbon buildup and it still does it. time for new injectors. brand new index 12 injectors get put inand programmed and next morning car is still misfiring. car then goes to bmw and they warranty my hpfp. still misfires on cold starts. tried putting in a new sensor and still didnt fix it. any help would be much appreciated been carless for month now =[
Appreciate 0
      06-25-2018, 02:30 AM   #2
maarzz
E92 335i P/S/C Pkg Monteg blue
maarzz's Avatar
United_States
0
Rep
8
Posts

Drives: E92 335i P/S/C Pkg Monteg blue
Join Date: Jun 2011
Location: Boston

iTrader: (0)

Similarly, I have a 2007 335i manual, and lately, when I give it gas in 3/4/5/6 gear it misfires/starts to stall almost unless I downshift.. this is new and I had never experienced it before. 86K miles on it, bone stock...any suggestions on where to start looking? Also, my TPMS batteries are done I think... it went inactive.. any suggestions on what folks are doing? Thx
Appreciate 0
      06-25-2018, 07:38 PM   #3
adam_c
Private
Canada
6
Rep
77
Posts

Drives: e92 328i
Join Date: May 2018
Location: Calgary, AB

iTrader: (0)

Do you have oil in your Eccentric Shaft Sensor? I have similar symptoms as you, no misfire though

https://www.pelicanparts.com/BMW/tec..._Replacing.htm
Appreciate 0
      06-25-2018, 08:52 PM   #4
ichrisppyy
Registered
0
Rep
2
Posts

Drives: 08 e92 335i
Join Date: May 2018
Location: New York

iTrader: (0)

Quote:
Originally Posted by adam_c View Post
Do you have oil in your Eccentric Shaft Sensor? I have similar symptoms as you, no misfire though

https://www.pelicanparts.com/BMW/tec..._Replacing.htm
i dont think thatd have to do with cold start misfires would it?
Appreciate 0
      06-25-2018, 10:06 PM   #5
JUMAS
Private First Class
United_States
39
Rep
165
Posts

Drives: 2011 335i
Join Date: Mar 2018
Location: Tampa

iTrader: (0)

Quote:
Originally Posted by ichrisppyy View Post
i dont think thatd have to do with cold start misfires would it?
Wouldn't be a bad idea to inspect it, you can take a look with minimal disassembly.
Appreciate 0
      06-26-2018, 11:53 AM   #6
jwh335i
New Member
23
Rep
17
Posts

Drives: 2007 335i
Join Date: Jan 2015
Location: Newport Coast, CA

iTrader: (0)

N54 does not have valvetronic and so does not have an eccentric shaft sensor
Appreciate 0
      06-26-2018, 11:57 AM   #7
msjt
First Lieutenant
153
Rep
301
Posts

Drives: 335i e92
Join Date: Jan 2013
Location: queens

iTrader: (0)

What are the codes? Did you change the coil packs?
Appreciate 0
Reply

Bookmarks

Tags
cold, idle, misfire, mystery, n54, problem, start

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 03:49 PM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST