E90Post
 


The Tire Rack
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > ConnectedDrive / I-Drive / Navigation Related Discussion > Combox Retrofit complete but missing features



Reply
 
Thread Tools Search this Thread
      09-03-2016, 08:19 PM   #1
ssshake
Second Lieutenant
Canada
11
Rep
271
Posts

Drives: 328i coupe 2009
Join Date: Aug 2014
Location: Waterloo

iTrader: (0)

Combox Retrofit complete but missing features

Hey there

yet another person who completed (subjective) a combox retrofit.

Upon completing it I'm having some success but a lot of stuff just isn't working. I'm finding the information on the forums very fragmented and filled with side talk so it's hard for me to get a concise idea of what I need to do. If I could get this all clear maybe I'll even do a blog post to help others.

First off here's what works: Bluetooth connectivity. I can use the phone, see SMS messages, I can play and control music on my phone. Awesome.

What doesn't work:

Album art
USB media
Connected Drive / Apps (still says BMW assist in main menu, no connected drive option).
No internet browser.

What coding needs to be done, if any, to get album art? When I look at track info its the same old layout that I had with the mulf.

For USB media, does anything need to be coded for this or should it just work? Also I found a 'hub' option in ncs dummy.. what is that?

There's long story here where I think I might have fried the USB port. I tried doing this retrofit last summer and it ended up killing a USB stick. I put the project on hold until today.

IF my USB is fried, the good news is that I have another brand new combox in my possession. Why not use the new one and bother with the old one, you might ask. Well I bought my CIC and Combox used from a friend and the combox was already coded to use the donor VIN of the CIC (my basic understanding at least).. So it was more plug and play than a brand new combox.

So if I go to use the new combox, my understanding is I have to code it to the donor vin. Is this true? If so, how do I get the donor vin and how do I get the combox coded to it? Would it be as simple as me backing up the 'old' combox's config? Is this an NCS expert thing or something more complicated? My current experience with coding is limited to ncs expert, but I do have all the tools installed.

Can you point me to a link explaining how to get all the connected drive stuff going?

Are there other things I have to enable on the CIC or combox? I'm not aware of all the nuances of the features it offers. Is there a complete list of codes?

I hope I dont come across as someone who did zero research and decided to make a post. I have a very bloated google sheet I've been maintaining of links, diagrams, etc etc... and I'm still confused.

Lastly, this is a telematics combox, but I'm getting an error about SOS not working when I turn the car on. Is this because I have to remove my old TCU (and MULF while I'm at it) from the VO? What are the codes that need to be removed and how to I code the telematics in the combox to work?

Thanks!
Appreciate 0
      09-04-2016, 06:32 PM   #2
ssshake
Second Lieutenant
Canada
11
Rep
271
Posts

Drives: 328i coupe 2009
Join Date: Aug 2014
Location: Waterloo

iTrader: (0)

OK I got everything working. Back to document in case that helps anyone.

First off it turns out that the usb ports on my old combox are indeed dead. At least it certainly seems that way. It was hard to tell because the new combox had the exact same symptoms.. no devices detected and no power to the usb port. However once I got it working on the new combox it was obvious that the same coding isnt fixing the old one.

Misconception: I didn't need to do any special vin coding for the new combox. All I did to get everything working was to do a default coding of the CIC and Combox in NCS expert.

This blew away all of my custom CIC coding so I took a back up first. After that I did a diff in ncsdummy and merged both configs together.

There were a few options pertaining to usb and a2dp which were set to active in my old config (when it didnt work) and not active in the new config. It would seem intuitive to enable these but it seems to reason that the usb option wasn't supposed to be enabled. As for the a2dp option, who knows.. BT audio streaming works fine without it.

I also VO coded S6NF and tested that the second usb port works (blue connector). It does, which means I can now use 2 usb connections in the CIC after I order another usb cable.
Appreciate 0
      09-04-2016, 11:00 PM   #3
ssshake
Second Lieutenant
Canada
11
Rep
271
Posts

Drives: 328i coupe 2009
Join Date: Aug 2014
Location: Waterloo

iTrader: (0)

I'm finding that upon boot my usb drive isn't being detected. I have to unplug and replug it. I've tried 3 different micro SD to usb adapters. Thoughts?
Appreciate 0
      09-06-2016, 11:11 PM   #4
Scrippy
Lord Scrip
Scrippy's Avatar
United_States
937
Rep
2,211
Posts

Drives: 2011 M3 Coupe
Join Date: Jan 2012
Location: LA,Ca

iTrader: (0)

Garage List
2007 BMW 335i  [0.00]
Quote:
Originally Posted by ssshake
I'm finding that upon boot my usb drive isn't being detected. I have to unplug and replug it. I've tried 3 different micro SD to usb adapters. Thoughts?
Is it a FAT32 formatted USB drive?
__________________
Appreciate 0
Reply

Bookmarks

Tags
combox, retrofit

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 04:34 PM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST