E90Post
 


Coby Wheel
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > DME Codes 2CA7 and 2CAB(E92 335i) out of ideas, need help.



Reply
 
Thread Tools Search this Thread
      08-23-2019, 03:37 PM   #23
Danne335i
New Member
2
Rep
10
Posts

Drives: 335i E92 -08
Join Date: May 2016
Location: Sweden

iTrader: (0)

Quote:
Originally Posted by wei888 View Post
Danne, or anyone who may have the answer.
Any final updates for the car with 2CA7?
I'm have the exact same issue on my 2008 528i. Zero on STFT B1S1. I replaced the o2 sensor on B1S1. Code didn't go away 2CA6.
Will be great if your car is fixed. Please let me know.
Sorry for a late reply.

I ended changing my DME(MSD81) to a used one a few weeks ago and now its working perfectly again!
Appreciate 0
      01-07-2020, 11:03 AM   #24
Ilma
Colonel
Canada
169
Rep
2,839
Posts

Drives: 2008 135i
Join Date: Nov 2008
Location: Mississauga

iTrader: (0)

Having the same symptoms of intermittent codes 2CA7 2CAB for bank 2 precat Oxygen sensor.

As I understand it this is an O2 heater circuit signal issue and not necessarily a faulty O2 sensor.

I replaced both my precat O2 sensors about a year and half ago on a 2008 MSD81 135i.

Beginning to conclude the DME may be the root cause of the signal interuption/failure.

Can anyone recommend a good vendor for replace/reprogram an MSD81?
Appreciate 0
      01-17-2020, 01:29 AM   #25
AngelFarelli
Second Lieutenant
AngelFarelli's Avatar
Abu Dhabi
54
Rep
276
Posts

Drives: BMW n52 e90
Join Date: Nov 2019
Location: California

iTrader: (0)

Hello all .
I have a post similar but my topic is more about post cat narrow band sensor. I would love some help in my situation . My main concern is the roll of the post cat o2 sensors in its roll with the pre cat o2 sensor.
And sorry if any of my information is incorrect I am still learning. I have a n55 and I have heard that they rely more heavily on the precat sensor is this true? Does anyone have any links?
And sorry I don't mean to try to draw attention away from you thread but if the secondary does affect wideband o2 then maybe it will apply to you?
Please read and help me thank you..
Post cat o2 sensor! What does it really do for dme? https://www.e90post.com/forums/showthread.php?t=1686467
Appreciate 0
      01-17-2020, 07:41 AM   #26
relative4
Major
United_States
587
Rep
1,256
Posts

Drives: '08 335xi E90 MT stage 1+
Join Date: Feb 2019
Location: Denver, CO

iTrader: (0)

OK, now I'm with the guy who crapped on your last thread. Would you please stop spamming every thread on the forum with this topic, you freaking psycho?
Appreciate 0
      01-17-2020, 08:08 AM   #27
mweisdorfer
Major General
mweisdorfer's Avatar
United_States
1868
Rep
6,982
Posts

Drives: 2007 Black/Black 335i e90
Join Date: Apr 2011
Location: Holly, MI

iTrader: (0)

Garage List
2007 BMW E90 335i  [0.00]
2008 bmw x5  [0.00]
I think I had that code for a while 2Ca7

I was able to clear it by replacing the turbo seals on the inside lip of the turbos as they meet the downpipes & the seals from the mid-pipe to the end of the downpipe. I bought OEM seals for the turbo side & BMS seals for the mid-pipe side.
Appreciate 0
      01-17-2020, 08:35 AM   #28
stewbets
Captain
446
Rep
823
Posts

Drives: '08 335xi, '04 545i
Join Date: Sep 2019
Location: Dayton, OH

iTrader: (0)

Quote:
Originally Posted by relative4 View Post
you freaking psycho
Appreciate 0
      06-04-2020, 04:07 PM   #29
Ilma
Colonel
Canada
169
Rep
2,839
Posts

Drives: 2008 135i
Join Date: Nov 2008
Location: Mississauga

iTrader: (0)

Quote:
Originally Posted by Ilma View Post
Having the same symptoms of intermittent codes 2CA7 2CAB for bank 2 precat Oxygen sensor.

As I understand it this is an O2 heater circuit signal issue and not necessarily a faulty O2 sensor.

I replaced both my precat O2 sensors about a year and half ago on a 2008 MSD81 135i.

Beginning to conclude the DME may be the root cause of the signal interuption/failure.

Can anyone recommend a good vendor for replace/reprogram an MSD81?

Follow up to this issue........Had to clone and replace my MSD81 DME through a company called G-Coding. Have been running code free since doing so in January
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 01:50 AM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2023, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST