E90Post
 


European Auto Source (EAS)
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N57 / M57 Turbo Diesel Discussions - 335d > E70 X5 30D M57 DPF Sensor



Reply
 
Thread Tools Search this Thread
      07-16-2019, 05:20 AM   #1
Superdaws
Lieutenant
Australia
30
Rep
438
Posts

Drives: BMW 135i M Sport Le Mans Blue
Join Date: Oct 2009
Location: Melbourne, Australia

iTrader: (0)

E70 X5 30D M57 DPF Sensor

Hi Everyone,

Trying to diagnose this issue with my M57. 120,000km. Particle filter warning came on iDrive so looked into it further.

Had the 480A and 481A codes as well as Pressure sensor codes. I took it for a 1:30-2hr drive at 100kph about 2500-3000 rpm to try clean it out and tried to force a DPF regen in ISTA a few times. The active regen never happened.

Im beginning to think it may not be a clogged filter? Ive run the EGR test and results posted, do you think the pressure sensor could be bad? The figures are not "way out there" but it didnt measure atmosphereic pressure exactly with engine off.

Coolant temp was at 80C+ and EGT at at least 350C when i was trying to force a regen. Having read more into the target temps for the M57 on this forum too, im starting to think it may not be reaching target temp of 88C+ either so ill look at replacing the main and EGR thermos, but i doubt that would cause the pressure results im seeing?

Filter, sensor, thermos? Any ideas, thanks in advance.
Attached Images
   
__________________

2010 BMW 135i M Sport 6MT | Le Mans Blue | BMW Perf CF Rear Diffuser | BMW Perf CF Rear Spoiler | Kerscher CF Front Lip | MHD | Wagner Evo2Comp | VRSF DP's | ER CP Turbosmart Dual Port | LUX AE's | Alpine Hifi | Blacklines
2010 BMW E70 X5 30D Sports Innovation | Sapphire Black | Black Leather | LUX AE's
Appreciate 0
      07-16-2019, 08:32 AM   #2
335dlci
Major
126
Rep
1,062
Posts

Drives: 335d
Join Date: Apr 2014
Location: Socal

iTrader: (0)

What's 80+? Even 8 degrees off can cause issues. Your dpf is clogged. Forcing a regen doesnt always work.
Appreciate 0
      07-16-2019, 05:22 PM   #3
Superdaws
Lieutenant
Australia
30
Rep
438
Posts

Drives: BMW 135i M Sport Le Mans Blue
Join Date: Oct 2009
Location: Melbourne, Australia

iTrader: (0)

Quote:
Originally Posted by 335dlci View Post
What's 80+? Even 8 degrees off can cause issues. Your dpf is clogged. Forcing a regen doesnt always work.
Thanks for your response. I can't be totally specific on the temp based on the info from my drive as the hidden temp gauge kept dropping off screen while I was driving sand it wasn't really safe to switch it while driving. So the only time was when I pulled over to try and re-force regen again, I'd pull the temp again and have a look.

That said highest I saw was 81, and I didn't shut the engine off, so I'll look that replacing the thermostats.
__________________

2010 BMW 135i M Sport 6MT | Le Mans Blue | BMW Perf CF Rear Diffuser | BMW Perf CF Rear Spoiler | Kerscher CF Front Lip | MHD | Wagner Evo2Comp | VRSF DP's | ER CP Turbosmart Dual Port | LUX AE's | Alpine Hifi | Blacklines
2010 BMW E70 X5 30D Sports Innovation | Sapphire Black | Black Leather | LUX AE's
Appreciate 0
      07-17-2019, 12:50 AM   #4
Yozh
Colonel
Yozh's Avatar
No_Country
725
Rep
2,401
Posts

Drives: 2011 335d M-Sport
Join Date: Mar 2014
Location: Wet Coast

iTrader: (4)

Your regens should still be happening above 75C. If you have a failed thermostat, chances are you are getting below 70-75C on the highway.
Appreciate 0
      07-17-2019, 11:29 AM   #5
jdub486
Lieutenant
United_States
134
Rep
471
Posts

Drives: 19' M2C dct/ e90 335d dd
Join Date: Sep 2011
Location: Maryland

iTrader: (1)

A bad MAF sensor was causing my car to not re-gen recently.
Appreciate 0
      07-25-2019, 08:28 AM   #6
Superdaws
Lieutenant
Australia
30
Rep
438
Posts

Drives: BMW 135i M Sport Le Mans Blue
Join Date: Oct 2009
Location: Melbourne, Australia

iTrader: (0)

Thanks everyone for your input. Main and EGR thermostats were changed and then i was able to force a regen, DPF cleared! Yozh i think was right, it must have been dropping below 75C on the highway. I managed to get the temp indicator to stay up permanently and its now sitting comfortably 87-89C.

Cheers.
__________________

2010 BMW 135i M Sport 6MT | Le Mans Blue | BMW Perf CF Rear Diffuser | BMW Perf CF Rear Spoiler | Kerscher CF Front Lip | MHD | Wagner Evo2Comp | VRSF DP's | ER CP Turbosmart Dual Port | LUX AE's | Alpine Hifi | Blacklines
2010 BMW E70 X5 30D Sports Innovation | Sapphire Black | Black Leather | LUX AE's
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 05:36 PM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST