E90Post
 


 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > AUDIO/VIDEO + BLUETOOTH + Electronics/Alarm/Software > Strange constant buzz from speaker, continues on, even with no key in the ignition



Reply
 
Thread Tools Search this Thread
      06-15-2016, 01:49 PM   #89
007_e350
Lieutenant Colonel
007_e350's Avatar
United_States
175
Rep
1,925
Posts

Drives: 335i 2008 MHD'd / x5d E70
Join Date: May 2013
Location: left lane

iTrader: (3)

HOLY CRAP .. I hate Walmart...
Bought windshield fluid and put it in the trunk ... this morning radio buzzed like hell .. I read on forums then checked the trunk driver side... thats correct that bitch leaked all over, that amp is fried thats for sure
__________________
Mods: 7" VRSF FMIC, Forge DVs, RB PCV, BMS Oil Cooler, VRSF DPs, MHD, JB4g5, OFT DIYs: Walnut blasting : Trans Oil at 45k, w Filter at 65k : Diff Oil Flush @ 45k : WP&TS @ 69k : Alternator @ 79k --- E70d Alphabet Soup del 44.4k : JR Stg2.25 tune : Buzzken Catted Exhaust : Trans fluid drain/ fill (3 Qrts), both Diffs fluids flushed Wheels: Style 95s on PSSs (Sold): AG 359s on S04s : 162s on Blizzaks : Rohana RF1 Matt black
Appreciate 0
      06-22-2016, 10:11 AM   #90
invaz
Registered
0
Rep
4
Posts

Drives: 2008 e93 335i
Join Date: Jun 2016
Location: Singapore

iTrader: (0)

I had a similar issue after water got into the 2 side wells of my boot and fried my amp. I'm now on eBay looking for a used one for replacement!
Appreciate 0
      06-27-2016, 12:22 AM   #91
135ivert
Lieutenant
31
Rep
459
Posts

Drives: '10 E88 135i, '13 E70 M-sport
Join Date: Mar 2013
Location: Colorado

iTrader: (0)

Quote:
Originally Posted by EidleonDrexel View Post
Same problem in a 2010 328i, reseated the connector, buss is gone.
Yep, that's how I solved mine. But it's coming back . . .I think the connector isn't making good contact, or is coming loose due to my, ahem, driving.
Appreciate 0
      10-21-2016, 02:13 PM   #92
Cayey14
Registered
0
Rep
2
Posts

Drives: 2008 528xi
Join Date: Jul 2016
Location: New Jersey

iTrader: (0)

Hey Guys, I'm new here. But I had this problem. Try going to the amp in the rear. Start tugging on the harness that connects to the Amp. Prob solved. Another thing that was happening to me was my driver side speaker would work one day and the next won't. This solved everything. You might need a new amp. Hope this helps..
Appreciate 0
      11-10-2016, 01:48 PM   #93
Etxp
Enlisted Member
3
Rep
36
Posts

Drives: BMW E90 LCI 325D M Sport
Join Date: Aug 2016
Location: Ireland

iTrader: (0)

I have this issue on my 2011 LCI, I'm hoping its the connectors at the back of the head-unit, is it possible the head unit is broken?
Appreciate 0
      11-11-2016, 12:46 AM   #94
Alex_WLY
Terorist!
Alex_WLY's Avatar
Romania
27
Rep
315
Posts

Drives: Black bmw
Join Date: Dec 2008
Location: Targoviste-RO

iTrader: (0)

Garage List
2009 E91  [0.00]
Send a message via Yahoo to Alex_WLY
Quote:
Originally Posted by Etxp View Post
I have this issue on my 2011 LCI, I'm hoping its the connectors at the back of the head-unit, is it possible the head unit is broken?
90% the wiring are problem.
Appreciate 2
Etxp3.00

      11-14-2016, 05:25 PM   #95
Etxp
Enlisted Member
3
Rep
36
Posts

Drives: BMW E90 LCI 325D M Sport
Join Date: Aug 2016
Location: Ireland

iTrader: (0)

Quote:
Originally Posted by Alex_WLY View Post
90% the wiring are problem.

It seemed to be wiring although i dont know which one as i just took the unit out made sure everything was plugged in and put it back in again and it was fixed :O
Appreciate 1
      10-26-2017, 07:07 PM   #96
dn32844
Registered
0
Rep
1
Posts

Drives: BMW 330i
Join Date: Oct 2017
Location: FL

iTrader: (0)

330i Unusual behavior

Recently bought a 2005 330i, which is in very good condition inside and outside with low mileage. One morning I started the car to go after my business. It started but with an unusual pop pop out of two real speakers while the radio was off. Sound got louder and turned into mimicking a motorcycle. As I drove faster sound became lower and when slowed it got louder. Even while it was parked and engine running same motorcycle race continued. The next day I used a different key, all went normal no motorcycle or any other unusual sounds. Then I switch to my usual key same, nothing unusual happened. Was it a gremlin? I have no clue and still trying to figure out what was cause of that behavior. Any opinion? Love to hear it.
Appreciate 0
      03-20-2018, 06:34 PM   #97
Semih166
Registered
0
Rep
1
Posts

Drives: 2011 BMW 328I
Join Date: Mar 2018
Location: Alabama

iTrader: (0)

Problem Solved !!!!!!!

!!!!! PROBLEM SOLVED !!!!!

I took the head unit out ( very easy, it takes 2 minutes to get it out). I disconnected all the cables that goes to the unit, reconnect them making sure they seat properly, and buzzing sound was gone instantly. It is worth to try, it only takes 10 minutes and it doesn't cost you anything ( Before you had to dealer and possibly spend some bucks ).

Last edited by Semih166; 03-20-2018 at 06:35 PM.. Reason: Adding few more words
Appreciate 0
      11-18-2018, 04:21 PM   #98
LaF Arch
Registered
0
Rep
1
Posts

Drives: 2011 330i coupe
Join Date: Nov 2018
Location: cambridge, MA

iTrader: (0)

alert gong is really loud since replacing head unit...

I had the buzzing problem for a couple of years. finally could not stand it and bought a replacement head unit from reputable reseller. installed by a super high-end audio place. it cured the buzzing, but now the chime for unfastened seat-belts and other alerts is incredibly loud.

can this be reprogrammed to make it softer?

help? John
Appreciate 0
      11-18-2018, 06:12 PM   #99
ctuna
Lieutenant General
1258
Rep
10,966
Posts

Drives: 325xi 06 wagon MT
Join Date: Jan 2010
Location: Santa Cruz, Ca

iTrader: (0)

Most likely you got a Head unit programmed for the base system
stereo setup and you have the Hi Fi setup.
The head unit needs to be reprogrammed for Hi Fi .
You need to verify this by printing out your options list
from one of the free online Vin checkers or you could look for
the amp in the Driver side rear wheel Well. (US driver side)

The option for Hi Fi is 676.
How can you have a 2011 330 when the only US version in
a e90 is 06
Appreciate 0
      12-16-2018, 06:57 PM   #100
bonomo335i
New Member
0
Rep
20
Posts

Drives: 335i
Join Date: Aug 2014
Location: va

iTrader: (0)

ive had this problem for a long time now . i was tired of it so i found this thread and went outside and as soon as i popped the climate control out it flipping stopped . AMAZING lol
Appreciate 0
      12-17-2018, 07:08 PM   #101
ctuna
Lieutenant General
1258
Rep
10,966
Posts

Drives: 325xi 06 wagon MT
Join Date: Jan 2010
Location: Santa Cruz, Ca

iTrader: (0)

Its amazing how many things in electronics go bad due
to restive connectors that just need re seating.
Appreciate 0
      06-11-2019, 03:41 PM   #102
buttermilk
Registered
0
Rep
1
Posts

Drives: 335i
Join Date: Jun 2019
Location: los angeles

iTrader: (0)

I've been meaning to post this for like a year. So yes, this speaking buzzing issue is caused by the head unit, which does need to be replaced to completely resolve the issue (at least this is what i was told by a bmw mechanic).

The buzzing happens at different intensities and sometimes goes away (after hitting a pothole maybe) which led me to believe it's some kind of loose connection. I just read a post above me about reseating the wires at the back of the head unit, which I haven't tried and probably should.

My quickfix was this.. after learning it was a head unit issue I tried just giving a swift judo chop to the side of the center panel and the buzz went away. Of course it eventually comes back but that completely gets rid of the noise for me for now when it's unbearable, and I have to do it once a week or so maybe. Not sure if I'm causing damage or anything but just saying, if you really aren't trying to swap out your unit and you find this issue as annoying as me, it's one possible option? Maybe one day it won't work but it's been working for months so far.

To clarify.. I'm just reaching down where the passenger's legs would be and just hitting the right side of the center console, around where i think the head unit is.

Last edited by buttermilk; 06-11-2019 at 03:43 PM.. Reason: added last sentence
Appreciate 0
      06-11-2019, 04:47 PM   #103
ctuna
Lieutenant General
1258
Rep
10,966
Posts

Drives: 325xi 06 wagon MT
Join Date: Jan 2010
Location: Santa Cruz, Ca

iTrader: (0)

Have you tried re seating the main connector.
Like take the Radio out and throw the lever a few times.
Appreciate 0
      06-13-2019, 10:40 PM   #104
Strodder
Registered
Strodder's Avatar
United_States
0
Rep
1
Posts

Drives: BMW 328i Coupe
Join Date: Jun 2019
Location: Hesperia Ca

iTrader: (0)

I have a 2008 328i Coupe with the same problem with my drivers door speaker. I think I'm doing what everyone else said to do, plus replace the radio with an aftermarket one with more features. Like GPS, and back up camera. What do you guys think?
Appreciate 0
      06-13-2019, 11:33 PM   #105
kenship
New Member
Canada
4
Rep
25
Posts

Drives: 2011 323i
Join Date: Jun 2019
Location: Markham, Ontario

iTrader: (0)

I followed advice here, removed climate control unit, unscrewed head unit, unplugged connector and replugged, noise gone.

Thanks to the nice folk here.
Appreciate 0
      10-29-2019, 07:06 PM   #106
sunjiulu
Registered
0
Rep
1
Posts

Drives: BMW 328xi
Join Date: Oct 2019
Location: Victoria, BC, canada

iTrader: (0)

I had the speaker buzz two times, in 2012 and 2019

Both time of the buzz sound from rear speaker stopped by itself after being locked and rested for awhile (I checked a few hours later and the buzz sound is gone). as many said, the symptom is that the sound start from nowhere, volume cannot be controlled by tuning in radio volume etc, sound does not stop when turn off radio. shut off engine and lock the door does not make the buzz sound go away. but after a few hours when I check again, the buzz sound is gone and never comes back.

Maybe I am lucky, just want to post my experience for your reference.
Appreciate 0
      10-29-2019, 08:25 PM   #107
ctuna
Lieutenant General
1258
Rep
10,966
Posts

Drives: 325xi 06 wagon MT
Join Date: Jan 2010
Location: Santa Cruz, Ca

iTrader: (0)

We know why the sound stays on if you read this thread you would to.
The car uses the stereo for alarms and reminders. When you unlock
the car the car wakes up and although the screen on the stereo is
off it's still really on . There is a timeout after you leave the car before
it goes to sleep and powers everything down.
Appreciate 0
      11-02-2019, 10:20 AM   #108
Kaisah
Second Lieutenant
United Kingdom
28
Rep
212
Posts

Drives: 340i F30 LCI
Join Date: Jun 2014
Location: Newcastle

iTrader: (0)

Garage List
2017 340i  [0.00]
Quote:
Originally Posted by Kaisah View Post
Quote:
Originally Posted by taibanl View Post
A service bulletin was posted last month (March 2014) for this issue. Recommend you take it to the dealer
Hello, Do you have a link to this service bulletin please? My 2010 E92 320D pro radio is making the same noise as Roundle's video shows.

I have only just bought the car today and it has a 3 month "warranty" from the Jaguar main dealer who sold me the car. Hopefully if I can pinpoint the issue they might cave and fix it for me?

Thanks in advance
Just realised I never updated this.. I ended up taking it to a dealer and they did some sort of software reset/update which fixed it. Just in case anyone searches for this in future
Appreciate 0
      02-23-2021, 09:30 AM   #109
B2021
New Member
0
Rep
6
Posts

Drives: BMW 320D
Join Date: Feb 2021
Location: UK

iTrader: (0)

Question Similar issue

Quote:
Originally Posted by dmichael View Post
So Its been cold out lately, single digits, and I go to may car in the parking lot and press the button on the fob to open the door, immediately I hear this constant buzz that was coming from the drivers side speaker on the rear parcel shelf. It was loud too, I could hear it with all the doors/windows closed from outside the car. It was like the car was possessed. I turned on the radio and the buzz kept on going in the background over the music. I shut off the radio, turned on the ignition, shut off the ignition, pulled the key out and only after several lock/unlock cycles did the noise stop. Speaker sounded fine afterwards so it's probably not blown. To me this seems like some an electrical gremlin not caused by the radio system, just manifesting itself through that left rear speaker because it started immediatly after I unlocked the car for the first time and didn't resolved itself until after a few cycles of locking/unlocking.

Anyone else have this happen?

Speaking of rear parcel shelf, when driving over bumps in the road, I have been getting a lot of creaking and/or ticking from that area since the weather has turned colder and the colder it gets the more frequent the noise. If I get that buzzing from the speaker again, I will take the car to the dealer and do a 2fer and have them try to resolve the noise in the rear shelf along with checking on the possessed speaker.

BMW 320D 2010
When I put the key into the ignition I can hear a constant noise from front passenger door speaker, when the radio is on this sound doesn't stop and sometimes buzzing noise from radio, upon turning the car off and I remove the key I can hear a sound for about a minute then stop. Need a software re-flash? What can this be and how to resolve this?

Many thanks

Last edited by B2021; 02-23-2021 at 03:59 PM..
Appreciate 0
      02-23-2021, 11:45 AM   #110
ctuna
Lieutenant General
1258
Rep
10,966
Posts

Drives: 325xi 06 wagon MT
Join Date: Jan 2010
Location: Santa Cruz, Ca

iTrader: (0)

Did you read any of this thread?
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 09:09 PM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST