E90Post
 


GetBMWParts
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > Need help. Car wont start. Mhd flash gone wrong.



Reply
 
Thread Tools Search this Thread
      05-24-2017, 06:45 PM   #1
Hbiliouris335i
Private First Class
12
Rep
105
Posts

Drives: 2009 Bmw 335i Xdrive 6MT
Join Date: Feb 2017
Location: Medway, Ma

iTrader: (0)

Need help. Car wont start. Mhd flash gone wrong.

Hey i really need some help. I put on a battery charger and pluged in mhd stock map. It then said preparrimg ecu and the wipers came on. I ripped out the cable and unplugged the battery charger. I tryed to start it amd it cranked and wont start. I pluged it in and tryed and it said no connection. Please help. My car is a 2009 bmw 335i x drive. Ran fine before.
Appreciate 0
      05-24-2017, 11:53 PM   #2
ZeeVaughn
Second Lieutenant
ZeeVaughn's Avatar
81
Rep
207
Posts

Drives: E92 335i 6MT SG/Coral
Join Date: Jul 2016
Location: Norcal

iTrader: (0)

This is somewhat common if not done properly and something I did 4 days ago. I think I may have accidently inserted my keys but forgot to turn on the car, maybe I wasn't really sure but I had the same exact symptoms with the wipers.

I simply turned off the car, took my keys out, unplugged the obd cable and started all over. Had to flash back to stock map and then do a full rewrite on my custom tune and she started right up and everything was fine.
__________________
Remember the buster
Appreciate 0
      05-25-2017, 01:08 AM   #3
46m3csl
Captain
58
Rep
751
Posts

Drives: 335i
Join Date: May 2010
Location: Rowland Heights

iTrader: (0)

You ll be fine just replug the obd cable, and start from the begining , it may need a full flash which is 25 mins or soo depending on your car. It may start from where it left off
Appreciate 0
      05-25-2017, 05:55 AM   #4
racermp
Major
racermp's Avatar
United_States
163
Rep
1,017
Posts

Drives: e90 335i n55, e70 X5 35i n55
Join Date: Apr 2013
Location: Houston, TX

iTrader: (1)

Quote:
Originally Posted by 46m3csl View Post
You ll be fine just replug the obd cable, and start from the begining , it may need a full flash which is 25 mins or soo depending on your car. It may start from where it left off
What he said
Appreciate 0
      05-25-2017, 06:49 AM   #5
Antetokounmpo
Brigadier General
Antetokounmpo's Avatar
United_States
1308
Rep
3,173
Posts

Drives: E90 6MT
Join Date: Jul 2013
Location: WI

iTrader: (3)

Full flash again.

Why the heck would you unplug it???????????? What did you think was going to happen??
__________________

BC Racing BR | Hawk HPS | Stoptech 600
Apex Arc-8 | Firehawk Indy 500 255 Square | Atric Altimax 225 Sq.
Appreciate 1
Fritzer234.50

      05-25-2017, 07:43 AM   #6
NoGuru
Lieutenant
NoGuru's Avatar
154
Rep
495
Posts

Drives: 335is
Join Date: Apr 2017
Location: MI

iTrader: (0)

Garage List
2011 335is  [0.00]
Quote:
Originally Posted by Harambe View Post
Full flash again.

Why the heck would you unplug it???????????? What did you think was going to happen??
I was thinking the same thing. Who cares if the wipers turn on, let it run it's coarse.
__________________
2011 335is MHD Stage 2+ / BMS CAI / VRSF kittyless DP's / Synapse BOV and charge pipe / 5" ETS FMIC / Stage 2 bucketless / Motive Flex Fuel / Vwetish Diff Brace / Carbon wrapped roof / M4 Grill / 15mm spacers in rear / Arkym front lip/PR coils
Appreciate 1
Fritzer234.50

      05-25-2017, 08:18 AM   #7
BeastMode335i
Maximus Decimus Meridius
BeastMode335i's Avatar
United_States
946
Rep
4,502
Posts

Drives: F30 335i
Join Date: Apr 2014
Location: Down South

iTrader: (2)

LoL, he ran off on the plug.. Literally..
__________________
13' F30 335i
Melbourne Red Metallic
M-Sport Package

Last edited by BeastMode335i; 05-26-2017 at 06:30 AM.
Appreciate 1
      05-25-2017, 09:14 AM   #8
BimmerGeeks
BimmerPost Supporting Vendor
BimmerGeeks's Avatar
1149
Rep
1,397
Posts


Drives: Bmw
Join Date: Feb 2017
Location: Atlanta

iTrader: (4)

Quote:
Originally Posted by Harambe View Post
Full flash again.

Why the heck would you unplug it???????????? What did you think was going to happen??
+1, no idea why you would purposely disrupt the process...asking for trouble.
__________________
Appreciate 1
Fritzer234.50

      05-25-2017, 09:28 AM   #9
lordbmw
Captain
United_States
137
Rep
662
Posts

Drives: 2010 BMW 335xi Coupe (AT)
Join Date: Sep 2016
Location: Alexandria, VA

iTrader: (0)

Quote:
Originally Posted by Hbiliouris335i View Post
Hey i really need some help. I put on a battery charger and pluged in mhd stock map. It then said preparrimg ecu and the wipers came on. I ripped out the cable and unplugged the battery charger. I tryed to start it amd it cranked and wont start. I pluged it in and tryed and it said no connection. Please help. My car is a 2009 bmw 335i x drive. Ran fine before.
Sometimes my wipers come on too when I flash with MHD. Must be a bug.

Whenever it does that, the flash will fail and frequently the ECU will go into recovery mode.

When it does that, I unplug everything, turn off everything, relaunch MHD and start again.

It's always worked the 2nd time so far for me at least. It will usually give an option the 2nd time to continue with the failed flash so MHD knows if you attempted a flash and failed.
Appreciate 0
      05-25-2017, 11:04 AM   #10
roadkillrob
Brigadier General
United_States
517
Rep
4,996
Posts

Drives: 08 335i,19 X5 35i,14 C63 AMG
Join Date: Jul 2007
Location: Boston

iTrader: (15)

I have had my wipers come on also with MHD and I have had it happen flashing the trans with xhp - I think it is related to low battery voltage, but maybe not if it just works when you try again. In my case, both times I put my 70 amp charger on and it worked fine second try.
__________________
2019 X540i Phytonic Blue M-Sport
2008 E93 335i FBO
2014 Mercedes C63 507 Edition
Appreciate 0
      05-25-2017, 12:13 PM   #11
NoSlow5oh
First Lieutenant
54
Rep
331
Posts

Drives: 08 e90 335i
Join Date: Jul 2015
Location: Madison, AL

iTrader: (2)

I've only had the wipers come on once, and it was during a failed flash. I had to unplug the battery and wait a few minutes. I was then able to flash to stock and drive home, then I reflashed back to the tune. I did not need to do a full flash.

My issue was I didn't put the key in and turn the car to "ON/ACC" correctly as I've done flashes before without the keys since I have comfort access. Dumb on my part and I will always insert the key and make sure the car is "ON/ACC" before starting a flash again.
Appreciate 0
      02-12-2019, 01:57 AM   #12
Gucho15
Registered
0
Rep
4
Posts

Drives: 2010 e90 335i
Join Date: Feb 2019
Location: bay area, california

iTrader: (0)

MHD gone worng

hey i need help getting my car running again, the first time I tried to install MHD, my battery tender wasn't keeping up with how much energy was being used and now the battery is dead, the flash finished but everything is wrong with my car, windshield wipers are on, abs is malfunctioning, throttle is malfunctioning, etc the car revs up to 2,000 rpm over and over. I've tried reflashing with a better battery tender but the car is in the same state and the battery is still dead.
Appreciate 0
      02-12-2019, 10:38 AM   #13
robthewrench
Captain
234
Rep
942
Posts

Drives: 11 E90 335i
Join Date: Aug 2014
Location: Columbus OH

iTrader: (0)

If the battery is truly shorted and won't hold 12 volts, you need to replace the battery. Charge the battery. Then test the battery voltage with the car off. If less than 12.6 volts, replace the battery.
__________________
bone stock
Appreciate 0
      02-12-2019, 01:47 PM   #14
Fritzer
No one sleep in Tokyo
Fritzer's Avatar
No_Country
235
Rep
539
Posts

Drives: 2011 E90 328i
Join Date: Oct 2018
Location: San Diego, California

iTrader: (0)

Quote:
Originally Posted by Hbiliouris335i View Post
It then said preparrimg ecu and the wipers came on. I ripped out the cable and unplugged the battery charger.
HAHAHA, why would you do that? Wipers going to fry your ECU?

Man, just do a full re-flash you interrupted the data transfer for no reason so the ECU has no idea how to run.
__________________
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 05:11 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST