E90Post
 


GetBMWParts
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > DIY Guides > DIY: Install SSD in CIC



Reply
 
Thread Tools Search this Thread
      12-07-2018, 12:21 PM   #45
SteveEvans
Private
31
Rep
67
Posts

Drives: E92 M3 Coupe
Join Date: Oct 2016
Location: UK

iTrader: (0)

Just did this update using:

Lycom ST-173-7 mSATA SSD to 2.5" IDE SSD Drive Converter
Kingston UV500 120GB mSATA SSD/Solid State Drive

Certainly starts up faster, although it still takes much the same time for the nav system to start, presumably down to the time it takes to acquire a GPS lock. Zooming in and out on the maps is faster as is entering destinations and looking up points of interest. All in all very worthwhile for 50.

I used a StarTech.com USB 2.0 to SATA IDE Adapter USB2SATAIDE to read/write the disk.

Steve
Appreciate 0
      12-21-2018, 10:58 PM   #46
aa12
Registered
0
Rep
2
Posts

Drives: 2010 550I
Join Date: Dec 2018
Location: Dallas

iTrader: (0)

Has any one seeing an issues where everything is working (nav, contact) but i cant access the music collection, shows no info for the drive?

also thank you for this DIY.
Appreciate 0
      12-22-2018, 05:57 PM   #47
Jagaer
Private First Class
Canada
123
Rep
119
Posts

Drives: 2011 E91 328xi 6MT
Join Date: Aug 2017
Location: Kingston, Ont

iTrader: (0)

@aa12

It sounds like you successfully cloned the drive, but did not expand the music partition correctly.

It is likely that either the partition table for the expanded partition isn't correct, or the partition itself isn't formatted.

Personally, I would reformat the music partition, as:

1. If QNX is able to successfully format the music partition, the partition table isn't corrupt; and
2. Once formatted, if you can mount the partition table in QNX, you can test copying music back to the partition.

Note that this does not guarantee that it will work in the BMW, as the CIC is a bit more particular in how the partition is formatted and where it is in the partition table. But this is where I would start as it is likely to fix the problem, and doesn't take considerable effort.
Appreciate 0
      12-22-2018, 08:45 PM   #48
aa12
Registered
0
Rep
2
Posts

Drives: 2010 550I
Join Date: Dec 2018
Location: Dallas

iTrader: (0)

Little more background, Originally my iDrive/CIC started boot looping. it would start and reboot after few minutes, after looking at it it looked like the HDD died (clicking noise). I recovered the HDD (ddrescue) but i few kb read error.

So I cloned image to SSD drive without resizing, I wanted to make sure that I at least had a good image. With the new drive, everything works except the media collection. after looking at it more, I am able to mount (ready only) all of the partition except the hbdebug. I tried in ubuntu and in QNX 6.5, both show hbdebug as corrupted file system. I also tried to use mkqnx6fs on both partition and plug it back in, same results (no media).

The question I have, whats inside hbdebug (5th partition)? Is it something i can copy from a another car? could be the reason why the media shows no info?

As always, thank you!

Last edited by aa12; 12-23-2018 at 01:43 AM.
Appreciate 0
      12-23-2018, 04:14 PM   #49
jrobledo88
Registered
0
Rep
1
Posts

Drives: BMW 2014 3281 XDrive GT
Join Date: Dec 2018
Location: Orlando

iTrader: (0)

DIY HDD Died

Good Day just wanted to let you know very good post it was very detailed. One dumb question I just bought my first project BMW. I got the car with the HDD already dead. Will this post save me with the existing drive? or is this post to for cloned drives only?
Appreciate 0
      12-23-2018, 04:22 PM   #50
Jagaer
Private First Class
Canada
123
Rep
119
Posts

Drives: 2011 E91 328xi 6MT
Join Date: Aug 2017
Location: Kingston, Ont

iTrader: (0)

@aa12

You will need to be able to mount HBDebug for the CIC to operate correctly, but it can be a blank partition. The CIC uses that directory to store logfiles

jrobledo88 Edit: Apparently I can't PM you. Send me a message, when your account is able to.
Appreciate 0
      02-21-2019, 06:07 PM   #51
aames
Registered
0
Rep
1
Posts

Drives: BMW 520D F10+E46 320D Touring
Join Date: Feb 2019
Location: Porto, Portugal

iTrader: (0)

Quote:
Originally Posted by Jagaer View Post
I used the pre-configured QNX Neutrino 6.5.0 VM provided by QNX.

The VMX package is called "QNX_Eval_RT-201007091524.zip" and contains 4 files.

If you can't find it on the QNX Portal (free registration required), PM me.
Hi Jagaer!

I'm about to try your tutorial, but I haven't been able to get the QNX_Eval_RT-201007091524.zip , any chance you could send it to me?

Thank you so much!!
Appreciate 0
      02-23-2019, 04:37 PM   #52
Jagaer
Private First Class
Canada
123
Rep
119
Posts

Drives: 2011 E91 328xi 6MT
Join Date: Aug 2017
Location: Kingston, Ont

iTrader: (0)

aames

YGPM
Appreciate 0
      02-24-2019, 04:57 PM   #53
rottend
Registered
0
Rep
3
Posts

Drives: bmw 123d
Join Date: Feb 2019
Location: belgrade, serbia

iTrader: (0)

Hello folks! I managed to screw up my E82 navigation some time ago (it shows as grayed out entry in the menu) and I'm wondering would dumping an hdd image from a working nav hdd would fix it? Does anyone has any experience with that?
Appreciate 0
      02-28-2019, 07:59 PM   #54
Jagaer
Private First Class
Canada
123
Rep
119
Posts

Drives: 2011 E91 328xi 6MT
Join Date: Aug 2017
Location: Kingston, Ont

iTrader: (0)

rottend

Most of the drive is able to be cloned from one to another (The donor may need to be running the same firmware version. I've never tested using a hard drive from a CIC with a different firmware)

The debug partition includes keys specific to your vehicle. There are backup keys in the flash memory, but I've never tried replacing a failed drive missing the debug partition keys.

In either case, you will need to format (empty) the debug partition before installing it in your vehicle, as the CIC will not accept a key mismatch
Appreciate 0
      03-04-2019, 05:31 AM   #55
rottend
Registered
0
Rep
3
Posts

Drives: bmw 123d
Join Date: Feb 2019
Location: belgrade, serbia

iTrader: (0)

Quote:
Originally Posted by Jagaer View Post
rottend

Most of the drive is able to be cloned from one to another (The donor may need to be running the same firmware version. I've never tested using a hard drive from a CIC with a different firmware)

The debug partition includes keys specific to your vehicle. There are backup keys in the flash memory, but I've never tried replacing a failed drive missing the debug partition keys.

In either case, you will need to format (empty) the debug partition before installing it in your vehicle, as the CIC will not accept a key mismatch
Jagaer, do you think that I could only clone the partition which is used by Nav? I've been digging through forums and found out that some folks recommend to actually flash / code the Nav instead and leave the hdd as is. Do you think that it might help? I'm not a coder myself, so any help / hint will do. Thanks!
Appreciate 0
      03-10-2019, 08:00 PM   #56
dylim
Second Lieutenant
10
Rep
266
Posts

Drives: 328xi
Join Date: Mar 2012
Location: bay area

iTrader: (3)

Is there anything at all in the hbmedia directory (besides media files)? Seems like it just contains some empty directories:
1.0K /mnt/sdb9/.boot
1.0K /mnt/sdb9/entertainmentserver
1.0K /mnt/sdb9/pv_cover_cache
4.0K /mnt/sdb9
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 05:43 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST