E90Post
 


European Auto Source (EAS)
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N55 Turbo Engine Tuning and Exhaust Modifications - 335i Tuning > Strange Valvetronic Actuator/ Eccentric Shaft Issue



Reply
 
Thread Tools Search this Thread
      05-10-2019, 06:37 PM   #45
frostedsoul
New Member
2
Rep
8
Posts

Drives: 2009 535i, 2011 335i
Join Date: May 2015
Location: Biloxi, MS

iTrader: (0)

Quote:
Originally Posted by cahme View Post
What codes were you seeing before you replaced the servo motor?
Does the indy think you need a new DME? What are they doing for that $3500?
Codes was 2E0F and 300C, 300E. Indy thought my DME was fried but it wasnt (good for me). They want to replace new valve cover, new eccentric motor and harness, eccentric shaft bearings, spark plugs.
Appreciate 0
      05-10-2019, 06:48 PM   #46
frostedsoul
New Member
2
Rep
8
Posts

Drives: 2009 535i, 2011 335i
Join Date: May 2015
Location: Biloxi, MS

iTrader: (0)

Quote:
Originally Posted by Pladi View Post
Did you run the ista 20 min long procedures of learning the limits ?
The shaft could only rotate to driver side (when motor spins clock-wise), when the motor tried to spin counter clock-wise to rotate the shaft to passenger side it just stuck, thats y the shaft never reach maximum lift.
Appreciate 0
      05-10-2019, 06:53 PM   #47
frostedsoul
New Member
2
Rep
8
Posts

Drives: 2009 535i, 2011 335i
Join Date: May 2015
Location: Biloxi, MS

iTrader: (0)

I have owned 5 BMWs so far and still have 2009 535i and 2011 335i, these are my last 2. Every single dang time I brought my vehicles in for recall, always had problems when I have them back. My 335i was smooth and pulled really hard with JB4 and catless downpipe, when I took my 335i to dealership for Vanos recall, after I drove it back home, one of the stainless steel fuel line on top the engine was leaking very bad, leaking fuel all over my hot engine, the car could have been on fire and they also broke one of valve cover bolt, and the broken bolt stuck inside the engine, I was sooo pissed.
Appreciate 0
      05-10-2019, 07:08 PM   #48
frostedsoul
New Member
2
Rep
8
Posts

Drives: 2009 535i, 2011 335i
Join Date: May 2015
Location: Biloxi, MS

iTrader: (0)

And one more thing I need to tell you guys, when I replaced eccentric motor, my oil feed line was clogged up really really bad, I had to use needle and carburetor cleaner to unclog and clean it. I think all BMW latest engines are manufacture fault design or peace of craps. No more BMW.
Appreciate 0
      05-12-2019, 01:47 PM   #49
Pladi
Lieutenant Colonel
Pladi's Avatar
Canada
636
Rep
1,880
Posts

Drives: 2011 335i xdrive
Join Date: Nov 2017
Location: Waterloo, ON Canada

iTrader: (0)

Quote:
Originally Posted by frostedsoul View Post
And one more thing I need to tell you guys, when I replaced eccentric motor, my oil feed line was clogged up really really bad, I had to use needle and carburetor cleaner to unclog and clean it. I think all BMW latest engines are manufacture fault design or peace of craps. No more BMW.
Off topic but to add to BMW issues :

My car the other day noticed water coming from outside during a very rainy day into the floor of the passenger side.. WTF !! even a LADA from 1960's wont have that issue. I read a few posts of people had water leaks in the e90s trunk and front ...

These issues are unheard of with any other make. BMWs leak everything that can leak, from fuel to oil to coolant to water inside
Appreciate 0
      05-12-2019, 02:11 PM   #50
weehe126
Colonel
615
Rep
2,280
Posts

Drives: 2011 335i
Join Date: Apr 2014
Location: San Antonio

iTrader: (1)

Quote:
Originally Posted by Pladi View Post
Off topic but to add to BMW issues :

My car the other day noticed water coming from outside during a very rainy day into the floor of the passenger side.. WTF !! even a LADA from 1960's wont have that issue. I read a few posts of people had water leaks in the e90s trunk and front ...

These issues are unheard of with any other make. BMWs leak everything that can leak, from fuel to oil to coolant to water inside
That is a really common issue. Your sunroof drain on that side is clogged.
Appreciate 1
Pladi636.00

      05-12-2019, 02:12 PM   #51
weehe126
Colonel
615
Rep
2,280
Posts

Drives: 2011 335i
Join Date: Apr 2014
Location: San Antonio

iTrader: (1)

Quote:
Originally Posted by frostedsoul View Post
And one more thing I need to tell you guys, when I replaced eccentric motor, my oil feed line was clogged up really really bad, I had to use needle and carburetor cleaner to unclog and clean it. I think all BMW latest engines are manufacture fault design or peace of craps. No more BMW.
Wouldn't matter if it was clogged. It doesn't use a banjo bolt so it's basically an oil dripper, not sprayer.
Appreciate 0
      05-13-2019, 08:55 PM   #52
cranelec
Second Lieutenant
76
Rep
221
Posts

Drives: BMW
Join Date: Nov 2013
Location: NEPA

iTrader: (0)

Garage List
I love my car! (wet/dry-running/not running)!

Quote:
Originally Posted by weehe126 View Post
That is a really common issue. Your sunroof drain on that side is clogged.
Okay...Since my portable garage should be complete by this Sunday, I decided to remove the expensive car cover off my 335 and see if it would start (it didn't). To my surprise, the trunk contained a significant amount of water in it.
Appreciate 0
      06-11-2019, 08:45 PM   #53
pipes777
Registered
0
Rep
2
Posts

Drives: 2012 bmw x5
Join Date: Jun 2019
Location: elgin

iTrader: (0)

I have a 2012 x5 n55 motor.Had a salvage motor put info about 9,000 but having issues with valvetronic motor.The mechanic that was not specialized in BMW told me he was changing the motor because of the codes and the reduced power fault.After it was put in same reduced power fault and 4 codes----2de1...3011 camshaft installation faulty...2c58....2dd8 valvetronic servomotor, position sensors signal implausible.Cam was not touched.Need help badly everybody wants to replace everything.Car runs fine after rpm jumps for first 2 minutes of start up.Had someone put on machine to learn the new motor and no luck didn't fix.Do you think it was a bad install?how would I know?
Appreciate 0
      06-13-2019, 04:18 PM   #54
frostedsoul
New Member
2
Rep
8
Posts

Drives: 2009 535i, 2011 335i
Join Date: May 2015
Location: Biloxi, MS

iTrader: (0)

Finally I have got my car back on 06/12/2019, it running like a champ now, total cost was $4600 but the shop gave me $300 off so $4300. Beside replacing new eccentric motor, harness and shaft, they replace 2 vanos solenoids, 2 camshaft position sensors, new spark plugs, new valve cover. Here is the thing that I was really really lucky, when I was pulling really hard (JB4 map 5+ intercooler + catless dp) 5000-6000 rpm then I shift to next gear that when the engine shut off, there were 2 reasons why engine shut off, first was the eccentric motor and shaft, second (this is my very very lucky part) was the Jesus bolt was loosen and walked out caused the engine out of timing by alot because the crankshaft spinning but the vanos were not, this could have cost me a new engine, put holes on pistons or at least bent the valves( I was running 6000rpm), none of those happened. After all I am very happy to have my car back and only cost me $4300 to fix it, I can sleep well at night now. Lol...
Appreciate 0
      06-13-2019, 04:38 PM   #55
Pladi
Lieutenant Colonel
Pladi's Avatar
Canada
636
Rep
1,880
Posts

Drives: 2011 335i xdrive
Join Date: Nov 2017
Location: Waterloo, ON Canada

iTrader: (0)

Quote:
Originally Posted by frostedsoul View Post
Finally I have got my car back on 06/12/2019, it running like a champ now, total cost was $4600 but the shop gave me $300 off so $4300. Beside replacing new eccentric motor, harness and shaft, they replace 2 vanos solenoids, 2 camshaft position sensors, new spark plugs, new valve cover. Here is the thing that I was really really lucky, when I was pulling really hard (JB4 map 5+ intercooler + catless dp) 5000-6000 rpm then I shift to next gear that when the engine shut off, there were 2 reasons why engine shut off, first was the eccentric motor and shaft, second (this is my very very lucky part) was the Jesus bolt was loosen and walked out caused the engine out of timing by alot because the crankshaft spinning but the vanos were not, this could have cost me a new engine, put holes on pistons or at least bent the valves( I was running 6000rpm), none of those happened. After all I am very happy to have my car back and only cost me $4300 to fix it, I can sleep well at night now. Lol...
Your funny " It could have costed me an engine"

You can buy a used engine for the money you spent on parts and labor. A used engine with less miles probably.
Appreciate 0
      06-13-2019, 06:02 PM   #56
frostedsoul
New Member
2
Rep
8
Posts

Drives: 2009 535i, 2011 335i
Join Date: May 2015
Location: Biloxi, MS

iTrader: (0)

Quote:
Originally Posted by Pladi View Post
Your funny " It could have costed me an engine"

You can buy a used engine for the money you spent on parts and labor. A used engine with less miles probably.
Lol... Used engine is around $2500-$3000 plus labor but who knows if it runs probably or need anything replaced, my engine is only 50k miles it had run very smooth and pulled really hard till the eccentric motor and shaft went bad.
Appreciate 1
Pladi636.00

Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 11:38 PM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST