E90Post
 


TNT Racewerks
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > Australia > 2007 335i E93 Auto - iDrive random crashing



Reply
 
Thread Tools Search this Thread
      05-05-2020, 01:39 PM   #1
DaveSA
Private
7
Rep
72
Posts

Drives: 2007 E93 335i AT
Join Date: May 2016
Location: South Australia

iTrader: (0)

2007 335i E93 Auto - iDrive random crashing

Hi all,

IDK if this has anything to do with the issue, but the indy shop replaced the battery, generator (both were cactus), and I told em to replace the starter motor too, since they had it stripped down. All that was done back in 2018.

A few months after that, the iDrive would occasional freeze, then reboot. Didn't think much of it, as it occasionally did it before above repairs.

However, the issue is getting worse. Sometimes I can start up (cold) and the iDrive crashes multiple times within a 10 min period. It finally sorts it self out and is fine.

Other times on cold starts it's fine.

What I do notice a lot of is... Car is hot (engine oil temp 115C+), I'll stop the car at shops (etc) return 15min later, and the iDrive reboots multiple times. Then finally sorts itself out and is fine.

There's nothing consistent though, it's totally random. Happens under all type of starts and driving behaviours.

Anyway idea what the culprit might be?


Cheers

Dave
Appreciate 0
      05-05-2020, 05:34 PM   #2
GovernUrMental
Private First Class
GovernUrMental's Avatar
Australia
31
Rep
140
Posts

Drives: E92 335i
Join Date: Aug 2018
Location: In the Matrix

iTrader: (0)

When the CCC idrive starts to fail thats usually how they to go.

Does this look like your problem?

https://www.youtube.com/watch?v=V1iHivRBzMo

https://www.youtube.com/results?sear...+ccc+rebooting

Last edited by GovernUrMental; 05-05-2020 at 07:13 PM.. Reason: Link fix
Appreciate 0
      05-27-2020, 11:04 AM   #3
DaveSA
Private
7
Rep
72
Posts

Drives: 2007 E93 335i AT
Join Date: May 2016
Location: South Australia

iTrader: (0)

Quote:
Originally Posted by GovernUrMental View Post
When the CCC idrive starts to fail thats usually how they to go.

Does this look like your problem?

https://www.youtube.com/watch?v=V1iHivRBzMo

No... It's actually powers up fine, and operates. BUT... it randomly re-boots. However, once those random reboots stop (maybe 1x or could be 5x), everything works a treat, and the iDrive remains operational, without any further re-boots for the drive/outing.
Appreciate 0
      05-29-2020, 02:22 AM   #4
Socket
Lieutenant General
Socket's Avatar
Australia
3207
Rep
11,116
Posts

Drives: 335i
Join Date: Nov 2014
Location: Melbourne

iTrader: (4)

Garage List
2008 BMW E92  [0.00]
Quote:
Originally Posted by DaveSA View Post
No... It's actually powers up fine, and operates. BUT... it randomly re-boots. However, once those random reboots stop (maybe 1x or could be 5x), everything works a treat, and the iDrive remains operational, without any further re-boots for the drive/outing.
Should be able to remove the trim around the unit and screws
Then slide it out and check the connections
If all are plugged in ok and it keeps doing it, then it is def on the way out

Good excuse to upgrade to CIC
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 03:41 PM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST