E90Post
 


TNT Racewerks
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Suspension | Brakes | Chassis > Power steering pump whining



Reply
 
Thread Tools Search this Thread
      12-08-2017, 04:00 PM   #1
calswan7145
New Member
2
Rep
25
Posts

Drives: E90 328i Xdrive
Join Date: Jan 2017
Location: Bemus Point New York

iTrader: (0)

Garage List
Power steering pump whining

Ever since ive had my car the ps pump has whined. Recently I was parallel parking and it seemed like the pump just failed while i was reversing into the spot. But as soon as i start the car its fine again. Like i said the pump has always whined at low rpm. Fluid is topped off and It doesnt look like its leaking. Any ideas?
Appreciate 0
      12-08-2017, 11:55 PM   #2
mweisdorfer
Brigadier General
mweisdorfer's Avatar
United_States
674
Rep
3,154
Posts

Drives: 2007 Black/Black 335i e90
Join Date: Apr 2011
Location: Holly, MI

iTrader: (0)

Garage List
2007 BMW E90 335i  [0.00]
2008 bmw x5  [0.00]
Quote:
Originally Posted by calswan7145 View Post
Ever since ive had my car the ps pump has whined. Recently I was parallel parking and it seemed like the pump just failed while i was reversing into the spot. But as soon as i start the car its fine again. Like i said the pump has always whined at low rpm. Fluid is topped off and It doesnt look like its leaking. Any ideas?
How old is the fluid ?

Might need to vac & replace the fluid a couple times ? This should be done every 50k.

If fluid is good, might be a sign your power steering pump is going.
Appreciate 0
      12-19-2017, 04:28 PM   #3
GEOS07335i
Lieutenant
78
Rep
515
Posts

Drives: 08 335i
Join Date: Apr 2017
Location: Atlanta

iTrader: (0)

Garage List
Quote:
Originally Posted by calswan7145 View Post
Ever since ive had my car the ps pump has whined. Recently I was parallel parking and it seemed like the pump just failed while i was reversing into the spot. But as soon as i start the car its fine again. Like i said the pump has always whined at low rpm. Fluid is topped off and It doesn't look like its leaking. Any ideas?
I agree how many miles on the car and when was the last time the PS was changed. There are several methods to swapping out the old. The easiest but most expensive is to suck and replace several times. Takes about 3 quarts this way. Also if you have a lot of miles on your car and dont know if it's been done you might want to swap out the reservoir it contains a new filter. If the fluid is very old it could clog up the filter and prevent proper flow which would cause issues. This is the route I'm taking. Mine doesnt whine but judders when you turn it left or right. I'm hoping I dont have a PS pump or PS Rack issue.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 06:07 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST