E90Post
 


TNT Racewerks
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > Long cranks after a while of driving



Reply
 
Thread Tools Search this Thread
      03-11-2019, 06:25 PM   #1
tonyttot
New Member
United_States
0
Rep
9
Posts

Drives: 2011 BMW 335i Sedan
Join Date: Mar 2019
Location: Florida

iTrader: (0)

Garage List
Long cranks after a while of driving

Hi, my 76k miles BMW 335i (N55) has a problem with starting. When I shut down the engine after a while of driving and tries to start again, the car will crank around 2 seconds before it start. The car starts just fine when it is parked for a long time. I don't think it is the battery because it just got replaced last month. Can someone please tell me what issue the car is experiencing? Thanks!

Last edited by tonyttot; 03-16-2019 at 10:17 AM.
Appreciate 0
      03-15-2019, 06:32 PM   #2
ric
New Member
5
Rep
28
Posts

Drives: e93
Join Date: Nov 2018
Location: SE

iTrader: (0)

did you register the battery? possible corroded ground strap. possible starter going bad.
Appreciate 0
      03-15-2019, 10:01 PM   #3
relative4
Private
United_States
20
Rep
94
Posts

Drives: '08 335xi E90 MT stage 1
Join Date: Feb 2019
Location: Denver, CO

iTrader: (0)

Long cranks are of course not indicative of battery or starter problems. They are indicative of several possibilities, notably a failing HPFP. Pull codes.
__________________
Are you gonna eat that?
Appreciate 0
      03-15-2019, 10:12 PM   #4
dannyjones
First Lieutenant
52
Rep
382
Posts

Drives: 2011 BMW 335i M-Sport
Join Date: Jan 2014
Location: Florida, USA

iTrader: (0)

Quote:
Originally Posted by relative4 View Post
Long cranks are of course not indicative of battery or starter problems. They are indicative of several possibilities, notably a failing HPFP. Pull codes.
That would be my guess too, but Iím also guessing you wonít have any codes.
If itís linked to starting after running I canít see it being the battery or starter, and that mainly leaves the well known hpfp as the culprit.
My cranks got worse and worse over months until a seriously bad stutter and limp mode just after starting and finally a code related to fuel pressure. And thatís on a 2011 n55 where the pump is supposed to be better
Appreciate 0
      03-16-2019, 10:08 AM   #5
tonyttot
New Member
United_States
0
Rep
9
Posts

Drives: 2011 BMW 335i Sedan
Join Date: Mar 2019
Location: Florida

iTrader: (0)

Garage List
Quote:
Originally Posted by dannyjones View Post
That would be my guess too, but Iím also guessing you wonít have any codes.
If itís linked to starting after running I canít see it being the battery or starter, and that mainly leaves the well known hpfp as the culprit.
My cranks got worse and worse over months until a seriously bad stutter and limp mode just after starting and finally a code related to fuel pressure. And thatís on a 2011 n55 where the pump is supposed to be better
Hmmm... I mean my cold starts are always quick. So if the hpfp is failing, wouldn't that effect the cold starts too?
Appreciate 0
      03-16-2019, 02:53 PM   #6
dannyjones
First Lieutenant
52
Rep
382
Posts

Drives: 2011 BMW 335i M-Sport
Join Date: Jan 2014
Location: Florida, USA

iTrader: (0)

Quote:
Originally Posted by tonyttot View Post
Hmmm... I mean my cold starts are always quick. So if the hpfp is failing, wouldn't that effect the cold starts too?
Might just be the way itís failing itís worse after running a lot. Canít be certain though, itís just a guess. I wouldnít replace it just yet. Iíd put up with the long cranks until they get worse and/or give you a code giving you more certainty on the source of the problem.
Appreciate 1
      03-16-2019, 05:25 PM   #7
tonyttot
New Member
United_States
0
Rep
9
Posts

Drives: 2011 BMW 335i Sedan
Join Date: Mar 2019
Location: Florida

iTrader: (0)

Garage List
Okay, thanks!
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 07:40 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST