Bimmerpost for Android has just been updated to version 4.3.55 with a host of bug fixes. Try it out!

  E90Post
 


Evolution of Speed
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > Headlight wasn't leveling - Fixed!



Reply
 
Thread Tools Search this Thread
      08-01-2013, 04:14 AM   #67
Henrik
Private
Henrik's Avatar
Canada
0
Rep
72
Posts

Drives: '13 Lexus GS 350 07' E92 335i
Join Date: Jan 2013
Location: Vancouver

iTrader: (3)

Very helpful DIY, thanks op I will try this.
Appreciate 0
      08-03-2013, 08:51 PM   #68
Henrik
Private
Henrik's Avatar
Canada
0
Rep
72
Posts

Drives: '13 Lexus GS 350 07' E92 335i
Join Date: Jan 2013
Location: Vancouver

iTrader: (3)

So I pop the servo back into the socket and it level the headlight now, but one minor problem.

The little green light on the knob that tells you your headlight is on or off doesn't come on when my headlights are on.
Appreciate 0
      08-04-2013, 01:14 AM   #69
v6turbo
Private First Class
United_States
8
Rep
192
Posts

Drives: '87 Buick GN, '06 330i jet blk
Join Date: Sep 2012
Location: Alabama

iTrader: (1)

My head lights are off, the drivers side seems to light further out then the left, how do I know which side is messed up? It sounds like I have the same problem since the previous owner replace two of the rims due to hitting pot holes, I wouldn't mind trying to fix this myself but sounds like it could be complicated and I would hate to take it apart and end up messing it up worse than it already is.
Appreciate 0
      09-27-2013, 07:09 PM   #70
Alliedacid
Enlisted Member
Alliedacid's Avatar
United_States
0
Rep
33
Posts

Drives: '06 325i ZHP / '13 X5d ZHP
Join Date: Jul 2011
Location: NJ

iTrader: (0)

Garage List
Up/down adjustment Ball and socket popped out...

Any suggestions??
Appreciate 0
      09-27-2013, 09:17 PM   #71
ny330xi
Second Lieutenant
8
Rep
249
Posts

Drives: 2006 330xi
Join Date: Apr 2013
Location: upstate

iTrader: (0)

Search for a thread I started about a month ago or pm me
Appreciate 0
      09-27-2013, 10:21 PM   #72
Alliedacid
Enlisted Member
Alliedacid's Avatar
United_States
0
Rep
33
Posts

Drives: '06 325i ZHP / '13 X5d ZHP
Join Date: Jul 2011
Location: NJ

iTrader: (0)

Garage List
Quote:
Originally Posted by ny330xi View Post
Search for a thread I started about a month ago or pm me
http://www.e90post.com/forums/showthread.php?t=875679


Read that one


I too got frustrated... So I cut an access panel in the to of the assembly with a dermal cut off wheel .. And was able to pop the ball back in... Next up some expoy for the housing
Appreciate 0
      12-24-2013, 02:33 PM   #73
dw1
New Member
0
Rep
10
Posts

Drives: 2009 BMW 328xi
Join Date: Nov 2013
Location: Michigan

iTrader: (0)

Great thread, I have a droopy headlight in need of repair on a new to me 328xi
Appreciate 0
      04-05-2014, 12:54 PM   #74
lagz
New Member
0
Rep
17
Posts

Drives: 335xi
Join Date: Aug 2012
Location: canada

iTrader: (0)

hey guy
I think my problem very close to the one op but for me, light goes up and down without reason.
Does someone else experienced it?
Append 80% of the time, even if i am stopped or while driving.

Here is the link:


Look carefully at the light..sometime it is wrost than that.
Appreciate 0
      04-06-2014, 11:21 PM   #75
BKV122
Major
BKV122's Avatar
United_States
31
Rep
1,146
Posts

Drives: E90
Join Date: Feb 2009
Location: NY

iTrader: (1)

Garage List
2006 330xi  [4.75]
Maybe your leveling sensor is loose?
__________________
Monaco Blue 330xi - Terra Interior/6-MT/Sport/Premium/Cold/CSL's/M3 Spoiler Lip/Black Kidney's
Appreciate 0
      04-23-2014, 11:04 AM   #76
deeLow
DOPE
deeLow's Avatar
112
Rep
738
Posts

Drives: 10' 335i
Join Date: Jan 2014
Location: 732

iTrader: (2)

Hey guys, similar problem here on my passenger side. L-R function is fine but the leveling is not. When i start the car I can see it trying to level but nothing more than an inch up or down if that. Light is pointing forward not up or down just a little lower than the driver. Height adjustment does nothing.

Then I noticed that after starting and leveling themselves, if I flash the bi-xenon on and off the level will be higher about 1" than before on both sides.

No codes/errors. I'm thinking it could be one of these arms inside the headlight??
Appreciate 0
      04-25-2014, 01:43 PM   #77
deeLow
DOPE
deeLow's Avatar
112
Rep
738
Posts

Drives: 10' 335i
Join Date: Jan 2014
Location: 732

iTrader: (2)

Bump any ideas??

I took off my light today and checked the servo. All was well ball was in the socket. I removed it and replaced it but still nothing.

My driver side sweeps up and down perfectly fine when I go to start the car and the lights are auto. My passenger doesn't move much at all either direction
Appreciate 0
      04-27-2014, 01:07 AM   #78
fazman
Brigadier General
United_States
591
Rep
3,599
Posts

Drives: 335 e90
Join Date: Feb 2011
Location: Los Angeles

iTrader: (0)

Quote:
Originally Posted by kingdLo View Post
Bump any ideas??

I took off my light today and checked the servo. All was well ball was in the socket. I removed it and replaced it but still nothing.

My driver side sweeps up and down perfectly fine when I go to start the car and the lights are auto. My passenger doesn't move much at all either direction
Where in NJ r u, i would like to compare my issue with yours and see if we can fix both of our headlights. PM me...
Appreciate 0
      04-28-2014, 09:11 AM   #79
BluRock
Registered
0
Rep
1
Posts

Drives: 2009 335i XDrive
Join Date: Mar 2014
Location: New Jersey

iTrader: (0)

Quote:
Originally Posted by fazman View Post
Where in NJ r u, i would like to compare my issue with yours and see if we can fix both of our headlights. PM me...
I have the same problem & not sure how I can fix it. Let me know if you are able to fix it. Could definitely use some help
Appreciate 0
      05-04-2014, 12:15 PM   #80
deeLow
DOPE
deeLow's Avatar
112
Rep
738
Posts

Drives: 10' 335i
Join Date: Jan 2014
Location: 732

iTrader: (2)

Quote:
Originally Posted by fazman
Quote:
Originally Posted by kingdLo View Post
Bump any ideas??

I took off my light today and checked the servo. All was well ball was in the socket. I removed it and replaced it but still nothing.

My driver side sweeps up and down perfectly fine when I go to start the car and the lights are auto. My passenger doesn't move much at all either direction
Where in NJ r u, i would like to compare my issue with yours and see if we can fix both of our headlights. PM me...
Not sure if you have INPA or not...

I loaded mine up today and ran some tests. I was able to activate the 4 different directions through the software. All of mine are working when activated. I was able to make my *problem side* move into proper position after a couple different button presses, but only after a certain direction change, IE pointing down towards left and them towards center would make it center correctly. But after a minute or so it would change positions back to a little droopy.

This is leading me to believe the servo socket ball that people have been finding out of place is indeed out of place for my car too, even after I already took apart the headlight and checked and replaced. It simply must not be in there fully. Will update next time I tackle this.
Appreciate 0
      05-04-2014, 12:16 PM   #81
deeLow
DOPE
deeLow's Avatar
112
Rep
738
Posts

Drives: 10' 335i
Join Date: Jan 2014
Location: 732

iTrader: (2)

Quote:
Originally Posted by BluRock
Quote:
Originally Posted by fazman View Post
Where in NJ r u, i would like to compare my issue with yours and see if we can fix both of our headlights. PM me...
I have the same problem & not sure how I can fix it. Let me know if you are able to fix it. Could definitely use some help
See above
Appreciate 0
      05-06-2014, 06:29 AM   #82
thevinrod
Registered
0
Rep
1
Posts

Drives: 335xi
Join Date: May 2014
Location: Indiana

iTrader: (0)

My left headlight went out after hitting a pothole as well. I posted a DIY fix to the lazy eye headlight issue over at bimmerfest. See below for instructions:

http://www.bimmerfest.com/forums/sho...84#post8320584
Appreciate 0
      06-01-2014, 03:40 PM   #83
snayko
Private First Class
18
Rep
142
Posts

Drives: 325i 2006
Join Date: May 2014
Location: Gainesville, FL

iTrader: (0)

Read this thread and still cannot understand where this thing and what should I unscrew to get to it. Maybe somebody can point me, would be appreciate.
Here is my picture of what I see inside:
Attached Images
 
Appreciate 0
      06-01-2014, 03:55 PM   #84
deeLow
DOPE
deeLow's Avatar
112
Rep
738
Posts

Drives: 10' 335i
Join Date: Jan 2014
Location: 732

iTrader: (2)

Quote:
Originally Posted by snayko
Read this thread and still cannot understand where this thing and what should I unscrew to get to it. Maybe somebody can point me, would be appreciate.
Here is my picture of what I see inside:
That silver thing on the right in this picture with the wires going into it. Look from an angle with light at the opposite end if that motor. Should see what OP is talking about here.

To remove, unclip the wires and turn the motor just like a bulb...
Appreciate 0
      06-01-2014, 06:15 PM   #85
snayko
Private First Class
18
Rep
142
Posts

Drives: 325i 2006
Join Date: May 2014
Location: Gainesville, FL

iTrader: (0)

I did try to remove it like a bulb - turning counterclockwise and pulling it out but looks like its been hold by something else from the other side because when I'm pulling it the whole module is being pulled as well . Does that mean its in place and everything is correct with it or I need it to remove to see ? Cause I can't even imagine how I can see something from other side in that little space.
Appreciate 0
      06-01-2014, 06:39 PM   #86
deeLow
DOPE
deeLow's Avatar
112
Rep
738
Posts

Drives: 10' 335i
Join Date: Jan 2014
Location: 732

iTrader: (2)

Quote:
Originally Posted by snayko
I did try to remove it like a bulb - turning counterclockwise and pulling it out but looks like its been hold by something else from the other side because when I'm pulling it the whole module is being pulled as well . Does that mean its in place and everything is correct with it or I need it to remove to see ? Cause I can't even imagine how I can see something from other side in that little space.
If you can't pull it then yea it's in place. The other end clips into the projector back assembly.

Could be a few things if you don't have up/down leveling.
Appreciate 0
      06-02-2014, 10:52 AM   #87
snayko
Private First Class
18
Rep
142
Posts

Drives: 325i 2006
Join Date: May 2014
Location: Gainesville, FL

iTrader: (0)

Actually sometimes I have up/down leveling after resetting adaptive headlight control unit for the left headlight. But I don't have left/right movement at all. At least I have never seen that.
Appreciate 0
      10-03-2014, 07:29 PM   #88
mattngsx
Enlisted Member
8
Rep
35
Posts

Drives: 09 E90 335i M Sport
Join Date: Aug 2014
Location: MadCity

iTrader: (0)

Not sure if I have the same problem? Everything seems to function like normal. No errors, the lights move Up, down, left, right, like they're supposed to but my driver side projector points down. I manually screw adjust the projector up to raise the projector to level off the lights. I drive around for a little while and the projector sags back down. Is this the same problem?
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 01:13 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST