E90Post
 


TNT Racewerks
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > DIY Guides > DIY - Clown nose blinking LED



Reply
 
Thread Tools Search this Thread
      05-12-2007, 11:26 AM   #111
JJP
New Member
0
Rep
18
Posts

Drives: 2006 BMW 325XI
Join Date: Jul 2006
Location: Omaha, NE

iTrader: (0)

I am actually trying to put the first one together. How do you connect the battery. I see one wire is a ground, and the other wire is the positive for the battery, but where is the negative? I hope I am making sense.

Thanks!
Appreciate 0
      05-12-2007, 12:00 PM   #112
msinfo_us
First Lieutenant
msinfo_us's Avatar
United_States
19
Rep
375
Posts

Drives: 335Xi ZSP, ZCW, PDC
Join Date: Apr 2006
Location: NY

iTrader: (0)

Quote:
Originally Posted by JJP View Post
I am actually trying to put the first one together. How do you connect the battery. I see one wire is a ground, and the other wire is the positive for the battery, but where is the negative? I hope I am making sense.

Thanks!
negative is the ground.
__________________
07 e90 335Xi, SB/Black, ZSP, ZCW, PDC
06 e91 325XiT, TS/Black, ZSP - Sold
Appreciate 0
      06-04-2007, 07:12 PM   #113
155MPH
Major
155MPH's Avatar
United_States
47
Rep
1,379
Posts

Drives: E89 Z4 sDrive28i M Performance
Join Date: May 2007
Location: South Jersey Shore

iTrader: (0)

Garage List
okay, a long thread so I admit I have not read the entire thread...sorry. My question is this...why do you need to do this? On my Z4M I do not have the alarm installed, but the dealer simply programed the car telling it the alarm was installed and the clown nose flashes when the car is locked. So, why doesn't the E90 work the same way?
Appreciate 0
      06-04-2007, 11:30 PM   #114
msinfo_us
First Lieutenant
msinfo_us's Avatar
United_States
19
Rep
375
Posts

Drives: 335Xi ZSP, ZCW, PDC
Join Date: Apr 2006
Location: NY

iTrader: (0)

Quote:
Originally Posted by 155MPH View Post
okay, a long thread so I admit I have not read the entire thread...sorry. My question is this...why do you need to do this? On my Z4M I do not have the alarm installed, but the dealer simply programed the car telling it the alarm was installed and the clown nose flashes when the car is locked. So, why doesn't the E90 work the same way?
Many tried with the same respond from the dealer "can't be done on e90 without buying an alarm". If you install org alarm even without ECU reprogramming LED will stat blinking. Different cars/models/years -- different implementation.
__________________
07 e90 335Xi, SB/Black, ZSP, ZCW, PDC
06 e91 325XiT, TS/Black, ZSP - Sold
Appreciate 0
      06-19-2007, 06:35 PM   #115
Mr. 5
Modder Raider
Mr. 5's Avatar
Scotland
566
Rep
8,629
Posts

Drives: M3
Join Date: Apr 2007
Location: Surf City, HB

iTrader: (31)

Garage List
2007 e90 335i  [4.00]
Quote:
Originally Posted by msinfo_us View Post
Many tried with the same respond from the dealer "can't be done on e90 without buying an alarm". If you install org alarm even without ECU reprogramming LED will stat blinking. Different cars/models/years -- different implementation.
This was one of the funnest DIYs that I've done. I just completed my module and just finished adjusting the flash rate.
I'll try to post some pics tonight.
__________________
e36 M3 Coupe, e36 325i Sedan
e90 335i--SOLD

Best 60-130-------------9.15 Seconds------------------WWW.MR5RACING.COM
Appreciate 0
      06-20-2007, 12:11 AM   #116
Mr. 5
Modder Raider
Mr. 5's Avatar
Scotland
566
Rep
8,629
Posts

Drives: M3
Join Date: Apr 2007
Location: Surf City, HB

iTrader: (31)

Garage List
2007 e90 335i  [4.00]
Quote:
Originally Posted by Mr. 5 View Post
This was one of the funnest DIYs that I've done. I just completed my module and just finished adjusting the flash rate.
I'll try to post some pics tonight.
OK, here's a pic of mine. Like I said previously, it was a blast to do.
I'll install it tomorrow.

Thanks a bunch to msinfo_us for coming up with this DIY.
Attached Images
  
__________________
e36 M3 Coupe, e36 325i Sedan
e90 335i--SOLD

Best 60-130-------------9.15 Seconds------------------WWW.MR5RACING.COM
Appreciate 0
      06-20-2007, 12:48 AM   #117
D-Rock
Lieutenant Colonel
142
Rep
1,855
Posts

Drives: 325i
Join Date: Jul 2005
Location: miami

iTrader: (2)

Send a message via AIM to D-Rock
This is very off topic. But could i take the alarm out of my moms x5 and put it in my car ?
__________________
Appreciate 0
      06-20-2007, 05:18 PM   #118
msinfo_us
First Lieutenant
msinfo_us's Avatar
United_States
19
Rep
375
Posts

Drives: 335Xi ZSP, ZCW, PDC
Join Date: Apr 2006
Location: NY

iTrader: (0)

Quote:
Originally Posted by Mr. 5 View Post
OK, here's a pic of mine. Like I said previously, it was a blast to do.
I'll install it tomorrow.

Thanks a bunch to msinfo_us for coming up with this DIY.
You are very welcome and great job!

BTW In case you don't want to remove the mirror than rewire connector to LED in a clown nose and you want to use existing wires. I finally traced them down in my car. When you open head console you'll see bunch of wires with different colors coming from the mirror and rain sensor. Negative is Black wire with Grey stripe and positive is Red wire with Blue stripe (at least it is in my car). To trace them I disconnected the car battery and used 9V battery with wires connected to needles (I did not want to strip any wires). Now, if you want to use existing wires you'll have to cut them! Don't try to tap -- there is 12V on one of the wires and second wire IS NOT grounded. I think that removing mirror is very easy to do but wanted to give you options so you can choose.
__________________
07 e90 335Xi, SB/Black, ZSP, ZCW, PDC
06 e91 325XiT, TS/Black, ZSP - Sold
Appreciate 0
      06-20-2007, 05:20 PM   #119
msinfo_us
First Lieutenant
msinfo_us's Avatar
United_States
19
Rep
375
Posts

Drives: 335Xi ZSP, ZCW, PDC
Join Date: Apr 2006
Location: NY

iTrader: (0)

Quote:
Originally Posted by D-Rock View Post
This is very off topic. But could i take the alarm out of my moms x5 and put it in my car ?
You can check with your dealer but I don't think so.
__________________
07 e90 335Xi, SB/Black, ZSP, ZCW, PDC
06 e91 325XiT, TS/Black, ZSP - Sold
Appreciate 0
      06-23-2007, 05:11 PM   #120
Mr. 5
Modder Raider
Mr. 5's Avatar
Scotland
566
Rep
8,629
Posts

Drives: M3
Join Date: Apr 2007
Location: Surf City, HB

iTrader: (31)

Garage List
2007 e90 335i  [4.00]
Quote:
Originally Posted by msinfo_us View Post
You are very welcome and great job!

BTW In case you don't want to remove the mirror than rewire connector to LED in a clown nose and you want to use existing wires. I finally traced them down in my car. When you open head console you'll see bunch of wires with different colors coming from the mirror and rain sensor. Negative is Black wire with Grey stripe and positive is Red wire with Blue stripe (at least it is in my car). To trace them I disconnected the car battery and used 9V battery with wires connected to needles (I did not want to strip any wires). Now, if you want to use existing wires you'll have to cut them! Don't try to tap -- there is 12V on one of the wires and second wire IS NOT grounded. I think that removing mirror is very easy to do but wanted to give you options so you can choose.
Well, I installed it and it didn't work.
Fist of all, the light still blinked when the car was on at a very, very fast pace.
Seciond, the light was very dim when the car was locked.

I tried the second scheamtic and I got nothing. I did this because this was supposed to make the led brighter.

Will you look at the second schematic and trace over what is wrong with this?
I did exactly what you said, but the light isn't even going on.
http://www.e90post.com/forums/attach...1&d=1160344114
__________________
e36 M3 Coupe, e36 325i Sedan
e90 335i--SOLD

Best 60-130-------------9.15 Seconds------------------WWW.MR5RACING.COM
Appreciate 0
      06-23-2007, 11:12 PM   #121
msinfo_us
First Lieutenant
msinfo_us's Avatar
United_States
19
Rep
375
Posts

Drives: 335Xi ZSP, ZCW, PDC
Join Date: Apr 2006
Location: NY

iTrader: (0)

Quote:
Originally Posted by Mr. 5 View Post
Well, I installed it and it didn't work.
Fist of all, the light still blinked when the car was on at a very, very fast pace.
Seciond, the light was very dim when the car was locked.

I tried the second scheamtic and I got nothing. I did this because this was supposed to make the led brighter.

Will you look at the second schematic and trace over what is wrong with this?
I did exactly what you said, but the light isn't even going on.
http://www.e90post.com/forums/attach...1&d=1160344114
OK Don't worry. It seems like a little troubleshooting is in order. BTW fast blinking was normal if second threshold (low voltage 4.5V) is not properly adjusted. Anyway, since you end up with second version let's concentrate on it. Check that C1 is properly installed; + to R2 and - to ground. Leave R2 at 3M and install let's say 10K for R1 (the blinking rate might be slightly faster than you want but you can always change it later). Put R3 in a minimum resistance position and R4 in mid position. Connect 9V battery or 12V power source and adjust R4 back and force - does LED blink? If not reverse LED. If you have multimeter troubleshooting will be so much easer. Record V before and after r3 and 3rd leg of the chip (out pin). Let me know what you've got. Now, keep in mind that you've got two thresholds to work with. The power comes with 10-12V when car is locked (after minute or so) and 4.5V when car s running/unlocked. At 4.5V your LED should not be blinking -- you need to adjust R4 to the threshold were it works at 12V and does not at 4.5V. Let me know the results.

PS Please double check that you've got everything connected properly. if there is a dot on a diagram there is a connection, if there is no dot -- no connetion.
__________________
07 e90 335Xi, SB/Black, ZSP, ZCW, PDC
06 e91 325XiT, TS/Black, ZSP - Sold
Appreciate 0
      06-24-2007, 01:27 AM   #122
Mr. 5
Modder Raider
Mr. 5's Avatar
Scotland
566
Rep
8,629
Posts

Drives: M3
Join Date: Apr 2007
Location: Surf City, HB

iTrader: (31)

Garage List
2007 e90 335i  [4.00]
Quote:
Originally Posted by msinfo_us View Post
OK Don't worry. It seems like a little troubleshooting is in order. BTW fast blinking was normal if second threshold (low voltage 4.5V) is not properly adjusted. Anyway, since you end up with second version let's concentrate on it. Check that C1 is properly installed; + to R2 and - to ground. Leave R2 at 3M and install let's say 10K for R1 (the blinking rate might be slightly faster than you want but you can always change it later). Put R3 in a minimum resistance position and R4 in mid position. Connect 9V battery or 12V power source and adjust R4 back and force - does LED blink? If not reverse LED. If you have multimeter troubleshooting will be so much easer. Record V before and after r3 and 3rd leg of the chip (out pin). Let me know what you've got. Now, keep in mind that you've got two thresholds to work with. The power comes with 10-12V when car is locked (after minute or so) and 4.5V when car s running/unlocked. At 4.5V your LED should not be blinking -- you need to adjust R4 to the threshold were it works at 12V and does not at 4.5V. Let me know the results.

PS Please double check that you've got everything connected properly. if there is a dot on a diagram there is a connection, if there is no dot -- no connetion.
OK, I have a lot of questions:

What about 4 on the timer?
I believe you said to connect 4 to the R4 pot, but should it be before the pot or after?
I couldn't find a 10-20k pot so I added a 10k resistor after a 0-10k pot. This will make it 10-20k because it is additive correct?

Also, I just want to make sure that you did say the capacitor is .1 to .5 uf.
That's a big change from before when we used 1000uf. Why did it go down so much?

Are there + and - sides on the capcitor or does it matter?
Thanks. I will try again tomorrow. Hopefully I will get these answered before I start.
__________________
e36 M3 Coupe, e36 325i Sedan
e90 335i--SOLD

Best 60-130-------------9.15 Seconds------------------WWW.MR5RACING.COM
Appreciate 0
      06-24-2007, 10:24 AM   #123
msinfo_us
First Lieutenant
msinfo_us's Avatar
United_States
19
Rep
375
Posts

Drives: 335Xi ZSP, ZCW, PDC
Join Date: Apr 2006
Location: NY

iTrader: (0)

Quote:
Originally Posted by Mr. 5 View Post
OK, I have a lot of questions:

What about 4 on the timer?
I believe you said to connect 4 to the R4 pot, but should it be before the pot or after?

POT has three legs: first to third resistance is constant, and second is variable resistance. For R4 100K POT you need to connect number 4 on a timer to variable leg of POT and other two to timer #8 (+) and ground correspondingly.

I couldn't find a 10-20k pot so I added a 10k resistor after a 0-10k pot. This will make it 10-20k because it is additive correct?

Correct, it will make it 10-20K. But for now use R3 0-10K POT without 10K. You'll add 10K IF 0-10K range won't be enough

Also, I just want to make sure that you did say the capacitor is .1 to .5 uf.
That's a big change from before when we used 1000uf. Why did it go down so much?

LED is reversed in a second version and you need a quick discharge

Are there + and - sides on the capacitor or does it matter?

Yes, there is + and - on capacitor and it does matters

Thanks. I will try again tomorrow. Hopefully I will get these answered before I start.
Please see above.
__________________
07 e90 335Xi, SB/Black, ZSP, ZCW, PDC
06 e91 325XiT, TS/Black, ZSP - Sold
Appreciate 0
      06-24-2007, 12:50 PM   #124
Mr. 5
Modder Raider
Mr. 5's Avatar
Scotland
566
Rep
8,629
Posts

Drives: M3
Join Date: Apr 2007
Location: Surf City, HB

iTrader: (31)

Garage List
2007 e90 335i  [4.00]
Quote:
Originally Posted by msinfo_us View Post
Please see above.
Thanks a bunch.
I'll try again today.
__________________
e36 M3 Coupe, e36 325i Sedan
e90 335i--SOLD

Best 60-130-------------9.15 Seconds------------------WWW.MR5RACING.COM
Appreciate 0
      06-24-2007, 07:54 PM   #125
Mr. 5
Modder Raider
Mr. 5's Avatar
Scotland
566
Rep
8,629
Posts

Drives: M3
Join Date: Apr 2007
Location: Surf City, HB

iTrader: (31)

Garage List
2007 e90 335i  [4.00]
Project completed!
Thanks again. I took off the 10K resistor and it started working.
The light still isn't that bright but I guess it will do.

I had a lot of fun doing this. I had no experience in the past with this and I had to read the first post around 10 times, but I really love puzzles and this was a good one.
__________________
e36 M3 Coupe, e36 325i Sedan
e90 335i--SOLD

Best 60-130-------------9.15 Seconds------------------WWW.MR5RACING.COM
Appreciate 0
      06-24-2007, 11:58 PM   #126
msinfo_us
First Lieutenant
msinfo_us's Avatar
United_States
19
Rep
375
Posts

Drives: 335Xi ZSP, ZCW, PDC
Join Date: Apr 2006
Location: NY

iTrader: (0)

Quote:
Originally Posted by Mr. 5 View Post
Project completed!
Thanks again. I took off the 10K resistor and it started working.
The light still isn't that bright but I guess it will do.

I had a lot of fun doing this. I had no experience in the past with this and I had to read the first post around 10 times, but I really love puzzles and this was a good one.
I am glad you liked it. Congrats!

PS Did you compare LED brightness to factory alarm? When I compared I did not see any noticable difference in brightness. The LED is not that bright during the day but very visible at night and the same is true for factory alarm ... Anyway, good job!
__________________
07 e90 335Xi, SB/Black, ZSP, ZCW, PDC
06 e91 325XiT, TS/Black, ZSP - Sold
Appreciate 0
      06-25-2007, 11:43 AM   #127
Mr. 5
Modder Raider
Mr. 5's Avatar
Scotland
566
Rep
8,629
Posts

Drives: M3
Join Date: Apr 2007
Location: Surf City, HB

iTrader: (31)

Garage List
2007 e90 335i  [4.00]
Quote:
Originally Posted by msinfo_us View Post
I am glad you liked it. Congrats!

PS Did you compare LED brightness to factory alarm? When I compared I did not see any noticable difference in brightness. The LED is not that bright during the day but very visible at night and the same is true for factory alarm ... Anyway, good job!
Thanks!
Another thing. I noticed myself adjusting the R3 pot for the threshold instead of the R4 pot. Honestly, the R4 pot isn't doing anything no matter how I adjust it. I've verified that the pot is working but it's not doing anything to the LED.
__________________
e36 M3 Coupe, e36 325i Sedan
e90 335i--SOLD

Best 60-130-------------9.15 Seconds------------------WWW.MR5RACING.COM
Appreciate 0
      06-25-2007, 07:43 PM   #128
msinfo_us
First Lieutenant
msinfo_us's Avatar
United_States
19
Rep
375
Posts

Drives: 335Xi ZSP, ZCW, PDC
Join Date: Apr 2006
Location: NY

iTrader: (0)

Quote:
Originally Posted by Mr. 5 View Post
Thanks!
Another thing. I noticed myself adjusting the R3 pot for the threshold instead of the R4 pot. Honestly, the R4 pot isn't doing anything no matter how I adjust it. I've verified that the pot is working but it's not doing anything to the LED.
That would explain why the LED is not as bright as it should be for version 2. What you doing is more or less adjusting version 2 to work like version 1. The R4 is used to setup a reset treshold instead of adjusting timer V using R3 in version 1. The only way I can think of when it would be doing nothing if timer leg #4 is NOT connected to a central leg (variable resistance) of R4. Do you have a multimeter? Can you check?
__________________
07 e90 335Xi, SB/Black, ZSP, ZCW, PDC
06 e91 325XiT, TS/Black, ZSP - Sold
Appreciate 0
      06-25-2007, 07:44 PM   #129
ctgazer
Major General
ctgazer's Avatar
Canada
322
Rep
7,953
Posts

Drives: a dilapidated ride
Join Date: Feb 2006
Location: canada eh!

iTrader: (10)

Garage List
2006 e90  [0.00]
Send a message via MSN to ctgazer
got a question...in the e46 the clown nose could be twisted to control the dimness of the mirror...how come it cant be adjusted in the e90?
__________________
Appreciate 0
      06-25-2007, 09:01 PM   #130
msinfo_us
First Lieutenant
msinfo_us's Avatar
United_States
19
Rep
375
Posts

Drives: 335Xi ZSP, ZCW, PDC
Join Date: Apr 2006
Location: NY

iTrader: (0)

Quote:
Originally Posted by ctgazer View Post
got a question...in the e46 the clown nose could be twisted to control the dimness of the mirror...how come it cant be adjusted in the e90?
I am not sure about this question ... that is how it works in e90 as well: twist clone nose and mirror changes it's angle.
__________________
07 e90 335Xi, SB/Black, ZSP, ZCW, PDC
06 e91 325XiT, TS/Black, ZSP - Sold
Appreciate 0
      06-26-2007, 04:14 PM   #131
Mr. 5
Modder Raider
Mr. 5's Avatar
Scotland
566
Rep
8,629
Posts

Drives: M3
Join Date: Apr 2007
Location: Surf City, HB

iTrader: (31)

Garage List
2007 e90 335i  [4.00]
Quote:
Originally Posted by ctgazer View Post
got a question...in the e46 the clown nose could be twisted to control the dimness of the mirror...how come it cant be adjusted in the e90?
If you have the auto dimming mirror then the clown nose won't adjust.
If you don't, then turning the clown nose will tilt the mirror for the night.
__________________
e36 M3 Coupe, e36 325i Sedan
e90 335i--SOLD

Best 60-130-------------9.15 Seconds------------------WWW.MR5RACING.COM
Appreciate 0
      06-26-2007, 04:17 PM   #132
Mr. 5
Modder Raider
Mr. 5's Avatar
Scotland
566
Rep
8,629
Posts

Drives: M3
Join Date: Apr 2007
Location: Surf City, HB

iTrader: (31)

Garage List
2007 e90 335i  [4.00]
Quote:
Originally Posted by msinfo_us View Post
That would explain why the LED is not as bright as it should be for version 2. What you doing is more or less adjusting version 2 to work like version 1. The R4 is used to setup a reset treshold instead of adjusting timer V using R3 in version 1. The only way I can think of when it would be doing nothing if timer leg #4 is NOT connected to a central leg (variable resistance) of R4. Do you have a multimeter? Can you check?
I'll check with the mutimeter a little bit later.
Thank for all of the repsonses.
__________________
e36 M3 Coupe, e36 325i Sedan
e90 335i--SOLD

Best 60-130-------------9.15 Seconds------------------WWW.MR5RACING.COM
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 05:13 AM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST