E90Post
 


The Tire Rack
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > Australia > N54 Powerglide



Reply
 
Thread Tools Search this Thread
      07-01-2020, 03:07 PM   #441
Brule
Brigadier General
Australia
714
Rep
3,143
Posts

Drives: 2007 335i e92 6spd man
Join Date: Jul 2013
Location: Darwin

iTrader: (0)

No drive had a big big day at work.
The further past 400hp it gets the less fun this car is on the street.
Might just leave it until I can get on the dyno.
Appreciate 0
      07-02-2020, 01:15 AM   #442
Aus335iguy
Colonel
Aus335iguy's Avatar
627
Rep
2,277
Posts

Drives: 2009 e92 335i MSport DCT
Join Date: Jul 2015
Location: Sydney Aus

iTrader: (0)

Garage List
2009 BMW 335i  [10.00]
Quote:
Originally Posted by Brule View Post
No drive had a big big day at work.
The further past 400hp it gets the less fun this car is on the street.
Might just leave it until I can get on the dyno.
hand full ?
__________________
When you doppelkaplung you doppel your fun.
Appreciate 0
      07-02-2020, 01:30 AM   #443
Brule
Brigadier General
Australia
714
Rep
3,143
Posts

Drives: 2007 335i e92 6spd man
Join Date: Jul 2013
Location: Darwin

iTrader: (0)

Most fun I had was with a bigger set of twins with pump fuel on 15psi or e40 at 20 psi. Floor it any time and have fun.

Now its on boost and you just hang on.
Literally no other 700hp street car would be faster.
Manual would be awsome with single turbo.
Appreciate 1
      07-03-2020, 01:37 AM   #444
Brule
Brigadier General
Australia
714
Rep
3,143
Posts

Drives: 2007 335i e92 6spd man
Join Date: Jul 2013
Location: Darwin

iTrader: (0)

Went for test drive.

About an hour out of town.
3rd wot blew the same intercooler pipe.

I did not put the vacuum hose back on the turbo.
spiked to 30psi. Had 27psi safety set and it worked.

Might extend cooler pipe 30mm and try again with the vacuum hose on..oops
Appreciate 1
      07-03-2020, 01:43 AM   #445
Brule
Brigadier General
Australia
714
Rep
3,143
Posts

Drives: 2007 335i e92 6spd man
Join Date: Jul 2013
Location: Darwin

iTrader: (0)

Log image 30.5psi
lpfp and hpfp going allright.
Attached Images
 
Appreciate 2
Socket4017.00
      07-03-2020, 09:18 AM   #446
Aus335iguy
Colonel
Aus335iguy's Avatar
627
Rep
2,277
Posts

Drives: 2009 e92 335i MSport DCT
Join Date: Jul 2015
Location: Sydney Aus

iTrader: (0)

Garage List
2009 BMW 335i  [10.00]
Did you manage to get a draggy time out of it?
__________________
When you doppelkaplung you doppel your fun.
Appreciate 0
      07-03-2020, 01:57 PM   #447
Brule
Brigadier General
Australia
714
Rep
3,143
Posts

Drives: 2007 335i e92 6spd man
Join Date: Jul 2013
Location: Darwin

iTrader: (0)

Not yet.

I just changed the scalar to reduce fuel trims on tip in. They look better now.

The boost was going up and up crazy as I had the boost reference line off the turbo or it blew off?
Ill put clamps on them now.

I had dragy ready go. Maybe this wknd I can get a 1/4 time.
Appreciate 0
      07-03-2020, 07:32 PM   #448
Brule
Brigadier General
Australia
714
Rep
3,143
Posts

Drives: 2007 335i e92 6spd man
Join Date: Jul 2013
Location: Darwin

iTrader: (0)

Did a 17.22 at 55mph 1/4
5.65 0-60

Little bit of room for improvement
Appreciate 1
      07-04-2020, 06:08 PM   #449
Brule
Brigadier General
Australia
714
Rep
3,143
Posts

Drives: 2007 335i e92 6spd man
Join Date: Jul 2013
Location: Darwin

iTrader: (0)

Did a few runs this morning.

I got pulled down to reality pretty quick with 3 13 sec runs and best of 12.95 114mph 2.65 60ft.
lpfp is normally strong holding boost pressure amount above base of 70psi.
The first run that was filmed I hit 46psi lpfp. Luckily hpfp was still pumping over 1400 down to 1000psi before I let off.
Intercooler is unreal. A rise of 7f from transbrake to end of 1/4mile is pretty good. It drops the gained 7f heat in about 10 seconds or by the time you slow down.

I will have to re work the lpfp setup as I think its draining the batterry.
I have a ti274 lift pump and 2 ti274 to pump the fuel.
I will change the lift pump to a low amp e85 rated pump and see if that improves.
Might need to hold off l9ng runs for now.

Last edited by Brule; 07-04-2020 at 06:34 PM..
Appreciate 0
      07-04-2020, 06:11 PM   #450
Brule
Brigadier General
Australia
714
Rep
3,143
Posts

Drives: 2007 335i e92 6spd man
Join Date: Jul 2013
Location: Darwin

iTrader: (0)

Runs.

I did a few 17s trying to use dragy too.
Attached Images
 
Appreciate 0
      07-04-2020, 06:13 PM   #451
Brule
Brigadier General
Australia
714
Rep
3,143
Posts

Drives: 2007 335i e92 6spd man
Join Date: Jul 2013
Location: Darwin

iTrader: (0)

Might need more boost.

Appreciate 0
      07-05-2020, 10:09 PM   #452
Aus335iguy
Colonel
Aus335iguy's Avatar
627
Rep
2,277
Posts

Drives: 2009 e92 335i MSport DCT
Join Date: Jul 2015
Location: Sydney Aus

iTrader: (0)

Garage List
2009 BMW 335i  [10.00]
I dont think ive ever seen anyone break records on a shake down run and 12s is pretty good considering
Keep going mate
__________________
When you doppelkaplung you doppel your fun.
Appreciate 0
      07-05-2020, 11:53 PM   #453
Coupes33
Major
351
Rep
1,356
Posts

Drives: 2006 335i, 2017 Audi S3
Join Date: Aug 2013
Location: Brisbane, QLD, Australia

iTrader: (0)

Quote:
Originally Posted by Brule View Post
Might need more boost.

Interesting watching the video a couple of times as a couple of things have got me puzzled. Firstly, when you launched, the tacho seemed to flare from 4,000rpm to 5,000rpm and then dropped back to 3,000rpm before accelerating again as if something was slipping in the transmission or was it wheel spin. Then, when you changed into 2nd the tacho only dropped back to 6,000rpm and didn't seem to move much although the speedo was increasing substantially. Is your tacho working ok?

Last edited by Coupes33; 07-06-2020 at 12:41 AM..
Appreciate 0
      07-06-2020, 04:30 AM   #454
Brule
Brigadier General
Australia
714
Rep
3,143
Posts

Drives: 2007 335i e92 6spd man
Join Date: Jul 2013
Location: Darwin

iTrader: (0)

I accidentally had the dtc button left normal. When I felt it starting to wheel spin so I backed off.
I didnt even realise the dtc was working on. It has not worked for around 4 years and its always like traction control is off. Might explain why it was difficult to launch.

The converter works alot on a powerglide. 1st gear is like 3rd and 2nd is lime 5th gear. The converter just gets up in the rpm and slowly get less and less slip as you go faster mph. Its a fair old load especially with a 3.08 diff.
Appreciate 0
      07-06-2020, 04:45 AM   #455
Brule
Brigadier General
Australia
714
Rep
3,143
Posts

Drives: 2007 335i e92 6spd man
Join Date: Jul 2013
Location: Darwin

iTrader: (0)

Quote:
Originally Posted by Aus335iguy View Post
I dont think ive ever seen anyone break records on a shake down run and 12s is pretty good considering
Keep going mate
lol
yea 12.9 after 4 goes pulls you back to reality real quick. Its not easy.

Accidentally had dtc button not pressed or held down.
17 psi
6 degrees adv.

I will try again on 17psi but turn traction off and let tyres down.
see iff I can get low 12.
Appreciate 0
      07-06-2020, 07:29 PM   #456
Coupes33
Major
351
Rep
1,356
Posts

Drives: 2006 335i, 2017 Audi S3
Join Date: Aug 2013
Location: Brisbane, QLD, Australia

iTrader: (0)

Quote:
Originally Posted by Brule View Post
I accidentally had the dtc button left normal. When I felt it starting to wheel spin so I backed off.
I didnt even realise the dtc was working on. It has not worked for around 4 years and its always like traction control is off. Might explain why it was difficult to launch.

The converter works alot on a powerglide. 1st gear is like 3rd and 2nd is lime 5th gear. The converter just gets up in the rpm and slowly get less and less slip as you go faster mph. Its a fair old load especially with a 3.08 diff.
Brule, I would have thought that in second (top) gear (1.00 to 1 ratio) the converter should be locked up without any slip from around 4,000 rpm onwards. If it is slipping at 6,000 rpm, you are losing power to the ground, time and heating up the transmission fluid. A calculation of what speed you should be doing at 6,000 rpm in top gear, it works out at 240 kph. In the video, the rpm only drops to 6,000 rpm when changing into top gear and speed starts increasing from 100 kph up to 200 kph at 6,500 rpm. Something is slipping in the transmission mate.

Last edited by Coupes33; 07-07-2020 at 03:46 AM..
Appreciate 0
      07-06-2020, 11:24 PM   #457
Coupes33
Major
351
Rep
1,356
Posts

Drives: 2006 335i, 2017 Audi S3
Join Date: Aug 2013
Location: Brisbane, QLD, Australia

iTrader: (0)

What gear ratio is 1st in your powerglide Brule? Is it 1.82? Assuming it is, I have done calculations to see what speed you should be doing at 6,500 rpm in 1st gear (What you went to in video). Using the diameter of my tyres, it works out at 146 kph. In the video, you were at 100 kph @ 6,500 rpm. Something is slipping in your transmission (converter or clutches). If you tell me the diameter of your tyres, I can review the calculations.

Last edited by Coupes33; 07-07-2020 at 03:39 AM..
Appreciate 0
      07-07-2020, 02:32 AM   #458
Socket
Lieutenant General
Socket's Avatar
Australia
4017
Rep
11,775
Posts

Drives: 335i
Join Date: Nov 2014
Location: Melbourne

iTrader: (4)

Garage List
2008 BMW E92  [0.00]
At least its up and running and setting draggy times
Is just the start of dialing it in
Sounds like a friggin monster Brule
Appreciate 0
      07-07-2020, 03:58 AM   #459
Brule
Brigadier General
Australia
714
Rep
3,143
Posts

Drives: 2007 335i e92 6spd man
Join Date: Jul 2013
Location: Darwin

iTrader: (0)

1.86 1st gear

I need a higher rear diff ratio to help get the car moving.

Not sure why it is such a high rpm for the speed its going. I thought it was normal as it feels like you are moving. I have checked the band twice but might need to re check trans fluid then keep digging around.
Appreciate 0
      07-07-2020, 04:07 AM   #460
Brule
Brigadier General
Australia
714
Rep
3,143
Posts

Drives: 2007 335i e92 6spd man
Join Date: Jul 2013
Location: Darwin

iTrader: (0)

I haven't even had enough wot time to get boost on target.
Only 4 1st to 2nd gear runs to try and dial it in. Ive got duty cycle at 30% and its within 1psi. I've got the ramp of boost really low also at 40. (100% duty to 7psi then trying to stop it coming on hard)

Ordered a low amp lift pump, see if that helps battery draw down a bit. See whats going on with the trans and keep testing.

I might go to alice springs in 2 weeks if its running well.
Appreciate 0
      07-08-2020, 02:47 AM   #461
Brule
Brigadier General
Australia
714
Rep
3,143
Posts

Drives: 2007 335i e92 6spd man
Join Date: Jul 2013
Location: Darwin

iTrader: (0)

O2 heat bungs turned up.

No copper gasket
No adjustable rings to make the flow the right way.

cheap but now I need custom parts for them to work.

photos
Attached Images
   
Appreciate 0
      07-08-2020, 03:26 AM   #462
RJ019
Private First Class
Australia
80
Rep
103
Posts

Drives: 2009 135i Low Mount ST
Join Date: May 2017
Location: ACT

iTrader: (0)

That came quick I had to wait like a month to get mine as they ran out of stock.

I was just going to use some washers to make sure it was clocked correctly shouldn't be too hard.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 01:37 AM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST