E90Post
 


TNT Racewerks
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > All-Wheel-Drive (Xi / xDrive) Talk > SOLVED: HELP - 07 328xi Stuttering/Shaking at 3-8% throttle



Reply
 
Thread Tools Search this Thread
      12-04-2015, 08:56 AM   #1
igzekyativ
Captain
United_States
110
Rep
756
Posts

Drives: 2007 BMW 328xi Wagon
Join Date: Apr 2011
Location: Asheville, NC

iTrader: (2)

Garage List
2007 BMW 328xi  [0.00]
SOLVED: HELP - 07 328xi Stuttering/Shaking at 3-8% throttle

Solution - Buy new (re-manufactured) torque converter and install.


2016.4.22 - I changed the transmission fluid and added two Lubegard additives. It's only been one day and so far so good. I will report back in a couple weeks time.

2016.4.27 - Everything is still good, the shudder has not returned.

2016.5.20 - Shudder returned

2016.6.18 - broken leg.. repairs will have to wait

2016.11 - ordered remanufactured TC and installed. Shudder is less, but still present

2016.12 - TC has broken in and I do not have any shudder anymore.. finally, yay!


Original Post:
Hello, looking for some help to diagnose my 328xi Shudder/Shaking Issue

Here is the info on the car:
2007 BMW 328xi Wagon
~101,000 miles

I already took the car to an indy shop Sterling, VA and they could not correctly diagnose the problem. I've taken the car to BMW and they told me it was software and coils, which we fixed, and they did not solve the problem. The indy shop told me I needed new driveshaft flex discs, and that while doing that job they could take a look at the transfer case (it was leaking oil) as it could be a contributing factor. They also said the engine does not seem to be the problem and they ruled out coil packs causing the issue. They noted that the engine mounts seem to be ok, but that with a prybar they were able to move the engine, so there is signs of wear. BMW said it was an engine problem and not drivetrain.

I bought this car a few month ago and it needed work right away. I replaced the battery, water pump, thermostat, valve cover gasket, valve cover, valve cover screws, spark plugs, and eccentric shaft sensor.

Now on to the problem. After the car has reached full operating temperature, the issue starts to present itself. Basically, the car shudders/shakes when applying the throttle just a little (~1-8%). It happens at all speeds, and only in the 1200-2500 RPM range. It happens in non-sport mode and in sport mode, but more so in non-sport mode, due to lower RPMs. It does not happen when the car accelerates at a good pace, and does not happen at WOT. I am also noticing that the shaking/vibrations happens during shifts under light load.

The indy shop said they could replicate the problem when they were cruising at about 40 mph and then applied 2-5% throttle. For me it happens constantly on my 25 mile commute to and from work. It takes about 10-15 miles of driving before the problem really starts to show up and the stop and go traffic intensifies the shaking. It feels as if I am going over rumble strips, but there is no noise. Going up a hill exacerbates the issue and the stuttering/shaking happens more frequently.

After taking the car to the indy shop:

1 - I replaced the front and rear guibos and the center bearing on the rear driveshaft.
1.1 - This did not resolve the issue.

2 - I removed the front driveshaft and drove around.
2.1 - The issue was still present.
2.2 - I re-installed the front driveshaft.
2.3 - Issue must reside within the rear drive-line or engine.

3 - I replaced the rear output shaft seal (item #3 in the image) as well as the o-ring (item #5), drained and filled the transfer case fluid, replaced the fill and drain plugs, had the transmission learning reset, and had the transfer case programmed for its new oil.
3.1 - This did not solve the problem.
3.2 - The transfer case was leaking from the o ring, and not the seal.
3.2.1 - I suspect do to the shaking/vibrations.
3.2.2 - Replaced the seal anyways.
3.3 - I thought maybe the fluid was low due to the leak and the clutches in the transfer case were not working properly.

Not knowing what to do and not wanting to waste money, I took the car to BMW for diagnostics. They told me the entire car needed to have its software updated because it was still running its original 2006 software and that the ignition coils were causing the shaking. The tech's notes said, "Vehicle let idle at operating temperature, with slight tap on gas pedal, vibration was felt on engine. Vehicle test drove and vibration felt at all speed around 1800 RPM with light load on engine. Smooth running value checked to verify erratic spike on reading for cylinder 1 and 3 after short test. Removal on ignition coil to verify vehicle has 2006 (possible original) ignition coils. Replacement of all ignition coils, plugs* and resealing valve cover* recommended." *I just replaced the plugs and valve cover less than 1,000 miles ago. All of this lead him to believe that it is an engine problem and not a drivetrain problem.

4 - I had BMW update all of the software on my car (took 10+ hours to do this).
4.1 - Did not resolve the issue

5 - I ordered and replaced all ignition coils.
5.1 - did not resolve the issue.

6 - Replaced the transfer case actuator motor
6.1 - this did not solve the problem
6.2 - the original motor gears show no signs of wear

I had 3 suspicions as to what the problem is before taking it to BMW:
A - The rear driveshaft is messed up (unbalanced, bad u-joint, etc) and needs to be replaced/refurbished.
i - I have read about “harmonic vibrations” where things hit a certain RPM which resonates the rotating piece and causes the vibration.
ii - Could be a bad u-joint causing the shaking.

B - Something with the transmission because the car sometimes shakes when shifting, but that could also be due to the driveshaft shaking at different RPMs.
i - This is just my own thoughts, not really sure about it, maybe a slipping torque converter?

ALL I WANT TO DO IS STOP WASTING MONEY ON SOLUTIONS THAT DON'T WORK.

Hopefully I've done a thorough job describing my issues, but please feel free to ask me for any additional details you think would be helpful.

Does anyone have any thoughts or suggestions?

__________________
2007 328xi Wagon, Black Sapphire Metallic, Sports Package, Cold Weather Package, Rear PDC, Airlift kit with 3P mgmt, CF Akrym rep lip, LCI M-Tech front bumper, LUX Angel Eyes, Black Kidneys, LED Interior Lights, M3 Steering Wheel with Extended Billet DCT Paddles, 19" Staggered VMR 710's

Last edited by igzekyativ; 01-28-2017 at 03:43 PM..
Appreciate 0
      12-04-2015, 01:07 PM   #2
YGazis109
Yiannis Gazis
YGazis109's Avatar
United_States
85
Rep
734
Posts

Drives: 2007 328xi
Join Date: Jul 2012
Location: Somers, CT

iTrader: (4)

Garage List
2013 BMW 335is  [0.00]
Dude I have the same exact thing! In the spring when I change my oil pan gasket I am going to change my tranny mounts and motor mounts going to see if that helps
__________________
2nd Bimmer - 2013 335is | Alpine White | DCT | Loaded
1st Bimmer - 2007 328xi | SGM | e90 | Premium | Navi | Gloss black trim | Cold | AA headers | 3 stage intake manifold | AA stage 3 tune | AFE stage 2 intake | Cyba Scoops | OEM Blacklines | OEM LCI mtech front bumper | OEM LCI hood | OEM gloss black kidney grills | Orion v4 LED halos with blackout headlights | Valentine 1 Radar | Sport wheel with paddles | kw v1 coilovers | VMR 710 | Continental ExtremeContact DW |
Appreciate 0
      12-05-2015, 12:06 AM   #3
RL325xi
Private
12
Rep
74
Posts

Drives: 2006 e91
Join Date: Nov 2015
Location: Bay Area

iTrader: (0)

Ygazis,

My oil pan leaks on my 325xi wagon. I am doing all planning to do it. May I ask you how much did you spent?
Appreciate 0
      12-07-2015, 08:59 AM   #4
igzekyativ
Captain
United_States
110
Rep
756
Posts

Drives: 2007 BMW 328xi Wagon
Join Date: Apr 2011
Location: Asheville, NC

iTrader: (2)

Garage List
2007 BMW 328xi  [0.00]
anyone else want to chime in?

I am also noticing that the shaking/vibrations happens during shifts under light load.

This problem is really ruining my experience with this car...
__________________
2007 328xi Wagon, Black Sapphire Metallic, Sports Package, Cold Weather Package, Rear PDC, Airlift kit with 3P mgmt, CF Akrym rep lip, LCI M-Tech front bumper, LUX Angel Eyes, Black Kidneys, LED Interior Lights, M3 Steering Wheel with Extended Billet DCT Paddles, 19" Staggered VMR 710's
Appreciate 0
      12-10-2015, 08:56 AM   #5
igzekyativ
Captain
United_States
110
Rep
756
Posts

Drives: 2007 BMW 328xi Wagon
Join Date: Apr 2011
Location: Asheville, NC

iTrader: (2)

Garage List
2007 BMW 328xi  [0.00]
bump, this is a really big problem and ruins my driving experience daily...
__________________
2007 328xi Wagon, Black Sapphire Metallic, Sports Package, Cold Weather Package, Rear PDC, Airlift kit with 3P mgmt, CF Akrym rep lip, LCI M-Tech front bumper, LUX Angel Eyes, Black Kidneys, LED Interior Lights, M3 Steering Wheel with Extended Billet DCT Paddles, 19" Staggered VMR 710's
Appreciate 0
      12-11-2015, 09:45 AM   #6
rothwem
Captain
United_States
274
Rep
989
Posts

Drives: 2009 BMW 328i Wagon
Join Date: Apr 2009
Location: Arden, NC

iTrader: (0)

Garage List
2009 BMW 328i  [0.00]
If you think its the transfer case, try getting under the car and pulling the front driveshaft and driving around for a bit. If the problem goes away, then you know you've solved the problem. That will also eliminate the front drivetrain as a source of the problem (axles and driveshaft).
Appreciate 0
      12-11-2015, 10:59 AM   #7
igzekyativ
Captain
United_States
110
Rep
756
Posts

Drives: 2007 BMW 328xi Wagon
Join Date: Apr 2011
Location: Asheville, NC

iTrader: (2)

Garage List
2007 BMW 328xi  [0.00]
I spoke with my mechanic friend and he told me that the problems I describe sound like "harmonic issues" - vibration caused by some loose or broken rotating mass hitting its resonating frequency causing it to shake or vibrate.

I'm thinking the shop may have been on the right track with their assessment that the flex discs (front and back) need to be replaced because they are cracked. The vibrations seem to occur at the same RPMs - 1200-1300, 1700-1800, 2100-2200 (hence the harmonic issue lead) and only under load. This leads me to believe that it could be something with the driveshaft.

I plan to replace the front and back flex discs as well as the center bearing. Hopefully this will solve my problem.
__________________
2007 328xi Wagon, Black Sapphire Metallic, Sports Package, Cold Weather Package, Rear PDC, Airlift kit with 3P mgmt, CF Akrym rep lip, LCI M-Tech front bumper, LUX Angel Eyes, Black Kidneys, LED Interior Lights, M3 Steering Wheel with Extended Billet DCT Paddles, 19" Staggered VMR 710's
Appreciate 0
      12-11-2015, 01:03 PM   #8
YGazis109
Yiannis Gazis
YGazis109's Avatar
United_States
85
Rep
734
Posts

Drives: 2007 328xi
Join Date: Jul 2012
Location: Somers, CT

iTrader: (4)

Garage List
2013 BMW 335is  [0.00]
Quote:
Originally Posted by RL325xi
Ygazis,

My oil pan leaks on my 325xi wagon. I am doing all planning to do it. May I ask you how much did you spent?
I haven't replaced it yet I am going to do it in the spring
__________________
2nd Bimmer - 2013 335is | Alpine White | DCT | Loaded
1st Bimmer - 2007 328xi | SGM | e90 | Premium | Navi | Gloss black trim | Cold | AA headers | 3 stage intake manifold | AA stage 3 tune | AFE stage 2 intake | Cyba Scoops | OEM Blacklines | OEM LCI mtech front bumper | OEM LCI hood | OEM gloss black kidney grills | Orion v4 LED halos with blackout headlights | Valentine 1 Radar | Sport wheel with paddles | kw v1 coilovers | VMR 710 | Continental ExtremeContact DW |
Appreciate 0
      12-11-2015, 03:03 PM   #9
rothwem
Captain
United_States
274
Rep
989
Posts

Drives: 2009 BMW 328i Wagon
Join Date: Apr 2009
Location: Arden, NC

iTrader: (0)

Garage List
2009 BMW 328i  [0.00]
Quote:
Originally Posted by igzekyativ View Post
I spoke with my mechanic friend and he told me that the problems I describe sound like "harmonic issues" - vibration caused by some loose or broken rotating mass hitting its resonating frequency causing it to shake or vibrate.

I'm thinking the shop may have been on the right track with their assessment that the flex discs (front and back) need to be replaced because they are cracked. The vibrations seem to occur at the same RPMs - 1200-1300, 1700-1800, 2100-2200 (hence the harmonic issue lead) and only under load. This leads me to believe that it could be something with the driveshaft.

I plan to replace the front and back flex discs as well as the center bearing. Hopefully this will solve my problem.
Throwing parts at a car is never a good way to go about diagnosing a problem. If there's a way that you can get a mechanic to actually look at the car, that's probably the best way to go.

I wonder, will the car drive with the rear driveshaft pulled? In the 4x4 world, this is a pretty common way to diagnose driveline problems, you pull the front, listen for vibes, if nothing changes, you reinstall the front and pull the rear, lock it in 4wd, then try driving it in "FWD mode" to see if the vibes go away.
Appreciate 0
      12-14-2015, 09:59 AM   #10
igzekyativ
Captain
United_States
110
Rep
756
Posts

Drives: 2007 BMW 328xi Wagon
Join Date: Apr 2011
Location: Asheville, NC

iTrader: (2)

Garage List
2007 BMW 328xi  [0.00]
Quote:
Originally Posted by rothwem View Post
Throwing parts at a car is never a good way to go about diagnosing a problem. If there's a way that you can get a mechanic to actually look at the car, that's probably the best way to go.

I wonder, will the car drive with the rear driveshaft pulled? In the 4x4 world, this is a pretty common way to diagnose driveline problems, you pull the front, listen for vibes, if nothing changes, you reinstall the front and pull the rear, lock it in 4wd, then try driving it in "FWD mode" to see if the vibes go away.
I've taken it to a shop and they were not able to figure it out, but they did tell me that the flex discs needed to be replaced and could be the cause.

Does anyone know if I can run the car without the front or rear driveshafts? I think this would be a great way to diagnose the issue...
__________________
2007 328xi Wagon, Black Sapphire Metallic, Sports Package, Cold Weather Package, Rear PDC, Airlift kit with 3P mgmt, CF Akrym rep lip, LCI M-Tech front bumper, LUX Angel Eyes, Black Kidneys, LED Interior Lights, M3 Steering Wheel with Extended Billet DCT Paddles, 19" Staggered VMR 710's
Appreciate 0
      12-14-2015, 11:31 AM   #11
rothwem
Captain
United_States
274
Rep
989
Posts

Drives: 2009 BMW 328i Wagon
Join Date: Apr 2009
Location: Arden, NC

iTrader: (0)

Garage List
2009 BMW 328i  [0.00]
Quote:
Originally Posted by igzekyativ View Post
I've taken it to a shop and they were not able to figure it out, but they did tell me that the flex discs needed to be replaced and could be the cause.

Does anyone know if I can run the car without the front or rear driveshafts? I think this would be a great way to diagnose the issue...
There was a thread about running with no front driveshaft, I'm not sure about the rear though. Its like 8 bolts though, why not give it a shot?
Appreciate 0
      12-18-2015, 09:09 AM   #12
igzekyativ
Captain
United_States
110
Rep
756
Posts

Drives: 2007 BMW 328xi Wagon
Join Date: Apr 2011
Location: Asheville, NC

iTrader: (2)

Garage List
2007 BMW 328xi  [0.00]
came across this thread... sounds similar...

http://www.m3forum.net/m3forum/showthread.php?t=375693
__________________
2007 328xi Wagon, Black Sapphire Metallic, Sports Package, Cold Weather Package, Rear PDC, Airlift kit with 3P mgmt, CF Akrym rep lip, LCI M-Tech front bumper, LUX Angel Eyes, Black Kidneys, LED Interior Lights, M3 Steering Wheel with Extended Billet DCT Paddles, 19" Staggered VMR 710's
Appreciate 0
      12-21-2015, 08:12 AM   #13
igzekyativ
Captain
United_States
110
Rep
756
Posts

Drives: 2007 BMW 328xi Wagon
Join Date: Apr 2011
Location: Asheville, NC

iTrader: (2)

Garage List
2007 BMW 328xi  [0.00]
so I replaced the front and rear guibo's and the center bearing this weekend. My guibo's didn't look all that worn.

It does look like my transfer box is leaking oil though (looks like the driveshaft/front guibo is spraying oil around... not sure what to do about that though...
Attached Images
   
__________________
2007 328xi Wagon, Black Sapphire Metallic, Sports Package, Cold Weather Package, Rear PDC, Airlift kit with 3P mgmt, CF Akrym rep lip, LCI M-Tech front bumper, LUX Angel Eyes, Black Kidneys, LED Interior Lights, M3 Steering Wheel with Extended Billet DCT Paddles, 19" Staggered VMR 710's

Last edited by igzekyativ; 12-22-2015 at 08:38 AM..
Appreciate 0
      12-22-2015, 08:31 AM   #14
igzekyativ
Captain
United_States
110
Rep
756
Posts

Drives: 2007 BMW 328xi Wagon
Join Date: Apr 2011
Location: Asheville, NC

iTrader: (2)

Garage List
2007 BMW 328xi  [0.00]
ok, so maybe it didn't solve my issue... it seems to have helped but I'm still getting vibrations and shaking... ugh..

maybe its a bad u-joint, or maybe the driveshaft needs to be replaced altogether... could be the front half shafts also..

I guess my next step is to run the car with no front driveshaft.

This should identify if it is the front or rear. If its the front it could be the half shafts, and I will check for play. If its the rear it would have to be the u-joint, and I will buy a new driveshaft. If that doesn't work maybe it's transmission or engine mounts...
__________________
2007 328xi Wagon, Black Sapphire Metallic, Sports Package, Cold Weather Package, Rear PDC, Airlift kit with 3P mgmt, CF Akrym rep lip, LCI M-Tech front bumper, LUX Angel Eyes, Black Kidneys, LED Interior Lights, M3 Steering Wheel with Extended Billet DCT Paddles, 19" Staggered VMR 710's

Last edited by igzekyativ; 12-22-2015 at 09:49 AM..
Appreciate 0
      12-22-2015, 07:28 PM   #15
PatrickO
New Member
2
Rep
17
Posts

Drives: 335xi
Join Date: May 2015
Location: Boston

iTrader: (0)

You can try unplugging that connector on the transfer case motor then go for a ride. If it goes away most likely the clutches inside the case are the issue.
Appreciate 0
      01-12-2016, 07:18 AM   #16
igzekyativ
Captain
United_States
110
Rep
756
Posts

Drives: 2007 BMW 328xi Wagon
Join Date: Apr 2011
Location: Asheville, NC

iTrader: (2)

Garage List
2007 BMW 328xi  [0.00]
Quote:
Originally Posted by PatrickO View Post
You can try unplugging that connector on the transfer case motor then go for a ride. If it goes away most likely the clutches inside the case are the issue.
Is this ok to do? I am starting to think this could be the issue. The only problem is that I would have to drive 10-15 miles this way, would that be ok?

I've removed the front drive-shaft and drove around a lot and the issue continues.

Because I saw a leak from the rear output-shaft seal on the transfer case when I replaced the guibos, I am planing on doing a transfer case fluid flush and replacing the seal this weekend.

I am starting to believe maybe its low on fluid and that's what's causing the issue (clutches are slipping due to low fluid level?). I am thinking this because the issue does not show up until 10-15 miles into a drive (once everything is warm). if it was an unbalanced drive-shaft it should shake regardless of how warm the car is.
__________________
2007 328xi Wagon, Black Sapphire Metallic, Sports Package, Cold Weather Package, Rear PDC, Airlift kit with 3P mgmt, CF Akrym rep lip, LCI M-Tech front bumper, LUX Angel Eyes, Black Kidneys, LED Interior Lights, M3 Steering Wheel with Extended Billet DCT Paddles, 19" Staggered VMR 710's

Last edited by igzekyativ; 01-12-2016 at 07:45 AM..
Appreciate 0
      01-19-2016, 03:04 PM   #17
Jae1989
New Member
0
Rep
8
Posts

Drives: 08 bmw 328xi
Join Date: Jan 2016
Location: Providence, RI

iTrader: (0)

[QUOTE=igzekyativ;19202243]Is this ok to do? I am starting to think this could be the issue. The only problem is that I would have to drive 10-15 miles this way, would that be ok?

I've removed the front drive-shaft and drove around a lot and the issue continues.

Because I saw a leak from the rear output-shaft seal on the transfer case when I replaced the guibos, I am planing on doing a transfer case fluid flush and replacing the seal this weekend.

I am starting to believe maybe its low on fluid and that's what's causing the issue (clutches are slipping due to low fluid level?). I am thinking this because the issue does not show up until 10-15 miles into a drive (once everything is warm). if it was an unbalanced drive-shaft it should shake regardless of how warm the car is.[/QUOTE

I have a 08 328xi with the same problem. Can you give an update any luck?
Appreciate 0
      01-19-2016, 03:16 PM   #18
igzekyativ
Captain
United_States
110
Rep
756
Posts

Drives: 2007 BMW 328xi Wagon
Join Date: Apr 2011
Location: Asheville, NC

iTrader: (2)

Garage List
2007 BMW 328xi  [0.00]
waiting on the supplies for the fluid exchange... will post updates later. the car is sitting up on jack stands until I can perform all the services.

I did do an adaptive transmission reset, and have new wheels and tires on the way
__________________
2007 328xi Wagon, Black Sapphire Metallic, Sports Package, Cold Weather Package, Rear PDC, Airlift kit with 3P mgmt, CF Akrym rep lip, LCI M-Tech front bumper, LUX Angel Eyes, Black Kidneys, LED Interior Lights, M3 Steering Wheel with Extended Billet DCT Paddles, 19" Staggered VMR 710's
Appreciate 0
      01-19-2016, 03:24 PM   #19
Jae1989
New Member
0
Rep
8
Posts

Drives: 08 bmw 328xi
Join Date: Jan 2016
Location: Providence, RI

iTrader: (0)

Thanks good luck.
Appreciate 0
      02-02-2016, 09:33 AM   #20
igzekyativ
Captain
United_States
110
Rep
756
Posts

Drives: 2007 BMW 328xi Wagon
Join Date: Apr 2011
Location: Asheville, NC

iTrader: (2)

Garage List
2007 BMW 328xi  [0.00]
Ok, finally completed the transfer case fluid flush and replaced the o ring and seal around the rear output shaft. Turns out the leak was coming from the o ring on the output shaft,and not from the seal behind it. I replaced the seal anyways.

Did not solve the shaking (need more time to see if the leak is still there). I am going to order a refurbished rear driveshaft, next. If this doesn't work, I don't know what to do.
__________________
2007 328xi Wagon, Black Sapphire Metallic, Sports Package, Cold Weather Package, Rear PDC, Airlift kit with 3P mgmt, CF Akrym rep lip, LCI M-Tech front bumper, LUX Angel Eyes, Black Kidneys, LED Interior Lights, M3 Steering Wheel with Extended Billet DCT Paddles, 19" Staggered VMR 710's
Appreciate 0
      02-03-2016, 01:51 AM   #21
Jae1989
New Member
0
Rep
8
Posts

Drives: 08 bmw 328xi
Join Date: Jan 2016
Location: Providence, RI

iTrader: (0)

Quote:
Originally Posted by igzekyativ View Post
Ok, finally completed the transfer case fluid flush and replaced the o ring and seal around the rear output shaft. Turns out the leak was coming from the o ring on the output shaft,and not from the seal behind it. I replaced the seal anyways.

Did not solve the shaking (need more time to see if the leak is still there). I am going to order a refurbished rear driveshaft, next. If this doesn't work, I don't know what to do.
I took mine to the dealer today and they told me I need a transfer case actuator. I was quoted $1800 for the job. I'll probably buy one from eBay for $370 and install it myself since is not so difficult to get out. Only thing I don't know is if it has to be program after. I will ask that tomorrow when I go pick up the car and see how much they charge for that. Hope this help
Appreciate 0
      02-03-2016, 07:48 AM   #22
igzekyativ
Captain
United_States
110
Rep
756
Posts

Drives: 2007 BMW 328xi Wagon
Join Date: Apr 2011
Location: Asheville, NC

iTrader: (2)

Garage List
2007 BMW 328xi  [0.00]
Quote:
Originally Posted by Jae1989 View Post
I took mine to the dealer today and they told me I need a transfer case actuator. I was quoted $1800 for the job. I'll probably buy one from eBay for $370 and install it myself since is not so difficult to get out. Only thing I don't know is if it has to be program after. I will ask that tomorrow when I go pick up the car and see how much they charge for that. Hope this help
how much was your diagnostic charge? and please let me know if it needs to be programmed.
__________________
2007 328xi Wagon, Black Sapphire Metallic, Sports Package, Cold Weather Package, Rear PDC, Airlift kit with 3P mgmt, CF Akrym rep lip, LCI M-Tech front bumper, LUX Angel Eyes, Black Kidneys, LED Interior Lights, M3 Steering Wheel with Extended Billet DCT Paddles, 19" Staggered VMR 710's
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 05:48 PM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST