E90Post
 


Extreme Power House
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Suspension | Brakes | Chassis > H&R Springs/Sway Bars AND PROBLEMS



Reply
 
Thread Tools Search this Thread
      10-16-2007, 09:06 AM   #1
!Xoible
Banned
United_States
555
Rep
46,037
Posts

 
Drives: ....
Join Date: Nov 2006
Location: .

iTrader: (4)

Garage List
2008 M3  [3.50]
2007 335i  [4.50]
2008 528i  [4.00]
2006 Infiniti - G35 ...  [4.00]
H&R Springs/Sway Bars AND PROBLEMS

i dont know how much you guys can help, but if someone's having my same symptoms please post your experience.

Basically after i got my H&R springs the car ran normally, then i installed UUC sway bars.
once i did that the car started pulling HARD, like real HARD, in the direction of the last turn i took. (ie if i make a right turn it will pull to the right until i make a u-turn or a left turn, then it will pull left until the next right.. etc)

the car basically rarely goes straight now. I did an alignment, but i did not help that problem at all. any ideas?

================================================== ====
UPDATE
this thread explains the problems that i had with this install despite my initial excitement about it
http://www.e90post.com/forums/showthread.php?t=89909

First of all i realized that the sway bar tie rod was not tightened, so it broke.

But the car still pulled to left and right, Eric@SPP very kindly and generously helped me lift it, and see that the sway bar was installed upside down and that it was hitting my steering rods, so i was able to turn the steering wheel more, but the car still pulled. Thanks to Eric@SPP for investing time in this without even being compensated for his time/effort.

My next thought was to take out my springs and take the car back to stock. Long Tran offered to take me to an alignment shop that he knows of to help me out. So i drove to his place, and there he realized that the springs were not seated correctly at the bottom, and they were not seated correctly at the top either, and they were TWISTING and moving hard every time i turned my steering wheel.

Even bushings were installed upside down, everything was messed up, it's not even funny.

Long Tran re-installed my springs, and replaced the broken parts and now my car runs nicely again. no popping noises when i turn, no extra bounciness, no pulls. car's a 335 again. It's worth mentioning that Long did not charge me for spending several hours trying to figure out my problem + time on the phone + time online.

I still have to re-install my sway bar which will happen at SPP most likely.

I got pix of all that, but they're in Long's camera. I will put a picture how the front sway should be installed.

The worst of all is that the person who installed all this doesnt bother to PM me or reply to my IM's.

I am saddened to have to post this update, and i already regret it. I am already sorry to have to post this, but I expected Charlie to act a bit more responsibly, especially that he advertises himself as a professional.

Charlie is a great fun guy to work with, but i think he should realize this shit can get people killed and he shouldnt rush his work. I hope he learns that during his UTI training.

Last edited by !Xoible; 10-26-2007 at 11:16 PM.
Appreciate 0
      10-16-2007, 11:12 AM   #2
Crimson92
Smiling Politely
Crimson92's Avatar
United_States
300
Rep
28,647
Posts

 
Drives: Like a boss
Join Date: Jun 2007
Location: Whales Vagina

iTrader: (3)

holy crap, Im about to do the same set up. Can someone chime in on this?
__________________
Quote:
Some people are like slinkies...not really good for much but you can't help but smile when you see one tumble down the stairs"
Appreciate 0
      10-16-2007, 11:15 AM   #3
!Xoible
Banned
United_States
555
Rep
46,037
Posts

 
Drives: ....
Join Date: Nov 2006
Location: .

iTrader: (4)

Garage List
2008 M3  [3.50]
2007 335i  [4.50]
2008 528i  [4.00]
2006 Infiniti - G35 ...  [4.00]
man i got it checked by like 3 people, they cant find anything wrong.

if i dont hear from people here im going to take off sways first, see if that fixes it, then take off springs and see.
the thing is it only happened AFTER sways, but it doesnt make sense whatsoever for sways to cause it
Appreciate 0
      10-16-2007, 11:20 AM   #4
Crimson92
Smiling Politely
Crimson92's Avatar
United_States
300
Rep
28,647
Posts

 
Drives: Like a boss
Join Date: Jun 2007
Location: Whales Vagina

iTrader: (3)

hmmm judging from your first post is sounds like something is loose and is shifting whenever you make a sharp turn. I would double check the sways. Maybe theyre in wrong. Also check the the upper mounts and make sure the spring is seated properly, my old celica had this problem
__________________
Quote:
Some people are like slinkies...not really good for much but you can't help but smile when you see one tumble down the stairs"
Appreciate 0
      10-16-2007, 11:35 AM   #5
!Xoible
Banned
United_States
555
Rep
46,037
Posts

 
Drives: ....
Join Date: Nov 2006
Location: .

iTrader: (4)

Garage List
2008 M3  [3.50]
2007 335i  [4.50]
2008 528i  [4.00]
2006 Infiniti - G35 ...  [4.00]
Quote:
Originally Posted by Crimson92 View Post
hmmm judging from your first post is sounds like something is loose and is shifting whenever you make a sharp turn. I would double check the sways. Maybe theyre in wrong. Also check the the upper mounts and make sure the spring is seated properly, my old celica had this problem
something is loose in steering or suspension u think?
Appreciate 0
      10-16-2007, 11:41 AM   #6
Crimson92
Smiling Politely
Crimson92's Avatar
United_States
300
Rep
28,647
Posts

 
Drives: Like a boss
Join Date: Jun 2007
Location: Whales Vagina

iTrader: (3)

Well I haven't put anything in yet on my e92, but I'm assuming the sway install would be very similar to my 350z. Im sure its a suspension problem not steering.

1.check make sure the sway bar is installed correctly, from what I understand some people have managed to put it in backwards.

2. check for any loose bolts.

3. check that all parts that came off when installing springs were put back in, save for stock springs of course.

4. make sure that the springs are seated properly. Most shocks have an indentation to where the spring should sit.

5. double make sure that the shock mounts are tightened after checking the spring position.

6. if all else fails, try tracing your problem by taking off the sway first and installing oem, if problem persists, move on to the springs. You should have an answer my this point.

7. if nothing works ---->

"edit" have you aligned the car yet? nvm yes you did. and by any chance do you have a popping sound when cutting the wheel from left to right?
__________________
Quote:
Some people are like slinkies...not really good for much but you can't help but smile when you see one tumble down the stairs"
Appreciate 0
      10-16-2007, 11:43 AM   #7
Chowbow
pew pew
80
Rep
6,737
Posts

 
Drives: 三三五i
Join Date: Aug 2007
Location: CA

iTrader: (5)

Garage List
If it only did it after sway bar install then it's most likely something wrong with that installation I guess? Seen plenty of people with setups similar to this without issues. Did the installation go well? DIY or shop?
__________________
CSL replicas are now CSL counterfeits. Jesus saves, like Valentine1.
Appreciate 0
      10-16-2007, 12:23 PM   #8
flukey
Go big or go home!
United_States
17
Rep
948
Posts

 
Drives: E90 335xi
Join Date: Jun 2007
Location: Iowa

iTrader: (9)

http://www.e90post.com/forums/showthread.php?t=86896

check this thread out... sounds like op had similar problems... read the later posts, people offer suggestions
Appreciate 0
      10-16-2007, 12:31 PM   #9
thammel
New Member
0
Rep
23
Posts

 
Drives: 2007 335i e90 6MT
Join Date: Jul 2007
Location: maryland

iTrader: (1)

Did you do the install?

Hey Chowbow,

Did you do the installation of the sway bar(s)? Did you install both a front one and rear one? I think the others here are right on line - but my inclination is not that something is loose but rather too tight, hung up, or installed incorrectly (upside down).

I plan to do this - front and rear installation - myself, and am aware of the need to lower the rear subframe to remove and install rear sway bars. If you did this yourself, I'm sure many of us would appreciate a detailed write-up of lowering the rear subframe.

Thanks,
Tom
Appreciate 0
      10-16-2007, 12:34 PM   #10
!Xoible
Banned
United_States
555
Rep
46,037
Posts

 
Drives: ....
Join Date: Nov 2006
Location: .

iTrader: (4)

Garage List
2008 M3  [3.50]
2007 335i  [4.50]
2008 528i  [4.00]
2006 Infiniti - G35 ...  [4.00]
Quote:
Originally Posted by Crimson92 View Post
Well I haven't put anything in yet on my e92, but I'm assuming the sway install would be very similar to my 350z. Im sure its a suspension problem not steering.

1.check make sure the sway bar is installed correctly, from what I understand some people have managed to put it in backwards.

2. check for any loose bolts.

3. check that all parts that came off when installing springs were put back in, save for stock springs of course.

4. make sure that the springs are seated properly. Most shocks have an indentation to where the spring should sit.

5. double make sure that the shock mounts are tightened after checking the spring position.

6. if all else fails, try tracing your problem by taking off the sway first and installing oem, if problem persists, move on to the springs. You should have an answer my this point.

7. if nothing works ---->

"edit" have you aligned the car yet? nvm yes you did. and by any chance do you have a popping sound when cutting the wheel from left to right?
i do have a popping sound. it was much worse when my tie rod was bent, but i still have it, yes
Appreciate 0
      10-16-2007, 12:35 PM   #11
!Xoible
Banned
United_States
555
Rep
46,037
Posts

 
Drives: ....
Join Date: Nov 2006
Location: .

iTrader: (4)

Garage List
2008 M3  [3.50]
2007 335i  [4.50]
2008 528i  [4.00]
2006 Infiniti - G35 ...  [4.00]
Quote:
Originally Posted by Chowbow View Post
If it only did it after sway bar install then it's most likely something wrong with that installation I guess? Seen plenty of people with setups similar to this without issues. Did the installation go well? DIY or shop?
not a shop... a board member here
Appreciate 0
      10-16-2007, 12:38 PM   #12
Crimson92
Smiling Politely
Crimson92's Avatar
United_States
300
Rep
28,647
Posts

 
Drives: Like a boss
Join Date: Jun 2007
Location: Whales Vagina

iTrader: (3)

if you still have the popping its your springs
__________________
Quote:
Some people are like slinkies...not really good for much but you can't help but smile when you see one tumble down the stairs"
Appreciate 0
      10-16-2007, 12:56 PM   #13
!Xoible
Banned
United_States
555
Rep
46,037
Posts

 
Drives: ....
Join Date: Nov 2006
Location: .

iTrader: (4)

Garage List
2008 M3  [3.50]
2007 335i  [4.50]
2008 528i  [4.00]
2006 Infiniti - G35 ...  [4.00]
Quote:
Originally Posted by Crimson92 View Post
if you still have the popping its your springs
how can i make sure it's the springs? i can get coilovers today if i can be 100% sure it's my springs
Appreciate 0
      10-16-2007, 12:59 PM   #14
Crimson92
Smiling Politely
Crimson92's Avatar
United_States
300
Rep
28,647
Posts

 
Drives: Like a boss
Join Date: Jun 2007
Location: Whales Vagina

iTrader: (3)

Well like I said if you cut your wheel left to right and it pops its the springs not seating properly, by this time you have probably already damaged your upper mount
__________________
Quote:
Some people are like slinkies...not really good for much but you can't help but smile when you see one tumble down the stairs"
Appreciate 0
      10-16-2007, 01:00 PM   #15
!Xoible
Banned
United_States
555
Rep
46,037
Posts

 
Drives: ....
Join Date: Nov 2006
Location: .

iTrader: (4)

Garage List
2008 M3  [3.50]
2007 335i  [4.50]
2008 528i  [4.00]
2006 Infiniti - G35 ...  [4.00]
Quote:
Originally Posted by Crimson92 View Post
Well like I said if you cut your wheel left to right and it pops its the springs not seating properly
okay, that's awesome to know man. thanks a lot
Appreciate 0
      10-16-2007, 01:05 PM   #16
Crimson92
Smiling Politely
Crimson92's Avatar
United_States
300
Rep
28,647
Posts

 
Drives: Like a boss
Join Date: Jun 2007
Location: Whales Vagina

iTrader: (3)

check the edit as well
__________________
Quote:
Some people are like slinkies...not really good for much but you can't help but smile when you see one tumble down the stairs"
Appreciate 0
      10-16-2007, 01:07 PM   #17
!Xoible
Banned
United_States
555
Rep
46,037
Posts

 
Drives: ....
Join Date: Nov 2006
Location: .

iTrader: (4)

Garage List
2008 M3  [3.50]
2007 335i  [4.50]
2008 528i  [4.00]
2006 Infiniti - G35 ...  [4.00]
Quote:
Originally Posted by Crimson92 View Post
Well like I said if you cut your wheel left to right and it pops its the springs not seating properly, by this time you have probably already damaged your upper mount
Appreciate 0
      10-16-2007, 01:10 PM   #18
Crimson92
Smiling Politely
Crimson92's Avatar
United_States
300
Rep
28,647
Posts

 
Drives: Like a boss
Join Date: Jun 2007
Location: Whales Vagina

iTrader: (3)

Yea I know, gotta be careful with suspension...one bad thing can ruin alot of things
__________________
Quote:
Some people are like slinkies...not really good for much but you can't help but smile when you see one tumble down the stairs"
Appreciate 0
      10-16-2007, 01:23 PM   #19
Chowbow
pew pew
80
Rep
6,737
Posts

 
Drives: 三三五i
Join Date: Aug 2007
Location: CA

iTrader: (5)

Garage List
Quote:
Originally Posted by thammel View Post
Hey Chowbow,

Did you do the installation of the sway bar(s)? Did you install both a front one and rear one? I think the others here are right on line - but my inclination is not that something is loose but rather too tight, hung up, or installed incorrectly (upside down).

I plan to do this - front and rear installation - myself, and am aware of the need to lower the rear subframe to remove and install rear sway bars. If you did this yourself, I'm sure many of us would appreciate a detailed write-up of lowering the rear subframe.

Thanks,
Tom
Tom,

I have not installed my rear sway bar yet. With my shock/spring install, the car corners flat and quite neutral honestly. I'm going to wait and get on the track first before I decide if I'm going to install it or not. I will not DIY it, dropping subframes on a garage floor is a PITA in any car. It's gonna go to a shop for installation. If you have enough jacks, jackstands, and people helping out then it shouldn't be too bad.

If you're hearing popping from the springs, then the rubber mounts which go on the bottom / top of springs may not be installed which can be a big issue. I'd figure that any good installer would not miss something that obvious though.
__________________
CSL replicas are now CSL counterfeits. Jesus saves, like Valentine1.
Appreciate 0
      10-16-2007, 01:31 PM   #20
Crimson92
Smiling Politely
Crimson92's Avatar
United_States
300
Rep
28,647
Posts

 
Drives: Like a boss
Join Date: Jun 2007
Location: Whales Vagina

iTrader: (3)

^+1 I wouldn't recommend anyone trying to drop the subframe alone in the garage.

and Im pretty sure mantis' problem is with his springs and something has to be missing in there or something is loose.
__________________
Quote:
Some people are like slinkies...not really good for much but you can't help but smile when you see one tumble down the stairs"
Appreciate 0
      10-16-2007, 01:34 PM   #21
!Xoible
Banned
United_States
555
Rep
46,037
Posts

 
Drives: ....
Join Date: Nov 2006
Location: .

iTrader: (4)

Garage List
2008 M3  [3.50]
2007 335i  [4.50]
2008 528i  [4.00]
2006 Infiniti - G35 ...  [4.00]
Quote:
Originally Posted by Crimson92 View Post
^+1 I wouldn't recommend anyone trying to drop the subframe alone in the garage.

and Im pretty sure mantis' problem is with his springs and something has to be missing in there or something is loose.
goddamn, im taking it to shop today...
Appreciate 0
      10-16-2007, 02:57 PM   #22
Crimson92
Smiling Politely
Crimson92's Avatar
United_States
300
Rep
28,647
Posts

 
Drives: Like a boss
Join Date: Jun 2007
Location: Whales Vagina

iTrader: (3)

Manits let us know how it goes
__________________
Quote:
Some people are like slinkies...not really good for much but you can't help but smile when you see one tumble down the stairs"
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:32 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST